+ Responder ao Tópico



  1. #1

    Padrão Problema - SSH sem senha

    Boa tarde pessoal.
    Eu realizei o procedimento necessário para a chave de autenticação e copiei a chave pública, com o nome authorized_keys, para a pasta /home/usuario/.ssh do servidor remoto.

    Em uma máquina com o RH9 porém em outra com o FC4 não estou conseguindo... continua pedindo a senha.

    Alguém poderia me ajudar?

  2. #2

    Padrão

    verifica a conf do server ssh se ele permite o uso de chaves



  3. #3

    Padrão

    Citação Postado originalmente por 1c3m4n Ver Post
    verifica a conf do server ssh se ele permite o uso de chaves
    seria +- por aqui


    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    PasswordAuthentication yes

    Falow ...

  4. #4

    Padrão

    Valew pela ajuda de todos... consegui fazer funcionar.

    Precisei descomentar as seguintes linhas no conf do ssh

    RSAAuthentication yes
    PubkeyAuthentication yes