+ Responder ao Tópico



  1. Quebrando cabeça com o SquidGuard!!!!
    (Fez uma semana que tento resolver isso e nada)
    Bom Dia pessoal,

    É o seguinte....

    Tenho o squid instalado e instalei o SquidGuard para negar o acesso aos sites que estiverem na Blacklist. Instalei o BD Berkeley que eram um dos pre-requisitos para instalar o squidGuard e depois instalei o SquidGuard 1.2.0... Até aí tudo ok!!!! Criei o squidguard.conf dentro do diretorio do SquidGuard e configurecom muita atenção. Fui no conf do squid e adicionei a seguinte linha redirect_program /usr/local/bin/squidGuard -C /usr/local/squidGuard/squidguard.conf. Baixei a BlackList no site Shalla's URL Blacklist e terminei a configuração. Fiz a chama do squid, iniciou blz.... Dei um ps ax para ver se tinha iniciado o squidGuard e lá estava ele.... Bem, fui fazer o teste acessando uma página que estava no blacklist, para minha surpresa, consegui acessar o site normalmente. Vi que o squidGuard não estava bloqueando nada. não sei o que fazer.... Vou postar aqui o meu squidguard.conf,o qual tenho plena certeza que não está errado para vcs verem se acham algum erro:

    ## Conf do SquidGuard
    #
    // Define a pasta onde estão as blacklists
    dbhome /etc/squid/squidguard/blacklists
    // Define onde serão armazenados os logs do SquidGuard
    logdir /var/log/squidguard
    // Define a rede do órgão
    src orgao {
    ip 192.168.254.0/24
    }
    // Define o caminho das listas negras
    dest ads {
    domainlist ads/domains
    urllist ads/urls
    # expressionlist ads/expressions
    # abaixo coloque o ip do servidor web onde está armazenada a página que
    # exibirá a mensagem de erro
    redirect http://localhost/index.html
    }
    dest adult {
    domainlist adult/domains
    urllist adult/urls
    # expressionlist adult/expressions
    # abaixo coloque o ip do servidor web onde está armazenada a página que
    # exibirá a mensagem de erro
    redirect http://localhost/index.html
    }
    // Nega acesso às listas declaradas
    acl {
    orgao {
    pass !adult !ads all
    }
    // Indica a página de erro
    default {
    pass none
    # abaixo coloque o ip do servidor web onde está armazenada a página que
    # exibirá a mensagem de erro
    redirect http://localhost/index.html
    }
    }

    Quem souber como resolver esse mistério, por favor me ajude.....

    meu log está apresentando essas mensagens:

    2007-01-20 10:26:49 [5808] New setting: dbhome: /usr/local/squidGuard/db/BL
    2007-01-20 10:26:49 [5808] squidGuard: setting dbhome is defined in configfile /usr/local/squidGuard/squidGuard.conf
    2007-01-20 10:26:49 [5808] going into emergency mode

    Estou precisando muito....

    Obrigado

  2. Como está as permissões do asquiuvo ...

    dbhome /etc/squid/squidguard/blacklists

    Falow ...



  3. Citação Postado originalmente por rootmaster Ver Post
    Como está as permissões do asquiuvo ...

    dbhome /etc/squid/squidguard/blacklists

    Falow ...

    Olá Amigo,

    Ainda bem que apareceu alguém querendo ajudar....

    Está permissão total, dei um chmod 777 BL/

    Lembrando que meu Dbhome agora está em /usr/local/squidGuard/db/BL e eu já muidei lá no squidGuard.conf.

    Dou o comando squidGuard -C all para ativar a blacklist, mas fica horas lá e não faz nada.






Tópicos Similares

  1. Respostas: 2
    Último Post: 25-08-2014, 10:28
  2. Respostas: 8
    Último Post: 26-01-2014, 17:34
  3. Mais um exercicio ae gente para me ajudar pf
    Por hngoff no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 27-09-2011, 21:29
  4. Respostas: 2
    Último Post: 28-01-2010, 07:25
  5. Respostas: 2
    Último Post: 21-11-2007, 08:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L