Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal, varri o fórum atrás dessa pergunta mas não foi válida.
    Bom eu estou com uma conexão compartilhada em casa.


    Servidor = P233

    ppp0 - Speedy
    eth1 - Gateway


    Estação
    IP - 192.168.0.171

    Não estou conseguindo fazer o nat corretamente porque ele não pega ID Alto em nenhum dos 2 programas.

    ### +++++++++++++++++++++++++
    ### Regras NAT
    ### +++++++++++++++++++++++++
    ### Liberar acesso externo às portas de Mail(25), Pop-3(110), Dns(53(tcp e udp)),
    ### Https (443), Gmail (465,955) MSN (1863), RECEITANET (3456,) CONECTIVIDADE SOCIAL (2631)
    ### Serasa-Luiza (3007)

    # $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 20,21,22,25,53,80,110,443,465,995,1479,2083,2631,3007,3456,4661,4662,4711,38438 -j MASQUERADE
    echo " Regra acima comentada porque foi especificado mais que 15 portas"

    $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 20,21,22,25,53,80,110,443 -j MASQUERADE

    $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 465,995,1479,2083,2631,3007,3456,4661,4662,4711,38438 -j MASQUERADE
    echo "# Conexao Compartilhada via NAT: "

    # E M U L E
    $IPTABLES -t nat -A PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 4661 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 4662 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p udp -s 192.168.0.171 -d 0/0 --dport 4661 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p udp -s 192.168.0.171 -d 0/0 --dport 4662 -j ACCEPT


    # A Z U R E U S
    $IPTABLES -t nat -I PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 61540 -j ACCEPT

    Num vai.

  2. Citação Postado originalmente por spyderlinux Ver Post
    Pessoal, varri o fórum atrás dessa pergunta mas não foi válida.
    Bom eu estou com uma conexão compartilhada em casa.


    Servidor = P233

    ppp0 - Speedy
    eth1 - Gateway


    Estação
    IP - 192.168.0.171

    Não estou conseguindo fazer o nat corretamente porque ele não pega ID Alto em nenhum dos 2 programas.

    ### +++++++++++++++++++++++++
    ### Regras NAT
    ### +++++++++++++++++++++++++
    ### Liberar acesso externo às portas de Mail(25), Pop-3(110), Dns(53(tcp e udp)),
    ### Https (443), Gmail (465,955) MSN (1863), RECEITANET (3456,) CONECTIVIDADE SOCIAL (2631)
    ### Serasa-Luiza (3007)

    # $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 20,21,22,25,53,80,110,443,465,995,1479,2083,2631,3007,3456,4661,4662,4711,38438 -j MASQUERADE
    echo " Regra acima comentada porque foi especificado mais que 15 portas"

    $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 20,21,22,25,53,80,110,443 -j MASQUERADE

    $IPTABLES -t nat -A POSTROUTING -o $WAN -m multiport -p tcp --dports 465,995,1479,2083,2631,3007,3456,4661,4662,4711,38438 -j MASQUERADE
    echo "# Conexao Compartilhada via NAT: "

    # E M U L E
    $IPTABLES -t nat -A PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 4661 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 4662 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p udp -s 192.168.0.171 -d 0/0 --dport 4661 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -i eth1 -p udp -s 192.168.0.171 -d 0/0 --dport 4662 -j ACCEPT


    # A Z U R E U S
    $IPTABLES -t nat -I PREROUTING -i eth1 -p tcp -s 192.168.0.171 -d 0/0 --dport 61540 -j ACCEPT

    Num vai.
    O emule precisa fazer uma conexão de tuneling entre o servidor e você ...
    quando ele não tem acesso a máquina solicitante da conexão ... ele fica com ID LOW,
    pois o ip que ele encontra é o ip do firewall

    basta redirecionar as portas do emule, do firewall para sua máquina ...


    EX:

    # emule
    /sbin/iptables -t nat -A PREROUTING -p tcp -d 200.200.100.100 --dport 4661 -j DNAT --to 192.168.0.250:4661

    /sbin/iptables -t nat -A PREROUTING -p udp -d 200.200.100.100 --dport 4672 -j DNAT --to 192.168.0.250:4662

    ou

    /sbin/iptables -t nat -A PREROUTING -p tcp -i ppp0 --dport 4661 -j DNAT --to 192.168.0.250:4662

    /sbin/iptables -t nat -A PREROUTING -p udp -i ppp0 --dport 4672 -j DNAT --to 192.168.0.250:4662

    só não lembro se as portas são essas mesmo ...

    falow ..



  3. [QUOTE=
    /sbin/iptables -t nat -A PREROUTING -p tcp -i ppp0 --dport 4661 -j DNAT --to 192.168.0.250:4662

    /sbin/iptables -t nat -A PREROUTING -p udp -i ppp0 --dport 4672 -j DNAT --to 192.168.0.250:4662
    só não lembro se as portas são essas mesmo ...
    falow ..
    [/QUOTE]

    Apenas uma questão,
    Independente de ser windows a máquina que irá receber posso colocar o :4662

  4. Sim , sem problemas ... o que é levado em conta nessa regra é apenas as conexões
    TCP e UDP, independente do sistema ser windos , OS2, Solares , etc ...
    se comunicou através de TCP/IP funciona ....


    Falow ...



  5. Hum, eu vou testar isso em casa quando chegar.

    Valeu !






Tópicos Similares

  1. Ping alto em toda a rede.
    Por marciel2008 no fórum Redes
    Respostas: 17
    Último Post: 19-08-2009, 00:52
  2. Ping Alto em Rede Interna - Estranho
    Por fnandoicatel no fórum Redes
    Respostas: 3
    Último Post: 28-11-2008, 12:23
  3. Processamento alto em alguns momentos...
    Por ricardofjayme no fórum Redes
    Respostas: 4
    Último Post: 10-07-2008, 22:32
  4. Tempo de resp. alto em p2p
    Por fanestor no fórum Redes
    Respostas: 0
    Último Post: 08-11-2005, 09:11
  5. Problemas de ping alto em POP
    Por nataniel no fórum Redes
    Respostas: 2
    Último Post: 05-09-2005, 08:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L