+ Responder ao Tópico



  1. #1

    Padrão Problema com o squid

    Bom dia pessoal.
    Estou configurando um proxy transparente porém estou tendo alguns problemas.

    No squid.conf eu descomentei as seguintes linhas:

    httpd_accel_port 80
    httpd_accel_host virtual
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Depois no iptables, que por sinal está rodando na mesma máquina do squid, eu coloquei a seguinte regra:

    /sbin/iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Onde eth0 é a interface da sub-rede interna (192.168.3.0/24).

    O problema é que quando eu tento acessar algum site aparece o erro NO DNS RECORD.

    Alguém poderia me dar uma ajuda?

  2. #2
    wrochal
    Visitante

    Padrão

    Caro,

    Isso esta parecendo problema de DNS.

    Abraços,



  3. #3

    Padrão

    Citação Postado originalmente por andunno Ver Post
    Bom dia pessoal.
    Estou configurando um proxy transparente porém estou tendo alguns problemas.

    No squid.conf eu descomentei as seguintes linhas:

    httpd_accel_port 80
    httpd_accel_host virtual
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Depois no iptables, que por sinal está rodando na mesma máquina do squid, eu coloquei a seguinte regra:

    /sbin/iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Onde eth0 é a interface da sub-rede interna (192.168.3.0/24).

    O problema é que quando eu tento acessar algum site aparece o erro NO DNS RECORD.

    Alguém poderia me dar uma ajuda?
    Aparentemente suas regras estao certas.... mas faz o seguinte... vai no /etc/resolv.conf e verifica seu dns, depois vai nos logs do squid ( access.log ) e verifica se está dando erro de DNS, se estiver, tenta iniciar o squid com o comando squid -D ( esse comando desabilita teste de DNS ) pode ser q resolva, ja tive um problema parecido e resolvi assim.

    Faz ae e posta o result...

    VLw

  4. #4

    Padrão

    /sbin/iptables -t nat -A PREROUTING -s 192.168.0.0/24 -p tcp --dport 80 -j DNAT --to 192.168.0.1:3128


    tenta usar assim...



  5. #5

    Padrão

    Kra pra v se o squid ta com pau da esse comando:

    squid -d9

    vai ser criado um arquivo chamado squid.run ai se tive algum erro este script vai te mostra, + como ja disse a galera ai o problema esta em seu DNS, ligue em seu provedor e peça os DNS e coloque em /etc/resolv.conf q funfa file...