+ Responder ao Tópico



  1. #1

    Padrão OPENVPN as vezes não se reconecta

    Pessoal, aqui aonde eu trabalho fizemos uma VPN que se conecta com cada cliente, para acessar os clientes em um ambiente mais seguro, pois bem, mas durante a noite o Servidor aqui da empresa é desligado com isso derrubando todas as VPN`s que temos com os clientes... na parte da manha ligamos os servidores e boa as conexões se reestabelece belezinha, mas a cada semana, acontece um pipoco tem dois servidores que não se reconectam, tendo necessidade de pedir para o cliente ir e reiniciar o servidor... ai sim ele se reconecta,
    O que pode ser ? será que é algum problema de firewall ?? eu acho que não, ou mais porvavel ser com o OPENVPN, ?
    Estou usando o Fedora 5 como evidencia nesses dois Servidores
    Vlw... Pessoal, muito oBrigado por vossa Atenção

  2. #2
    wrochal
    Visitante

    Exclamation

    Caro,

    Em ambas tente colocar a seguinte função:

    ping 15

    Envia um ping a cada 15 segundos, caso não responda o mesmo reconecta.

    Abraços,




  3. #3

    Padrão

    Wrochal, em todas as VPN que o pessoal montou eles colocaram esses dois comandos:

    ping 15
    ping-restart 45

  4. #4
    wrochal
    Visitante

    Padrão

    Então veja se o firewall não pode estar bloqueando algo.

    abraços,



  5. #5

    Padrão

    Pelo que vi para o IP aqui da empresa esta liberado todas as portar e para a interface TUN+ tbm esta, mas só uma dulvida pode acontecer de um Firewall para o outro a Fedora se coportar diferente, pois por padrão o Firewall é o mesmo para todos os servidores...
    Tem algum coisa no Fedora 5 que faz bloqueios automaticos ?

  6. #6
    wrochal
    Visitante

    Padrão

    Caro,

    Tente ver se o SELinux esta ativado.

    Abraços,



  7. #7

    Padrão

    POr favor aonde posso ver se o SELinux, esta ativado... Obrigado

  8. #8
    wrochal
    Visitante

    Padrão

    Veja ai:

    How to disable SELinux

    Abraços,



  9. #9

    Padrão

    Ok, Obrigado por vossa atenção, vou fazer os testes aqui... tendo algum resultado eu posto aqui no Forum...

  10. #10

    Padrão

    Bem, pode ser que você esteja bloqueando protocolo ICMP em uma das pontas, o quê pode estar gerando este problema. Pode ocorrer bastante do status da conexão estar bloqueado. Tente inserir as seguintes regras de firewall:

    Código :
    # iptables -t filter -I FORWARD -i tun0 -j ACCEPT
    # iptables -t filter -I INPUT -i tun0 -j ACCEPT

    Resolveu pra mim quando eu tive um problema similar ao seu.