+ Responder ao Tópico



  1. #1
    fabricioigor
    Visitante

    Padrão Controle de banda por horário hotspot

    Ola gostaria de fazer controle de banda por horario mudando os profile user do hotspot, eu pensei em fazer um script e colocar no scheduler nos horarios determinados porem quando coloco o comando no script ele nao altera o rate-limit, mas quando uso comando via telnet funciona

    comando
    rate do profile 32k/64k q eu quero almentar

    /ip hotspot user profile set 3 rate-limit="48k/96k"

    to com um funcionario a noite responsavel so pra fazer isso toda 22:00 ele entra no telnet e executa esse comando, eu queria deixar isso altomatizado

    minha versao do MK é 2.9.27

  2. #2

    Padrão

    Não entendi muito bem como vc entra pelo telnet e muda, mas dependendo, se isso for feito fora do MK. Você poderia automatizar isso pelo "agendador de tarefas" do windows. Caso isso não seja viável, de detalhes de como vc consegue fazer funcionar. Se for o caso, tenhos os scripts de liberação de banda por horário aqui, que funcionam 100%.



  3. #3
    fabricioigor
    Visitante

    Padrão script hotspot contrle de banda por horario

    Bom minha situaçao e a sequinte tenho MK e controlo mes clientes por hotspot
    pra controlar a banda dos clientes eu utilizo os PROFILES USER
    EXEMPLO
    3 PLANO BASICO rate-limit = 48k/96k
    4 PLANO PROFESSOR rate-limit = 32k/64k

    os meus cliente estao arumados por esses profiles
    as 22:00 percebi diminiu o acesso e sobra banda

    ai entro no MK em modo telnet e na linha de comando digito
    /ip hotspot user profile set 3 rate-limit="64k/128k"
    /ip hotspot user profile set 4 rate-limit="48k/96k"

    a conexao do meus clientes ficam mais rapidas dai as 08:00
    da manha entro no MK via telnet e executo novamente os comandos com as velocidades recoloco as velocidade contratas.
    /ip hotspot user profile set 3 rate-limit="48k/96k"
    /ip hotspot user profile set 4 rate-limit="32k/64k"

    eu queria fazer isso via script e usar scheduler pra fazer esse trabalho por mim
    ate criei um script e coloque o mesmo comando no script mais quanto o script e executado nao altera o profile, e como nao sei mecher com debug do MK

    1 name="RED_25_PB" owner="igor"
    policy=ftp,reboot,read,write,policy,test,winbox,password
    last-started=mar/05/2007 13:19:39 run-count=2
    source=/ip hotspot user profile set 3 rate-limit="64k/128k"

    ele executa o script porem nao altera o profile

  4. #4

    Padrão

    Vc teria que definir duas queue, na opcao time tem como definir o horario que a regra fica ativa. Colocaria das 8 as 18 de segunda a sexta a banda normal e 18:01 as 7:59 a banda dobrada.


    Citação Postado originalmente por fabricioigor Ver Post
    Bom minha situaçao e a sequinte tenho MK e controlo mes clientes por hotspot
    pra controlar a banda dos clientes eu utilizo os PROFILES USER
    EXEMPLO
    3 PLANO BASICO rate-limit = 48k/96k
    4 PLANO PROFESSOR rate-limit = 32k/64k

    os meus cliente estao arumados por esses profiles
    as 22:00 percebi diminiu o acesso e sobra banda

    ai entro no MK em modo telnet e na linha de comando digito
    /ip hotspot user profile set 3 rate-limit="64k/128k"
    /ip hotspot user profile set 4 rate-limit="48k/96k"

    a conexao do meus clientes ficam mais rapidas dai as 08:00
    da manha entro no MK via telnet e executo novamente os comandos com as velocidades recoloco as velocidade contratas.
    /ip hotspot user profile set 3 rate-limit="48k/96k"
    /ip hotspot user profile set 4 rate-limit="32k/64k"

    eu queria fazer isso via script e usar scheduler pra fazer esse trabalho por mim
    ate criei um script e coloque o mesmo comando no script mais quanto o script e executado nao altera o profile, e como nao sei mecher com debug do MK

    1 name="RED_25_PB" owner="igor"
    policy=ftp,reboot,read,write,policy,test,winbox,password
    last-started=mar/05/2007 13:19:39 run-count=2
    source=/ip hotspot user profile set 3 rate-limit="64k/128k"

    ele executa o script porem nao altera o profile



  5. #5

    Padrão

    Vou postar o script para banda total liberada de 00:00 ás 6:00, todos os dias. Executando-a automaticamente. Você ajusta ela de acordo com suas necessidades:

    SCRIPTS DE LIBERAÇÃO DE BANDA (habilita e desabilita):

    / system script

    add name="queue_disable" source="/queue simple { disable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="queue_enable" source="/queue simple { enable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=queue_enable start-date=jan/21/2006 \
    start-time=00:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=queue_disable start-date=jan/21/2006 \
    start-time=06:00:01 interval=1d comment="HABILITA E DESABILITA TODA A \
    BANDA" disabled=no

    REGRA DE LIBERAÇÃO DA BANDA:

    / queue simple
    add name="LIBERA_TUDO" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 \
    interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=2000000/2000000 \
    total-queue=default-small disabled=yes

    Resumindo:

    1 regra são os scripts para ligar e desligar a regra de liberação de banda.

    2 regra são os agendamentos. Liga ás 00:00 e desliga ás 06:00, todos os dias.

    3 regra é o quanto de banda vai ser liberado. No exemplo acima são 2MB de up e down para todo mundo.

  6. #6

    Padrão

    Citação Postado originalmente por fabricioigor Ver Post
    Bom minha situaçao e a sequinte tenho MK e controlo mes clientes por hotspot
    pra controlar a banda dos clientes eu utilizo os PROFILES USER
    EXEMPLO
    3 PLANO BASICO rate-limit = 48k/96k
    4 PLANO PROFESSOR rate-limit = 32k/64k

    os meus cliente estao arumados por esses profiles
    as 22:00 percebi diminiu o acesso e sobra banda

    ai entro no MK em modo telnet e na linha de comando digito
    /ip hotspot user profile set 3 rate-limit="64k/128k"
    /ip hotspot user profile set 4 rate-limit="48k/96k"

    a conexao do meus clientes ficam mais rapidas dai as 08:00
    da manha entro no MK via telnet e executo novamente os comandos com as velocidades recoloco as velocidade contratas.
    /ip hotspot user profile set 3 rate-limit="48k/96k"
    /ip hotspot user profile set 4 rate-limit="32k/64k"

    eu queria fazer isso via script e usar scheduler pra fazer esse trabalho por mim
    ate criei um script e coloque o mesmo comando no script mais quanto o script e executado nao altera o profile, e como nao sei mecher com debug do MK

    1 name="RED_25_PB" owner="igor"
    policy=ftp,reboot,read,write,policy,test,winbox,password
    last-started=mar/05/2007 13:19:39 run-count=2
    source=/ip hotspot user profile set 3 rate-limit="64k/128k"

    ele executa o script porem nao altera o profile
    tente fazer esse mesmo script ai mas desmarque a opcão chamado "policy e password" diz ai se funciona.



  7. #7
    fabricioigor
    Visitante

    Padrão

    eu so preciso q o script execute corretamente esse comando
    /ip hotspot user profile "set 4 rate-limit="64k/128k""

    pois to usando hotspot com profile user é bem mais facil gerencia, do que criar queue e a solucao ja esta pronta so quero q o script execute corretamente comando acima, pois toda as 22:00 eu vou executo o comando e de manha volto ao normal, acredito q devo estar errando na sintaxe do comando via script

    obrigado

  8. #8
    fabricioigor
    Visitante

    Padrão

    tiago infelismente nao funcionou o engracado q se eu usar esse comando via linha de comando do telnet funciona q é uma blz, acredito q se funcionar isso muita gente vai se beneficiar principalmente quem usa hotspot, to tentando aqui
    tem aguma forma de depurar os scripts



  9. #9

    Padrão

    Citação Postado originalmente por fabricioigor Ver Post
    tiago infelismente nao funcionou o engracado q se eu usar esse comando via linha de comando do telnet funciona q é uma blz, acredito q se funcionar isso muita gente vai se beneficiar principalmente quem usa hotspot, to tentando aqui
    tem aguma forma de depurar os scripts
    Vc colocou as regras que postei? Estas aqui funcionam perfeitamente, testa ae e posta o resultado!!

  10. #10
    fabricioigor
    Visitante

    Padrão

    a tua regra funciona blz, porem eu nao posso usa-la pra todos aqui, minha internet é via satelite, e lenta e ainda depende do tempo, esses dois profiles sao os menores planos q tenho aqui e a noite eu queria deixar eles um pouco mais rapidos eu so to querendo mudar o rate-limit de 48k/96k para 64k/128k so mudar um parametro de um profile ja criado



  11. #11

    Padrão

    Estes seus profiles estão em qual faixa de IP? Basta colocar a regra com o valor que você deseja de banda a liberar e definir lá na regra do queue simple, a faixa de IP que você deseja atingir. Se mesmo assim não conseguir fazer a regra, diga qual faixa de ip, banda e qual horário deseja liberar que configuro as regras pra vc!!

  12. #12
    fabricioigor
    Visitante

    Padrão

    eu uso 192.168.100.0/24 pra todos os meus clientes infeliemente eu nao agrupo por grupo de ips e sim por profile eu nem uso o simple queue pois quando eu uso hotspot o cliente assumen a regra do hotspot quando loga ate cria um simple queue dinamicamente, tem como mudar via script somente o rate-limit de um detreminado profile, olha estou muito impressionado com a rapides das resposta de forum é a primeira vez q estou postando em um forum, vcs estao de parabens



  13. #13

    Padrão

    Citação Postado originalmente por fabricioigor Ver Post
    eu uso 192.168.100.0/24 pra todos os meus clientes infeliemente eu nao agrupo por grupo de ips e sim por profile eu nem uso o simple queue pois quando eu uso hotspot o cliente assumen a regra do hotspot quando loga ate cria um simple queue dinamicamente, tem como mudar via script somente o rate-limit de um detreminado profile, olha estou muito impressionado com a rapides das resposta de forum é a primeira vez q estou postando em um forum, vcs estao de parabens
    Tem como mudar sim apenas o rate-limit, mas deixa eu te falar, n estou usando aqui hotspot para testar isso vou arrumar uma maquina parada aqui para testar, mas a regra n esta errado n entendo pq n esta funcionando, o user qu esta criando essa regra no /system script é um usário FULL ? ele da algum erro no LOG do mikrotik de erro ?

  14. #14
    fabricioigor
    Visitante

    Padrão

    meu usuario tem acesso FULL e nao gera nenhm log nao, tem como mandar comandos via telnet com usuario e senha, tipo assim crio um arquivi bat que entra via telnet e manda o comando.



  15. #15

    Padrão

    Citação Postado originalmente por fabricioigor Ver Post
    meu usuario tem acesso FULL e nao gera nenhm log nao, tem como mandar comandos via telnet com usuario e senha, tipo assim crio um arquivi bat que entra via telnet e manda o comando.
    Como te disse antes vou testar aqui, te digo amanha isso, ou alguém aqui pode postar antes para vc o problema vamos esperar.

    Abraços.

  16. #16

    Padrão

    Citação Postado originalmente por fabricioigor Ver Post
    Bom minha situaçao e a sequinte tenho MK e controlo mes clientes por hotspot
    pra controlar a banda dos clientes eu utilizo os PROFILES USER
    EXEMPLO
    3 PLANO BASICO rate-limit = 48k/96k
    4 PLANO PROFESSOR rate-limit = 32k/64k

    os meus cliente estao arumados por esses profiles
    as 22:00 percebi diminiu o acesso e sobra banda

    ai entro no MK em modo telnet e na linha de comando digito
    /ip hotspot user profile set 3 rate-limit="64k/128k"
    /ip hotspot user profile set 4 rate-limit="48k/96k"

    a conexao do meus clientes ficam mais rapidas dai as 08:00
    da manha entro no MK via telnet e executo novamente os comandos com as velocidades recoloco as velocidade contratas.
    /ip hotspot user profile set 3 rate-limit="48k/96k"
    /ip hotspot user profile set 4 rate-limit="32k/64k"

    eu queria fazer isso via script e usar scheduler pra fazer esse trabalho por mim
    ate criei um script e coloque o mesmo comando no script mais quanto o script e executado nao altera o profile, e como nao sei mecher com debug do MK

    1 name="RED_25_PB" owner="igor"
    policy=ftp,reboot,read,write,policy,test,winbox,password
    last-started=mar/05/2007 13:19:39 run-count=2
    source=/ip hotspot user profile set 3 rate-limit="64k/128k"

    ele executa o script porem nao altera o profile
    Tenta assim, então

    SCRIPTS DE LIBERAÇÃO DE BANDA (habilita e desabilita):

    / system script

    add name="libera_banda1" source="/ip hotspot user profile set 3 rate-limit="64k/128k" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="libera_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="desliga_banda1" source="/ip hotspot user profile set 3 rate-limit="48k/96k" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="desliga_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword




    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=libera_banda1 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda1 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA1" disabled=no
    add name="enable" on-event=libera_banda2 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda2 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA2" disabled=no

    Resumindo:

    Já deixei as regras prontas ae em cima, copie e cole.... poste o resultado!!!



  17. #17

    Padrão

    pessoal n quis abrir outro topico, mas dentro do mesmo assunto hotspot uma duvida. eu ja uso hotspot mas sempre tive um problemas com esses aps (zinwell, kodama, ovislink) pq eles n repassam o mac dos clientes conectados a ele. minha duvida e a seguinte, su eu colocar no user profile na opçao shared user pra 10 nesse caso 10 clientes poderam se conectar com o mesmo login neh isso? com isso eu poderia colocar hotspot nos clientes do condominio. isso da certo?

  18. #18

    Padrão

    Citação Postado originalmente por Snake_jp Ver Post
    pessoal n quis abrir outro topico, mas dentro do mesmo assunto hotspot uma duvida. eu ja uso hotspot mas sempre tive um problemas com esses aps (zinwell, kodama, ovislink) pq eles n repassam o mac dos clientes conectados a ele. minha duvida e a seguinte, su eu colocar no user profile na opçao shared user pra 10 nesse caso 10 clientes poderam se conectar com o mesmo login neh isso? com isso eu poderia colocar hotspot nos clientes do condominio. isso da certo?
    sim, da sim.