+ Responder ao Tópico



  1. Pessoal, estou com um problema no WebProxy.

    Tenho um MK como AP fazendo esse webproxy. São duas placas, uma Wlan e outra Ether. Recebo o link pela Ether e passo para a Wlan.

    Segui todos os passos para a criação do proxy e funcionou. Porém, percebo que se fechar o browser do cliente, o micro não navega mais. Fica tentando localizar a página inicial até dar o erro "a página não pode ser exibida". Se eu reiniciar todo o sistema (MK e micro cliente) também não navega mais.

    Antes de colocar o proxy para funcionar, eu testei o MK com um NAT simples do tipo "masquerade". Usando esse nat sem o proxy, funciona 100%.

    Aí tem um detalhe:

    Se eu desativar o dst-nat que estou usando para direcionar a porta 80 para a 3128 e ativar o nat masquerade, o cliente volta a navegar. Depois disso, volto como estava desativando o masquerade e ativando o dst-nat. Feito isso, o cliente continua a navegar e depois de uns 5 minutos se eu fechar o browser e abrir novamente já não navega mais.

    Bom, acho que tem alguma coisa faltando um o meu MK está doido.

    Em anexo, capturei as telas.

    Alguém sabe o que pode estar acontecendo ?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         mk1.JPG
Visualizações:	131
Tamanho: 	85,0 KB
ID:      	285   Clique na imagem para uma versão maior

Nome:	         mk2.JPG
Visualizações:	118
Tamanho: 	76,1 KB
ID:      	286   Clique na imagem para uma versão maior

Nome:	         mk3.JPG
Visualizações:	117
Tamanho: 	31,8 KB
ID:      	287  

  2. Tira essas suas regras que esta no NAT e no seu web-proxy ai e coloca dessa forma aqui, n precisa desativar nada deposi de colocar essas que estou postando:

    /ip firewall nat
    add chain=srcnat src-address=192.168.200.0/24 action=masquerade comment="" disabled=no
    add chain=dstnat src-address=192.168.200.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3126 comment="" disabled=no

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3126 hostname="proxy.linuxap.com.br" transparent-proxy=yes parent-proxy=0.0.0.0:0 cache-administrator="tiagomatias@linuxap.com.br" \
    max-object-size=4069KiB cache-drive=system max-cache-size=unlimited max-ram-cache-size=unlimited
    / ip web-proxy access
    add src-address=192.168.200.0/24 dst-port=0-65535 action=allow comment="" disabled=no
    add dst-port=!443 method=connect action=deny comment="allow CONNECT only to SSL ports 443 \[https\] and 563 \[snews\]" disabled=no
    add dst-port=!563 method=connect action=deny comment="" disabled=no
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" disabled=no
    add dst-port=0-65535 action=deny comment="Deny everything else" disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no

    Concerteza vai funcionar.

    Ps. 1 - se tiver algo errado nos avise; 2 - Se esqueci de colocar algum ip fora de sua rede troque os dados de acordo com sua necessidade.

    Abraços.
    Última edição por tiagomatias; 10-02-2007 às 14:07.



  3. Tiago, obrigado. Está funcionando com essas regras que vc me passou.

    Eu acho que o meu erro está aqui:

    Eu estava desabilitando a regra de masquerade e deixando somente a regra de dst-nat ativada.

    Eu pensava que só a regra dst-nat direcionando para a porta 3128 já era suficiente.

    Então dessa forma que você me passou eu estou fazendo o proxy e também o NAT ?

    Valeu

    Samuel.

  4. Tiago,

    Percebi mais um detalhe:

    Se eu deixar essa regra ativada, o MK não faz o cache. O tamanho do arquivo de cache fica em 0. Agora se eu desativar essa regra, ele faz o cache normalmente.

    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no

    ----------------------------------

    Outra coisa, eu tenho 512MB de ram e HD de 20GB. É melhor eu deixar em unlimited ou definir na mão a quantidade de RAM e HD para o cache ?

    Dá uma olhada no anexo, como ficou com os parâmetros em Unlimited:
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         mk.JPG
Visualizações:	101
Tamanho: 	27,4 KB
ID:      	288  



  5. Citação Postado originalmente por Samuelso Ver Post
    Tiago, obrigado. Está funcionando com essas regras que vc me passou.

    Eu acho que o meu erro está aqui:

    Eu estava desabilitando a regra de masquerade e deixando somente a regra de dst-nat ativada.

    Eu pensava que só a regra dst-nat direcionando para a porta 3128 já era suficiente.

    Então dessa forma que você me passou eu estou fazendo o proxy e também o NAT ?

    Valeu

    Samuel.
    SIm, isso mesmo esta fazendo NAT e proxy transparente.

    Abraços






Tópicos Similares

  1. Problemas com WebProxy no Mk
    Por RenatoLima no fórum Redes
    Respostas: 20
    Último Post: 30-03-2011, 23:46
  2. PROBLEMA COM WEBPROXY X HOTSPOT
    Por JAMFS no fórum Redes
    Respostas: 0
    Último Post: 17-12-2008, 11:49
  3. Problemas com WebProxy
    Por admskill no fórum Redes
    Respostas: 12
    Último Post: 17-12-2007, 13:44
  4. Problemas com Webproxy
    Por emanuelms no fórum Redes
    Respostas: 3
    Último Post: 08-09-2007, 19:59
  5. Problema com WebProxy,,, alguem ja passou por isso??
    Por alanvictorjp no fórum Redes
    Respostas: 6
    Último Post: 30-05-2007, 08:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L