+ Responder ao Tópico



  1. ola galera!!!
    alguem pode me ajudar a concertar esse script?????
    quero usalo como um no-ip para conectar remotamente



    :log info "DDNS: Begin"

    :global ddns-user "gotch" "aqui coloco so gotch ou gotch.ddns.info?":global ddns-pass "********"
    :global ddns-host "*1" aqui continua o 1?
    :global ddns-interface "publica1" """aqui deixo a interface do modem adsl ou pppoe-out1 que e a interface que esta a conexão bridge que uso?"""

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    bom quando eu for montar esse script entro em system script e tem varias opções !! quais deixo mascaradas!!! desde ja obrigado

  2. Citação Postado originalmente por gotch Ver Post
    ola galera!!!
    alguem pode me ajudar a concertar esse script?????
    quero usalo como um no-ip para conectar remotamente



    :log info "DDNS: Begin"

    :global ddns-user "gotch" "aqui coloco so gotch ou gotch.ddns.info?":global ddns-pass "********"
    :global ddns-host "*1" aqui continua o 1?
    :global ddns-interface "publica1" """aqui deixo a interface do modem adsl ou pppoe-out1 que e a interface que esta a conexão bridge que uso?"""

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    bom quando eu for montar esse script entro em system script e tem varias opções !! quais deixo mascaradas!!! desde ja obrigado
    Mantenha todas habilitadas....



  3. ninguem se habilita???????????????????????????
    eu quase consegui!! vi que ele envia as informações mas o ip vai 0.0.0.0/0 sei disso porque tenho um outro servidor so pra analize de dados!!!!! o que pode estar errado nesse maldito script kkkk!!! desde ja obrigado!!!
    mais postem!!! pelomenos.. bom cara boua sorte... ow !! continua tentando!!!!
    cara tenta no sheduller!!! rsss


    Citação Postado originalmente por gotch Ver Post
    ola galera!!!
    alguem pode me ajudar a concertar esse script?????
    quero usalo como um no-ip para conectar remotamente



    :log info "DDNS: Begin"

    :global ddns-user "gotch" "aqui coloco so gotch ou gotch.ddns.info?":global ddns-pass "********"
    :global ddns-host "*1" aqui continua o 1?
    :global ddns-interface "publica1" """aqui deixo a interface do modem adsl ou pppoe-out1 que e a interface que esta a conexão bridge que uso?"""

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    bom quando eu for montar esse script entro em system script e tem varias opções !! quais deixo mascaradas!!! desde ja obrigado






Tópicos Similares

  1. Ajuda com script de firewall no fedora
    Por pearljam no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-09-2007, 08:45
  2. Ajuda com script pra desabilitar controle de banda
    Por cleciorodrigo no fórum Redes
    Respostas: 0
    Último Post: 10-06-2007, 07:30
  3. Ajuda com script (bash)
    Por sarna no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 08-03-2005, 21:42
  4. Ajuda com script para travar programa
    Por gamefe no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 10-02-2005, 16:13
  5. ajuda com script
    Por dboom no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-02-2004, 22:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L