Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde a todos.
    Estou instalado um server de DNS com o Bind + Chroot. Para isso segui este tutorial: Slacklife - Comunidade Slackware Linux do Brasil
    mas não consigo iniciar o bind.

    named[3190]: binding TCP socket: address in use
    last message repeated 2 times
    named[3190]: /etc/named.conf:19: couldn't add command channel 127.0.0.1#953: address in use

    Não sei o que fazer!! Alguem pode me ajudar??
    Valeu!!!

  2. Se seguiu este rautu ao pé da letra deveria funcinoar... a mensagem diz que o endereço está em uso.

    Já verificou se não existe outra cópia do bind rodando? Não existe outro serviço escutando nesta porta?



  3. Faça como o amigo acima falou e rode o comando "ps ax" pra ver se tem algum processo do BIND/named rodando.


    Abraços!

  4. Ja testei essa soluçao no slackware 10.0 10.2 11.0 e sempre funcionou perfeito.

    Voce deve rever as conf pra verificar se realmente fez tudo como mando o figurino, vc deve verificar se excluiu os arquivos normais criados na instalaçao do bind, apenas deixando a estrutura com chroot.

    Outra coisa que nao fala no material dele e vc deve ter atençao e o seguinte quando vc roda o seguinte comando:
    #rndc-confgen

    Ele gera uma chave essa chave nunca e igual, ela deve ser utilizada no restante dos arquivos que fazem uso dela, como por exemplo:

    /chroot/named/etc/named.conf
    /chroot/named/etc/rndc.conf

    Cara isso sao dicas que podem ajudar.

    Abraçao
    Última edição por gatoseco; 14-02-2007 às 18:21.



  5. Pessoal, consegui fazer rodar o bind... blz
    o problema é que vou usar o dns apenas para a rede local, ou seja, quero que as máquinas respondam pelo nome e nao pelo IP, por exemplo, eu tenho um registro no DNS que a maquina01.dominio.com.br é o ip 10.60.0.1, portanto se eu der um ping em maquina01.dominio esse IP vai responder.
    Blz daqui tudo legal.
    O lance é não consigo fazer isso. Aparentemente o bind está funcionando normal, mas não responda a nada.
    O que fazer???






Tópicos Similares

  1. BIND DNS não encontra o arquivo /var/named/chroot/etc/named.conf
    Por Luciano Cabral no fórum Servidores de Rede
    Respostas: 8
    Último Post: 11-09-2015, 19:32
  2. Bind com chroot - Centos 6.1 e agora
    Por spyderlinux no fórum Servidores de Rede
    Respostas: 4
    Último Post: 22-05-2012, 21:54
  3. Bind com Chroot (master and slave)
    Por spyderlinux no fórum Servidores de Rede
    Respostas: 4
    Último Post: 07-04-2010, 14:35
  4. Bind em CHROOT
    Por LinuxKids no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-08-2005, 12:41
  5. Chroot
    Por anjo-negro no fórum Servidores de Rede
    Respostas: 4
    Último Post: 27-07-2002, 22:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L