+ Responder ao Tópico



  1. #1

    Question Bind + CHROOT

    Boa tarde a todos.
    Estou instalado um server de DNS com o Bind + Chroot. Para isso segui este tutorial: Slacklife - Comunidade Slackware Linux do Brasil
    mas não consigo iniciar o bind.

    named[3190]: binding TCP socket: address in use
    last message repeated 2 times
    named[3190]: /etc/named.conf:19: couldn't add command channel 127.0.0.1#953: address in use

    Não sei o que fazer!! Alguem pode me ajudar??
    Valeu!!!

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Se seguiu este rautu ao pé da letra deveria funcinoar... a mensagem diz que o endereço está em uso.

    Já verificou se não existe outra cópia do bind rodando? Não existe outro serviço escutando nesta porta?



  3. #3

    Padrão

    Faça como o amigo acima falou e rode o comando "ps ax" pra ver se tem algum processo do BIND/named rodando.


    Abraços!

  4. #4

    Padrão

    Ja testei essa soluçao no slackware 10.0 10.2 11.0 e sempre funcionou perfeito.

    Voce deve rever as conf pra verificar se realmente fez tudo como mando o figurino, vc deve verificar se excluiu os arquivos normais criados na instalaçao do bind, apenas deixando a estrutura com chroot.

    Outra coisa que nao fala no material dele e vc deve ter atençao e o seguinte quando vc roda o seguinte comando:
    #rndc-confgen

    Ele gera uma chave essa chave nunca e igual, ela deve ser utilizada no restante dos arquivos que fazem uso dela, como por exemplo:

    /chroot/named/etc/named.conf
    /chroot/named/etc/rndc.conf

    Cara isso sao dicas que podem ajudar.

    Abraçao
    Última edição por gatoseco; 14-02-2007 às 19:21.



  5. #5

    Padrão Bind + Chroot

    Pessoal, consegui fazer rodar o bind... blz
    o problema é que vou usar o dns apenas para a rede local, ou seja, quero que as máquinas respondam pelo nome e nao pelo IP, por exemplo, eu tenho um registro no DNS que a maquina01.dominio.com.br é o ip 10.60.0.1, portanto se eu der um ping em maquina01.dominio esse IP vai responder.
    Blz daqui tudo legal.
    O lance é não consigo fazer isso. Aparentemente o bind está funcionando normal, mas não responda a nada.
    O que fazer???

  6. #6

    Padrão

    Não se esqueça que não basta você configurar os servidor. Você tem que configurar os seus clientes para resolver nomes pelo servidor DNS.



  7. #7
    vul4
    Visitante

    Padrão

    Bom dia Pessoal!

    Eu segui exatamente os passos do artigo, não deu nenhum tipo de problema. como eu apenas quero um DNS para resolver os nomes da internet internamente dando mais agilidade as consultas. Mas aqui o bind simplismente não inicia, não envia msgs de erro. Estou usando um RH9.

    Alguém tem alguma pista? Ou dica que eu possa verificar?

    Atenciosamente

  8. #8
    Marcell
    Visitante

    Thumbs up

    Boa tarde pessoal, sei que o tópico é pra resolver o problema do nosso amigo ticesar7 e de muitos outros...

    Eu ja tive muitos problemas com o BIND, e resolvi mudar pro DjbDNS.

    Não querendo mudar o pensamento de ninguem, mas tenta da uma olhada para ver a simplicidade, rapidez, eficiencia e sem fala q o DjbDNS roda por padrão em CHROOT.

    Estou rodando o DjbDNS no Slackware 11 e roda muito bem.

    esta aí um artigo para todos.
    Criando um servidor DNS com o DJBDNS

    e também uma comparação de bind e djbdns
    BIND versus djbdns

    Espero ter ajudado