+ Responder ao Tópico



  1. #1

    Padrão Recompilar kernel para aplicar Layer7 e IPP2P

    to tentando recompilar meu kernel q atualemnte é o 2.6.19-1.2895.fc6 pra o linux-2.4.34 para aplicar o Layer& e o IPP2P mas depois de aplicar pelo make menuconfig e tentar recompilar meu kernel retorna o erro abaixo (como o log é muito grande coloquei só o final onde surgem os erros)

    make[2]: Entrando no diretório `/usr/src/linux-2.4.34/arch/i386/math-emu'
    make[2]: Nada a ser feito para `all_targets'.
    make[2]: Saindo do diretório `/usr/src/linux-2.4.34/arch/i386/math-emu'
    make[1]: Saindo do diretório `/usr/src/linux-2.4.34/arch/i386/math-emu'
    ld -m elf_i386 -T /usr/src/linux-2.4.34/arch/i386/vmlinux.lds -e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o init/do_mounts.o \
    --start-group \
    arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o \
    drivers/acpi/acpi.o drivers/parport/driver.o drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o drivers/char/agp/agp.o drivers/char/drm-4.0/drm.o drivers/net/fc/fc.o drivers/net/appletalk/appletalk.o drivers/net/tokenring/tr.o drivers/net/wan/wan.o drivers/net/arcnet/arcnetdrv.o drivers/atm/atm.o drivers/ide/idedriver.o drivers/ieee1394/ieee1394drv.o drivers/cdrom/driver.o drivers/pci/driver.o drivers/mtd/mtdlink.o drivers/pcmcia/pcmcia.o drivers/net/pcmcia/pcmcia_net.o drivers/net/wireless/wireless_net.o drivers/char/pcmcia/pcmcia_char.o drivers/pnp/pnp.o drivers/i2c/i2c.o drivers/video/video.o drivers/block/paride/paride.a drivers/usb/usbdrv.o drivers/usb/gadget/built-in.o drivers/media/media.o drivers/input/inputdrv.o drivers/message/i2o/i2o.o drivers/net/irda/irda.o drivers/md/mddev.o drivers/hotplug/vmlinux-obj.o crypto/crypto.o arch/i386/math-emu/math.o \
    net/network.o \
    /usr/src/linux-2.4.34/arch/i386/lib/lib.a /usr/src/linux-2.4.34/lib/lib.a /usr/src/linux-2.4.34/arch/i386/lib/lib.a \
    --end-group \
    -o vmlinux
    drivers/media/media.o: In function `zoran_write_proc':
    zr36067.c.text+0xf350): undefined reference to `strchr'
    drivers/media/media.o: In function `rds_waitread':
    miropcm20-rds-core.c.text+0x324af): undefined reference to `aci_port'
    drivers/media/media.o: In function `rds_rawwrite':
    miropcm20-rds-core.c.text+0x3254c): undefined reference to `aci_port'
    drivers/media/media.o: In function `rds_readcycle_nowait':
    miropcm20-rds-core.c.text+0x32619): undefined reference to `aci_port'

    make: ** [vmlinux] Erro 1

  2. #2

    Padrão

    Poxa, mas você tá voltando o seu kernel? Por quê você não compila o mesmo kernel com suporte à ele?



  3. #3

    Padrão

    Citação Postado originalmente por xstefanox Ver Post
    Poxa, mas você tá voltando o seu kernel? Por quê você não compila o mesmo kernel com suporte à ele?
    Boa boa amigão., se voce puder me mostrar como faço isso agradeço., to a semanas ralando e até agora nada

  4. #4

    Padrão

    Olha, vou falar a mesma coisa que eu falei pra outro usuário.

    Pega o layer-7 e descompacte-o. Olhe quais as versões do iptables e do kernel ele suporta. Você vai se guiar por aí pra pegar as versões mais novas. Como a galera do layer-7 trabalha bastante, geralmente a última versão vai suportar o penúltimo ou último release oficial do kernel, disponível em The Linux Kernel Archives. Isso é até bom, porque coisa muito nova é pouco testada.

    No wiki tem tutoriais sobre isso e sobre recompilação de kernel eu recomendo o Focalinux.

    Abraços!



  5. #5

    Padrão

    Pessoal o problema é que as dicas só te mostram como recompilar e tudo fucnionando bonitinho., não ha reportes sobre os possives erros e qual a forma de resolvelos., alguém ai sabe como faço então pra aplicar esses patchs (Layer7 e IPP2P) no kernel em uso., por exemplo uso o Fedora core 6 com o kernel 2.6.19 ., como faço para aplicar esses patch ao kernel ja que ele esta em uso., como faço para aplicar?????

  6. #6

    Padrão

    Você não faz.

    Veja bem, a maioria das distribuições já vêm com um kernel pré-compilado para você. Esse kernel possui um suporte generalizado dos hardwares atuais no mercado e você precisa compilar um kernel (De preferência mais novo, se possível) ou então pegar o source do kernel que você está usando atualmente (Sim, as distribuições também fornecem pacotes com os sources dos seus kernels), mas de qualquer jeito você vai ter que baixar um source e recompilá-lo, salvo quando você já está utilizando um kernel que foi compilado por você.


    Abraços!