+ Responder ao Tópico



  1. #1

    Padrão Calling-Station-Id no ppp.tar.gz do Scorpion

    Olá pessoal,

    Consegui configurar um servidor PPPoE com autenticação em Freeradius/Firebird com a ajuda do tutorial do Scorpion, porém, o pppd não envia o Calling-Station-Id com o MAC do cliente. Segundo alguns posts que vi, o problema está com a versão do pppd que deve ser substituída pela 2.4.4. Eu já baixei o pacote, mas não consigo instala-lo como faz o pacote do tutorial. Ele não cria, por exemplo, o diretório "/etc/radiusclient" e alguns outros detalhes....

    Minha dúvida é: Como compilar o ppp-2.4.4.tar.gz ???

    Obrigado!

  2. #2



  3. #3

    Padrão

    seguinte..

    o radius client tem um erro na compilação

    entra no diretorio do radiusclient.. e da um make e veja qual erro.. e vai tentando consertar... aqui fiz assim.. vou ver se tenho o pacote com o fonte arrumado...

    vou tentar anexar aqui no forum...
    Arquivos Anexos Arquivos Anexos

  4. #4

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    seguinte..

    o radius client tem um erro na compilação

    entra no diretorio do radiusclient.. e da um make e veja qual erro.. e vai tentando consertar... aqui fiz assim.. vou ver se tenho o pacote com o fonte arrumado...

    vou tentar anexar aqui no forum...
    Mas essa versão envia o Calling-Station-Id com o MAC do cliente?



  5. #5

    Padrão

    nao testei mas acho que sim.. eh uma das ultimas versoes..

  6. #6

    Padrão

    Eu fiz o teste, tudo funciona perfeitamente, mas o Calling-Station-Id continua a não ser enviado:

    Service-Type = Framed-User
    Framed-Protocol = PPP
    User-Name = "eduardo"
    User-Password = "000"
    NAS-IP-Address = 200.xxx.xxx.xxx
    NAS-Port = 1

    Deveria aparecer o atributo:

    Calling-Station-Id = MACDOCLIENTE

    Mas até agora nada....

    Quem já conseguiu, dá uma força ae.



  7. #7

    Padrão

    Citação Postado originalmente por e-eduardo Ver Post
    Eu fiz o teste, tudo funciona perfeitamente, mas o Calling-Station-Id continua a não ser enviado:

    Service-Type = Framed-User
    Framed-Protocol = PPP
    User-Name = "eduardo"
    User-Password = "000"
    NAS-IP-Address = 200.xxx.xxx.xxx
    NAS-Port = 1

    Deveria aparecer o atributo:

    Calling-Station-Id = MACDOCLIENTE

    Mas até agora nada....

    Quem já conseguiu, dá uma força ae.
    Eduardo eu faco isto com mk sendo servidor de pppoe e uma maquina linux com freeradius e chega calling do cliente, o que vc roda neste servidor? se for o caso o mikrotick faz cache de dns, cache web servidor pppoe e outras coisas mais..

  8. #8

    Padrão

    Amigo pelo menos no meu caso, preciso dessa soluçao para linux mesmo mikrotik nao resolve pra mim.



  9. #9

    Padrão

    Eu uso Debian e preciso continuar usando, por isso faço questão dessa solução. Sei que tem como o MAC ser enviado, mas tá difícil de achar a solução.

    Outra coisa estranha é que o meu DNS não consegue resolver os endereços vinculados a "samba.org" e acredito que lá tenha alguma documentação.

  10. #10

    Padrão

    Acho que tem alguma coisa a ver com o PPPoE em kernel mode... pelo que vi no código fonte, o "remote_number" é preenchido no plugin.c que faz parte do rp-pppoe.so que é o plugin para kernel mode... Ainda não consegui fazer o pppoe-server rodar em kernel mode com a opção -k... dá a mensagem: pppoe-server: invalid option -- k

    Atribui um valor manualmente pra variavel e agora ela está sendo enviada para o radius, o problema é que não sei qual variavel realmente tem o endereço mac do cliente pra poder associar a remote_number...

    Alguém, por favor, ajude!!!



  11. #11

    Padrão

    FINALMENTE!!!!

    Realmente o rp-pppoe.so é o responsável pela informação do endereço MAC.... basta seguir o tutorial do Scorpion e adicionar a linha:

    plugin /etc/ppp/plugins/rp-pppoe.so

    E executar com o -k:

    # pppoe-server -C Seuprovedor -S seuservidor -I eth1 -k

    O -S é usado quando você tem mais de um servidor PPPoE no mesmo switch, aí é só configurar o "Nome do serviço" no cliente pra ele buscar o servidor dele.

    Obrigado a todos!!!!

  12. #12

    Padrão

    Blz amigo valeu ai pelo empenho em conseguir a soluçao, vou testar e posto os resultados.