+ Responder ao Tópico



  1. #1

    Thumbs up Tutorial para colocar dois Link de Operadoras diferentes

    Tutorial de configuração de dois Links Telemar e Embratel em um Cisco 1721
    por Fco soares da silva ([email protected])

    requisito: comandos
    1. router-map

    2. access-list

    3. set ip next-hop

    4. A expressão "SSS" em "route-map" pode ser qualquer outra desde quer na "policy route-map" seja a mesma expressão.

    ########################################
    Nesse tutorial vamos deixar uma rota da serial1 como default e vamos aplicar essas regras apenas na serial0


    ########################################
    1 - Configurando Fastethernet0
    No roteador digite:
    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)#int f0
    Netfacil-Router(config-if)#ip address 200.210.xxx.1 255.255.255.252
    Netfacil-Router(config-if)#ip address 200.200.xxx.1 255.255.255.248 secondary
    Netfacil-Router(config-if)#

    - Der um Ctrl+z para saír da interface
    - Configurada interface Fasethrnet0

    2 - Configurando serial0
    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)#int s0
    Netfacil-Router(config-if)#ip address 200.17.xxx.2 255.255.255.252
    Netfacil-Router(config-if)#Encapsulation hdlc
    Netfacil-Router(config-if)#

    - Der um Ctrl+z para saír da interface
    - Configurada interface serial0

    3 - Configurando serial1
    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)#int s1
    Netfacil-Router(config-if)#ip address 200.333.xxx.192 255.255.255.252
    Netfacil-Router(config-if)#encapsulation ppp
    Netfacil-Router#(config-if)#

    - Der um Ctrl+z para saír da interface
    - Configurada interface serial1

    - Deixando a serial1 como rota default e suas rotas

    4 - Configurando rotas default da serial1 e rotas de ip´s validos Correspondentes.

    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)#ip route 0.0.0.0 0.0.0.0 200.333.xxx.191
    Netfacil-Router(config)#ip route 200.210.xxx.4 255.255.255.252 ip do servidor
    Netfacil-Router(config)#ip route 200.210.xxx.8 255.255.255.252 ip do servidor
    Netfacil-Router(config)#ip route 200.210.xxx.12 255.255.255.252 ip do servidor
    Netfacil-Router(config)#ip route 200.210.xxx.16 255.255.255.252 ip do servidor
    Netfacil-Router(config)#ip route 200.210.xxx.20 255.255.255.252 ip do servidor

    - Der um Ctrl+z para sair
    - Configurada rotas default e rotas de ip´s validos Correspondentes

    5 - Aplicando as Regras "access-list"
    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)# access-list 1 permit 200.200.xxx.0 0.0.0.7
    Netfacil-Router(config)#
    Netfacil-Router(config)#route-map SSS permit 10
    Netfacil-Ro(config-route-map)#
    Netfacil-Ro(config-route-map)#match ip address 1
    Netfacil-Ro(config-route-map)#
    Netfacil-Ro(config-route-map)#set ip next-hop 200.17.xxx.1

    - Der um Ctrl+z para saír da interface
    - Configurada access-list 1, route-map, match e next-hop

    Netfacil-Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Netfacil-Router(config)#
    Netfacil-Router(config)#int f0
    Netfacil-Router(config-if)#ip policy route-map SSS


    ################ ficariam assim as configurações##############

    interface Fastheternet0
    ip address 200.200.xx.1 255.255.255.252 secundary
    ip address 200.210.xxx.1 255.255.255.252
    ip policy route-map SSS
    load-interval 30
    speed 100
    half-duplex
    !
    interface Serial0
    description LINK 2M -
    bandwidth 2048
    ip address 200.333.xx.2 255.255.255.252
    encapsulation HDLC
    load-interval 30
    !
    interface Serial1
    description LINK 2M -
    bandwidth 2048
    ip address 200.333.xx.192 255.255.255.252
    encapsulation ppp
    load-interval 30
    !
    no ip classless
    ip route 0.0.0.0 0.0.0.0 200.333.xxx.191
    ip route 200.210.xxx.4 255.255.255.252 200.210.xxx.2
    ip route 200.210.xxx.8 255.255.255.252 200.210.xxx.2
    ip route 200.210.xxx.12 255.255.255.252 200.210.xxx.2
    ip route 200.210.xxx.16 255.255.255.252 200.210.xxx.2
    ip route 200.210.xxx.20 255.255.255.252 200.210.xxx.2



    no ip http server
    no ip http secure-server
    !
    !
    !
    access-list 1 permit 200.200.xx.0 0.0.0.7
    route-map telemar permit 10
    match ip address 1
    set ip next-hop 201.18.xx.xx


    Espero que esse pequeno tutorial contribuia de alguma forma.
    ######################//#####################
    [email protected]
    Gestor de TI
    Documento sem título

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Muito bom, acho que ajudará vários que tem essa dúvida.

    Sem querer abusar... poderia colocar no wiki?



  3. #3

    Padrão Rota estática...

    Tó com um problemão aki...tenho 2 links da Telemar de 2MB cada um...os dois num Cisco 1721...mas insito com a operadora que eles não estão balanceados...qdo dá horario de pico a net fica lenta...gostaria de fazer o balanceamento por rota estática...
    tenho uma classe de 8 ip..queria dividir ela em duas...

    200.xxx.xxx.0 pool
    200.xxx.xxx.1 roteador
    200.xxx.xxx.2 servidor primario
    200.xxx.xxx.3 broadcast

    200.xxx.xxx.4 pool
    200.xxx.xxx.5 roteador
    200.xxx.xxx.6 servidor secundario
    200.xxx.xxx.7 broadcast

    gostaria que o servidor primario saisse por um link e o secundário pelo segundo link...mas nao to conseguindo...poderia me ajudar...

    link 1 201.18.xxx.42 gw 201.18.xxx.41
    link 2 201.35.xxx.46 gw 201.35.xxx.45

  4. #4

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Muito bom, acho que ajudará vários que tem essa dúvida.

    Sem querer abusar... poderia colocar no wiki?
    muito bom... a idéia de colocar no wiki é interessante mesmo, caso não tenha disposição para tal, outra pessoa pode colocar?

    valeu



  5. #5
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    muito bom... a idéia de colocar no wiki é interessante mesmo, caso não tenha disposição para tal, outra pessoa pode colocar?

    valeu
    Justamente Luciano, se ele autorizar eu mesmo edito lá.

  6. #6

    Padrão

    sergio

    autorizado

    so peço que vc coloque a referencia e o outor.



  7. #7

    Padrão

    terencerocha

    - Eles sempre dizem isso
    - Deve está assim

    fastethernet0
    ip address 201.18.xxx.41 255.255.255.248
    ip address 201.35.xxx.45 255.255.255.248 secondary

    seria0
    ip address 200.00.xxx.0 255.255.255.252

    Seria1
    ip address 200.00.xxx.0 255.255.255.252


    ip route 0.0.0.0 0.0.0.0 s0
    ip route 0.0.0.0 0.0.0.0 s1

    na verdade eles fazem o teste de lá para o seu roteador que por certo eles pingam em uma serial e depois na outra.

    por certo vai esta Ok

    tente da um ping estendido com 17997 no ip da telemar (limite Permitido)
    Lembrando que vc pode criar quantas secundaria vc quiser

  8. #8

    Thumbs down

    Senhores,

    estou tentando implementar algo semanhante ao tutorial, quero fazer o balanceamento de saida de dois links internet num router cisco.. fiz a seguinte configuração só que nao funciona.. alguem sabe o q pode estar acontecendo?

    Informações:

    s0 embratel
    s1 brasiltelecom
    eth0 10.10.10.1/24
    mail server 10.10.0.2
    proxy/ftp server 10.10.0.3

    ---------------------inicio--------------------------------

    int eth0
    ip address 10.10.0.10 255.255.255.0
    ip nat inside

    int s0
    ip adress 200.100.200.2 255.255.255.252
    ip nat outside
    int s1
    ip address 200.100.130.2 255.255.255.252
    ip nat outside

    ip route 0.0.0.0 0.0.0.0 200.100.200.1
    ip route 0.0.0.0 0.0.0.0 200.100.130.1

    ip nat inside source static 10.10.0.3 200.20.7.130 route-map EBT
    ip nat inside source static 10.10.0.2 200.20.7.129 route-map EBT
    ip nat inside source static 10.10.0.3 200.13.15.25 route-map BRT
    ip nat inside source static 10.10.0.2 200.13.15.26 route-map BRT

    access-list 101 permit ip 10.10.0.0 0.0.0.255 any
    access-list 102 permit ip 10.10.0.0 0.0.0.255 any

    route-map EBT
    match ip address 101
    set ip next-hop 200.100.200.1

    route-map BRT
    match ip address 102
    set ip next-hop 200.100.130.1

    ---------------------fim--------------------------------


    At.

    Ferla



  9. #9
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por fsoaress76 Ver Post
    sergio

    autorizado

    so peço que vc coloque a referencia e o outor.
    fsoares tá lá.

    Depois verifica e veja se existem erros ou algo que possa melhorar.

    https://under-linux.org/wiki/index.p...s_-_Cisco_1721
    Última edição por sergio; 14-03-2007 às 19:41.

  10. #10

    Padrão

    valeu "sergio"
    #
    #
    ferla
    vc está com duas rotas default
    So fuciona se for da mesma operador, e a operadora que balanciamento para vc.