+ Responder ao Tópico



  1. #1

    Padrão 3,2,1....290MB de memória livre

    caros boa tarde

    Temos aki na empresa um servidor microsiga,rodando sob um red hat e anco de dados db2. o servidor é biprocessado com 2 processadores dual core e tem 4 gb de memória.
    Quando nós ligamos ele,ele sempre tem 1.5 Gb de memoria, e horas depois,ele estava com 500 livre...horas depois,ele estava com 50 livre,de repente ...3,2,1 mb livre(se entrar pra swap,o microsiga cai!!!),meu chefe fez uma tranferencia simples de arquivos entre o note dele e este servidor,e,como s efosse num passe de magica, a memória foi pra 290 mb livre.Nem precisa dizer q ficamos no mínimo,intrigados...demos um updatedb,e a memória livre foi pra 500 mb.

    O db estah configurado pra usar no máximo 1,2 Gb de memória, eo microsiga usa em média 400 mb de memória .

    Alguém já passou por uma situação dessas? Eu acredito que seja algum problema no sistema,que não está dando refresh na memória disponível,algo assim...


    Flws!

  2. #2

    Smile

    Se eu estivesse no seu lugar recompilaria o kernel e especificando o tamanho atual da memoria e outras configurações voltadas a memoria do servidor.

    é só uma ideia.



  3. #3

    Padrão

    ola..essa máquina provavelmente não tem um kernel customizado.pode ser uma alternativa,mas pq vc acha que pode ser isso?

  4. #4

    Padrão

    exatamente, tive um problema desse em um servidor de um cliente..

    ele isntalou o slackware 10.2 com kernel 2.4.x padrao do slack..

    o que aconteceu foi que depois de um tempo ele me reclama que oservidor estava muito lento... etc etc

    fui analisar, o linux estava consumindo 2gb de swap... e.. para minha surpresa, o kernel 2.4 estava detectando apenas 900mb de ram (o servidor tinha 2gb) ..

    entao recompilei o kernel, coloquei o 2.6.20 ... alterei as configurações dea cordo com o processador do servidor, etc etc.. removi driver USB, firewire, isdn, som.. etc etc...

    o servidor agora esta 100% ... muito rapido, o acesso melhorou muitoooo !!!

    talvez voce deva recompilar o kernel ... com highmem para 64G (serie 2.6 recomendo)