+ Responder ao Tópico



  1. Pessoal,
    Sou meio novo em Linux e gostaria de ajuda para instalar o Squid 2.6 em um conectiva 10, onde já esta instalada a versão 2.5.
    Baixei o arquivos Stable10 e segui as instruções do install:
    ./configure
    make
    make install
    Apesar disso, o comando rpm -q squid continua informando que a versão é a 2.5.5...
    O que mais devo fazer?

    Obrigado,
    Paulo.

  2. Parceiro faz o seguinte remove a versão antiga e instala depois a outra

    Código :
    rpm -e squid

    Se você instalou via apt-get

    Execute o comando:

    Código :
    #apt-get remove squid
    Última edição por lucianogf; 09-03-2007 às 01:46.



  3. você pode verificar qual versão está instalada pelo comando:

    Código :
    squid -v

    se não der com "v" minúsculo tenta com "V" maiúsculo..

    mas tem um porém também, você simplesmente deu um ./configure, para poder funcionar várias opções do squid 2.6 é preciso passar várias flags ao configure...

    segue abaixo o que usei pra compilar o squid:

    Código :
    ./configure  \
    --prefix=/usr \
    --exec_prefix=/usr/sbin \
    --bindir=/usr/sbin \
    --sbindir=/usr/sbin \
    --libexecdir=/usr/lib/squid \
    --sysconfdir=/etc/squid \
    --localstatedir=/var/spool/squid \
    --datadir=/usr/share/squid \
    --enable-async-io \
    --enable-storeio=ufs,aufs,diskd,null \
    --enable-linux-netfilter \
    --enable-arp-acl \
    --enable-removal-policies=lru,heap \
    --enable-snmp \
    --enable-delay-pools \
    --enable-htcp \
    --enable-poll \
    --enable-cache-digests \
    --enable-underscores \
    --enable-referer-log \
    --enable-useragent-log \
    --enable-auth=basic,digest,ntlm \
    --enable-carp \
    --enable-diskd \
    --enable-icmp \
    --enable-ssl \
    --enable-default-err-language=Portuguese \
    --enable-tproxy \
    --with-pthreads \
    --with-large-files

    isso deixa o squid compilado quase com todas as suas opções de configuração...

    valeu

  4. Colegas,
    A versão do squid mostrada é 2.5.stable12.
    Eu realmente não forneci nenhum parâmetro ao ./configure.
    Ao fazer o ./configure novamente com os parâmetros, é necessário desinstalar a versão anterior antes?
    Desculpe, mas tenho que fazer a intalação com o máximo de certeza possível que vai funcionar, pois, se a net parar, eu tô danado.

    Obrigado,
    Paulo.



  5. cara...

    é interessante desinstalar a versão anterior..

    pra net não parar, é só vc tirar o redirecionamento para o proxy, dessa forma os clientes continuarão navegando enquanto vc instalar, configura e testa o squid novo... quando estiver rodando beleza vc volta o redirecionamento..






Tópicos Similares

  1. Como ativo o TFTP no Conectiva 10?
    Por georgemattos no fórum Servidores de Rede
    Respostas: 2
    Último Post: 21-06-2005, 00:33
  2. Como instalar o cbq no slackware 10.1
    Por rfm no fórum Servidores de Rede
    Respostas: 22
    Último Post: 20-06-2005, 11:20
  3. como instalar suporte mppe no conectiva 10, kernel 2.6.10?
    Por lampih no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-05-2005, 12:29
  4. como instalar o openoffice no conectiva 8.0??????
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 23-10-2003, 11:01
  5. como instalar um cluster em conectiva linux 8
    Por Leyzem no fórum Servidores de Rede
    Respostas: 9
    Último Post: 13-02-2003, 17:51

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L