Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Mensagem somente p/ cliente em débito. Tem como?

    Tenho clientes em atraso de mensalidade e queria saber se tem como eu editar algum arquivo HTML para quando ESTE CLIENTE EM ATRASO logar no sistema sair um aviso somente para ele avisando que se ele nao quitar será bloqueado.

    ou seja para ficar mais simples, editar um pop-up ligado ao IP+MAC do cliente.



    Obrigado pela atenção!

  2. #2

    Padrão

    Tem sim, se tiver um server linux, basicamente vc vai redirecionar a porta 80 do cliente para um porta que a pagina de debito esta rodando. Da uma pesquisada de como configurar o apache para rodar em + uma porta que não seja a 80.



    Citação Postado originalmente por ccampus Ver Post
    Tenho clientes em atraso de mensalidade e queria saber se tem como eu editar algum arquivo HTML para quando ESTE CLIENTE EM ATRASO logar no sistema sair um aviso somente para ele avisando que se ele nao quitar será bloqueado.

    ou seja para ficar mais simples, editar um pop-up ligado ao IP+MAC do cliente.



    Obrigado pela atenção!



  3. #3

    Padrão

    Eu nao tenho servidor Linux achei que nao tinha necessidade já que possuo um servidor com o MK.

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Imagino eu, que se puder marcar/criar alguma flag para os IPs que estão com DROP para navegação possa encaminhá-los para uma página do hotspot específica.



  5. #5

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Imagino eu, que se puder marcar/criar alguma flag para os IPs que estão com DROP para navegação possa encaminhá-los para uma página do hotspot específica.
    Como fazer isso? Sou marinheiro de primeira viagem

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por ccampus Ver Post
    Como fazer isso? Sou marinheiro de primeira viagem
    Sem querer ser grosseiro, mas para fazer só lendo a documentação. Sei que o MT é um software under Linux e como tal utiliza-se de uma série de ferramentas disponíveis no Linux, de forma adaptada para um padrão deles, mas basicamente aceita marcações de pacotes, criação de regras de firewall, redirecionamento de portas, entre outros; desta forma é estudar e compreender como funciona essas questões e criar as regras.

    Se fosse no Linux, você definiria um arquivo txt ou BD com o nome do cliente, seu status (aberto/fechado), o IP e o MAC, por exemplo. Com base neste arquivo criaria-se as regras do iptables onde de acordo com status tal o ip tal é redirecionado para o servidor tal (ip-porta) onde teria um apache com a página do aviso escutando.

    Para fazer isto no MT, acho que a idéia seria através da configuração de uma página tipo a alogin.html do hotspot e quando o usuário tal com uma flag XYZ tentasse conectar redirecionaria para esta html com o aviso.

    Bom a idéia é essa, como implementá-la... só estudando.



  7. #7

    Padrão

    Sérgio...
    realmente é muito complicado, estou a dias estudando uma maneira de fazer isso usando telas do proprio hotspot, mas não consegui ainda. Estou tentando, assim que conseguir coloco aqui pra galera .........

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Sérgio...
    realmente é muito complicado, estou a dias estudando uma maneira de fazer isso usando telas do proprio hotspot, mas não consegui ainda. Estou tentando, assim que conseguir coloco aqui pra galera .........
    RPS, o MT não tem um Radius embutido? Poderia configurar uma flag lá e de acordo com a mesma jogar a html do aviso.



  9. #9

    Padrão

    Boa idéia Sérgio, vou tentar por ae. Qualquer colaboração sua será bem vinda. Já tento isso a dias e sem sucesso. Valeu

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Boa idéia Sérgio, vou tentar por ae. Qualquer colaboração sua será bem vinda. Já tento isso a dias e sem sucesso. Valeu
    RPS, idéias eu tenho, o problema é tempo... quase nenhum. Imagino que, daqui umas duas semanas, estarei com um MT direto no meu escritório (na verdade o equipamento já está, mas como falei; o tempo não colabora), uma routerboard 112 com R5, ai sim poderei fazer testes e configurações com o mesmo.



  11. #11

    Padrão

    Aqui eu tenho um profile chamado de "chato", este profile mostra para o clientes em debito uma pagina q pede p ele entrar em contato com o escritorio, ativei a aba advertisement e indiquei a pagina q contem a mensagem para o cliente em debito, toda vez q o cliente digitar uma url a pagina chata apareçe.
    Última edição por 2KILLER2; 12-03-2007 às 00:52.

  12. #12

    Padrão

    Citação Postado originalmente por 2KILLER2 Ver Post
    Aqui eu tenho um profile chamado de "chato", este profile mostra para o clientes em debito uma pagina q pede p ele entrar em contato com o escritorio, ativei a aba advertisement e indiquei a pagina q contem a mensagem para o cliente em debito, toda vez q o cliente digitar uma url a pagina chata apareçe.

    Amigo como voce fez isso? venho tentando a tempos e nao da certo.. fiz uma pagina html no dreamweaver com o aviso de debito, hospedei no meu proprio mikrotik, dentro da pasta hotspot.. configurei o advertisement para o ip do mikrotik (http://192.168.2.254/hotspot/aviso.html) porem ele nao abre a pagina de aviso.. oq pode ser?



  13. #13

    Padrão

    Citação Postado originalmente por gsiena Ver Post
    Amigo como voce fez isso? venho tentando a tempos e nao da certo.. fiz uma pagina html no dreamweaver com o aviso de debito, hospedei no meu proprio mikrotik, dentro da pasta hotspot.. configurei o advertisement para o ip do mikrotik (http://192.168.2.254/hotspot/aviso.html) porem ele nao abre a pagina de aviso.. oq pode ser?


    ?????????? tambem tenho interesse na resposta ...rss

  14. #14

    Padrão

    Citação Postado originalmente por maxtex Ver Post
    ?????????? tambem tenho interesse na resposta ...rss
    Primeiro você cria uma entrada de dns statica em IP DNS (ex: provedor.com.br) no campo address coloque o gateway do hotspot.
    depois vc cria um profile com essa config:

    / ip hotspot user profile
    add name="debito" session-timeout=20s idle-timeout=none \
    keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    rate-limit="64k/64k" transparent-proxy=yes open-status-page=always \
    advertise=yes advertise-url=provedor.com.br/radvert.html \
    advertise-interval=1s advertise-timeout=never

    aqui eu sempre reduzo a banda do cliente em debito para a metade.

    PS: não esqueça de editar a pagina radvert.html.



  15. #15

    Padrão

    Isso é muito bom, valeu 2killer2 pela grande dica, vou testar ......

  16. #16

    Padrão

    amigo vc utiliza hotspot ou pppoe pq no hotspot tem como fazer isso sim a mensagem de debito, "inclusive colocar para aparecer tipo de 10 em 10 minutos para o cliente"



  17. #17

    Padrão

    desculpa num tinha visto o ultimo topico..... era dessa forma ai que ia explicar .... no hotspot


    Citação Postado originalmente por kramal Ver Post
    amigo vc utiliza hotspot ou pppoe pq no hotspot tem como fazer isso sim a mensagem de debito, "inclusive colocar para aparecer tipo de 10 em 10 minutos para o cliente"

  18. #18

    Padrão

    Citação Postado originalmente por 2KILLER2 Ver Post
    Primeiro você cria uma entrada de dns statica em IP DNS (ex: provedor.com.br) no campo address coloque o gateway do hotspot.
    depois vc cria um profile com essa config:

    / ip hotspot user profile
    add name="debito" session-timeout=20s idle-timeout=none \
    keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    rate-limit="64k/64k" transparent-proxy=yes open-status-page=always \
    advertise=yes advertise-url=provedor.com.br/radvert.html \
    advertise-interval=1s advertise-timeout=never

    aqui eu sempre reduzo a banda do cliente em debito para a metade.

    PS: não esqueça de editar a pagina radvert.html.
    Eu fiz isso só que só a abre a página de Aviso!!! o cara nao consegue navegar, e eu queria que meu cliente navegasse mas que ficasse aparecendo a mensagem de 10 em 10 min, tem como fazer isso?

    Obrigado



  19. #19

    Padrão

    Citação Postado originalmente por ccampus Ver Post
    Eu fiz isso só que só a abre a página de Aviso!!! o cara nao consegue navegar, e eu queria que meu cliente navegasse mas que ficasse aparecendo a mensagem de 10 em 10 min, tem como fazer isso?

    Obrigado
    Sim é perfeitamente possivel.. aqui fiz assim e funcionou 100%:

    /ip hotspot user profile add name="clientes-debito" session-timeout=1h keepalive-timeout=2m status-autorefresh=1m shared-users=unlimited transparent-proxy=yes open-status-page=always advertise=yes advertise-url=http://192.168.2.254/aviso.html advertise-interval=10m advertise-timeout=never

    Só muda a url ai.. peguei essa minha de exemplo. Detalhe: se o cliente tiver um bloqueador de popup, o aviso nao vai aparecer a nao ser que seja autorizada a exibição do popup (depende do cliente clicar la e autorizar). Testa ai e posta pra dizer se deu certo

  20. #20

    Padrão Bridge

    Será que é possivel fazer isso com o mkt configurado como bridge