Como ter múltiplos web servers em uma rede com mikrotik

Isso só funciona com conexões HTTP e não com conexões HTTPS, justamente porque o web-proxy não suporta conexões HTTPS.


123.com@192.168.0.2
abc.com@192.168.0.3
456.com@192.168.0.4

Passos

1º Configurar o seu web-proxy -->




/ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
transparent-proxy=yes parent-proxy=0.0.0.0:0 \
cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
max-cache-size=unlimited max-ram-cache-size=unlimited
/ip web-proxy access
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
disabled=no
add dst-port=80 action=allow comment="Enable Http Connection" disabled=no



2. Configurar DNS estatico com as informções de dominio para que se faça a resolução do ip

/ip dns static add name=123.com address=192.168.0.2
/ip dns static add name=abc.com address=192.168.0.3
/ip dns static add name=456.com address=192.168.0.4
/ip dns static add name=www.123.com address=192.168.0.2
/ip dns static add name=www.abc.com address=192.168.0.3
/ip dns static add name=www.456.com address=192.168.0.4



3. Agora configure o nat para redirecionar o trafico para a Web-Proxy.

/ip firewall nat
add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
dst-port=80 action=redirect to-ports=8080 comment="" disabled=no
O trafico para o 123.com vai ficar dessa maneira

O Web-Proxy vai derecionar o trafico para 123.com que internamente é o ip com o endereço 192.168.0.2

Internet --> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 --> 192.168.0.2:80


Bom pessoal esse artigo estava na Wiki mas em outra lingua espero ter dado um help para quem queria fazer isso