Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Saudações galera, então estou com um probleminha no meu servidor. Eu tinha o apache + php rodando nele perfeitamente, um dia restartei a maquina e surpresa, nao funcionava mais apache nem PHP, fui tentar reinstalar tudo(remover e instalar denovo os pacotes), comecei pelo do PHP, foi perfeito, quando cheguei no apache2 ele dá a segunte mensagem:

    fatecorg:/# apt-get install apache2
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following NEW packages will be installed:
    apache2
    0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
    Need to get 0B/33.5kB of archives.
    After unpacking 81.9kB of additional disk space will be used.
    Selecting previously deselected package apache2.
    (Reading database ... 16588 files and directories currently installed.)
    Unpacking apache2 (from .../apache2_2.0.54-5sarge1_i386.deb) ...
    Setting up apache2 (2.0.54-5sarge1) ...
    fatecorg:/#

    E não instala(não sei se nao instala ou o que, só sei que nao funciona) o apache, alguém sabe me dizer o por que?

    VAleu pela atenção!

  2. Vc acha que ele não está instalado pq? não está achando os scripts de inicialização? Arquivos de configuração??? ....??



  3. /# ls etc/init.d/
    atd hotplug-net mountall.sh README
    bootclean.sh hwclockfirst.sh mountnfs.sh reboot
    bootlogd hwclock.sh mountvirtfs rmnologin
    bootmisc.sh ifupdown mysql sendsigs
    checkfs.sh ifupdown-clean mysql.dpkg-dist single
    checkroot.sh inetd mysql-ndb skeleton
    console-screen.sh initrd-tools.sh mysql-ndb-mgm ssh
    cron keymap.sh networking stop-bootlogd
    discover klogd nviboot sysklogd
    dns-clean libdevmapper1.01 ppp umountfs
    exim4 libdevmapper1.02 pppd-dns umountnfs.sh
    glibc.sh lvm procps.sh urandom
    halt makedev proftpd
    hostname.sh module-init-tools rc
    hotplug modutils rcS


    Ele nem na inicialização se encontra.

    Gostaria de saber como remover ele e todas dependencias dele e instalar ele do zero novamente.

  4. Você tem que instalar também os pacotes referentes ao PHP.

    Código :
    # apt-get install php4


    Abraços!



  5. Código :
    /# apt-get install php4
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following extra packages will be installed:
      apache2-mpm-prefork libapache-mod-php4 libapache2-mod-php4 php4-common
    Suggested packages:
      php-pear php4-pear
    The following packages will be REMOVED:
      apache2-mpm-worker
    The following NEW packages will be installed:
      apache2-mpm-prefork libapache2-mod-php4 php4
    The following packages will be upgraded:
      libapache-mod-php4 php4-common
    2 upgraded, 3 newly installed, 1 to remove and 2 not upgraded.
    Need to get 3483kB/3686kB of archives.
    After unpacking 3424kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://packages.dotdeb.org stable/all libapache-mod-php4 4:4.4.6-0.dotdeb.2 [1640kB]
    Get:2 http://packages.dotdeb.org stable/all php4-common 4:4.4.6-0.dotdeb.2 [202kB]
    Get:3 http://packages.dotdeb.org stable/all libapache2-mod-php4 4:4.4.6-0.dotdeb.2 [1641kB]
    Get:4 http://packages.dotdeb.org stable/all php4 4:4.4.6-0.dotdeb.2 [1152B]
    Fetched 3483kB in 1m8s (51.1kB/s)
    dpkg: apache2-mpm-worker: dependency problems, but removing anyway as you request:
     apache2 depends on apache2-mpm-worker (= 2.0.54-5sarge1) | apache2-mpm-prefork (= 2.0.54-5sarge1) | apache2-mpm-perchild (= 2.0.54-5sarge1); however:
      Package apache2-mpm-worker is to be removed.
      Package apache2-mpm-prefork is not installed.
      Package apache2-mpm-perchild is not installed.
    (Reading database ... 16590 files and directories currently installed.)
    Removing apache2-mpm-worker ...
    invoke-rc.d: unknown initscript, /etc/init.d/apache2 not found.
    dpkg: error processing apache2-mpm-worker (--remove):
     subprocess pre-removal script returned error exit status 100
    Errors were encountered while processing:
     apache2-mpm-worker
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    fatecorg:/# apt-get install apache2-mpm-worker
    Reading Package Lists... Done
    Building Dependency Tree... Done
    apache2-mpm-worker is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

    Ele requer o apache lá na inicialização!






Tópicos Similares

  1. Apache + JSP
    Por joe_fox no fórum Servidores de Rede
    Respostas: 4
    Último Post: 13-08-2002, 05:20
  2. Redirecionamento com apache
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-08-2002, 15:24
  3. Apache
    Por gonzo no fórum Servidores de Rede
    Respostas: 2
    Último Post: 31-07-2002, 16:40
  4. Estatísticas no apache
    Por ediguedes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-07-2002, 10:56
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L