Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá galera, estou com o seguinte problema instalei o no-ip em meu servidor de internet para que os usuarios do software tenhãm acesso externo.
    tenho um:
    pentium 3 1000 , 256mb ,
    Velox de 600k
    slacware 10.2
    squid
    iptables

    e o software responde na porta 1000, e eu não estou conseguindo fazer o servidor do banco de dados que fica por traz do firewall responder.
    para que o software funcione eu só preciso nrmalmente que tenha o ip e a porta do servidor interno 10.10.11.100:1000 mas para ele passar por dentro do firewall com o no-ip eu não estou conseguindo.
    Alguem pode me ajudar?

  2. O serviço que vc quer disponibilizar está na mesma máquina que recebe o Velox e tem o no-ip instalado? Caso positivo, basta abrir a porta que vc quer no firewall.
    Caso não esteja, vc deve redirecionar o tráfego da porta que vc utiliza (no caso a 1000) para o IP do micro em que o software está instalado.
    Se não lhe ajudar, poste maiores detalhes do seu caso.



  3. Vamos devagar, agente resolve isso tranquilo, se vc instalou o no-ip sem dificuldades já um grande passo porque quando eu comecei a testar no-ip eu levei um banho pra botar pra funcionar, mas descobrir que lendo o help do programa faço em 10 segundos essa parada funcionar, agora é só festa.

    O sistema é de interface web?
    Se sim, o software obrigatóriamente precisa ser tb um servidor web e rodar sobre a porta 1000 aí vc vai ter que fazer um DNAT para a porta 1000 e liberar a porta 1000 na chain FORWARD, beleza.

    O sistema é desktop e fica em um servidor microsoft e os usuários acessam esta máquina vi TS?
    Se sim. Aí tem que fazer um DNAT para porta 3389 e tem que liberar porta 3389 na chain FORWARD.

    Essas são as primeiras coisas. Depois...

    Vc vai ter que ir no router e fazer um redirecionamento de porta das portas dos aplicativos/serviços para o teu Linux 1000 ou 3389 isso se seu modem for roteado, caso vc use protocolo ppp ou seja teu Linux disque e use modem como brige não precisa fazer redireciomento de portas.

    por enquanto é isso posta mais coisas que agente vai tentando abraços.

  4. Citação Postado originalmente por vioflas Ver Post
    Vamos devagar, agente resolve isso tranquilo, se vc instalou o no-ip sem dificuldades já um grande passo porque quando eu comecei a testar no-ip eu levei um banho pra botar pra funcionar, mas descobrir que lendo o help do programa faço em 10 segundos essa parada funcionar, agora é só festa.

    O sistema é de interface web?
    Se sim, o software obrigatóriamente precisa ser tb um servidor web e rodar sobre a porta 1000 aí vc vai ter que fazer um DNAT para a porta 1000 e liberar a porta 1000 na chain FORWARD, beleza.

    O sistema é desktop e fica em um servidor microsoft e os usuários acessam esta máquina vi TS?
    Se sim. Aí tem que fazer um DNAT para porta 3389 e tem que liberar porta 3389 na chain FORWARD.

    Essas são as primeiras coisas. Depois...

    Vc vai ter que ir no router e fazer um redirecionamento de porta das portas dos aplicativos/serviços para o teu Linux 1000 ou 3389 isso se seu modem for roteado, caso vc use protocolo ppp ou seja teu Linux disque e use modem como brige não precisa fazer redireciomento de portas.

    por enquanto é isso posta mais coisas que agente vai tentando abraços.
    Exatamente por ai, tem que ver em que maquina esta rodando a aplicacaoe depois abrir as portas que ela precisa e redirecionar essas portas do ip do velox para a maquina interna que esta rodando a aplicacao.
    Sou do RS, aqui é a brasil telecom a operadora, portanto não conheço completamente o velox, mas já li vários posts falando que o velox tem as portas altas bloqueadas. Não sei isto ainda acontece, mas poderia verificar isso também, pois esta pode ser uma das portas bloqueadas pelo velox.



  5. É exatamente isso!
    meu no-ip é xxxxxx.no-ip.biz , quando eu ping o meu server responde retorando o numero do ip e como eu estou usando um windows 2003 por tras deste servidor não estou conseguindo redirecionar o serviço.
    vou colocar o meu firewall para vcs analizarem e me ajudarem blz...

    $IPT -t nat -A PREROUTING -s $IPSOURCE -p tcp --dport 80 -j REDIRECT --to-port $SQUID
    $IPT -t nat -A PREROUTING -i ppp0 -j DNAT --to 10.10.11.100

    eu coloquei essa regra logo apos a regra do squid sera que eu fiz certo?






Tópicos Similares

  1. Porta do No-Ip
    Por admskill no fórum Redes
    Respostas: 2
    Último Post: 24-03-2010, 13:22
  2. Estou montando um provedor do zero
    Por Wavila no fórum Redes
    Respostas: 12
    Último Post: 30-03-2007, 12:10
  3. :: Como montar um servidor dns local :: Pelo no-ip
    Por Bruno Lucena no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-03-2006, 10:31
  4. utilizar host do no-ip no iptables
    Por wgalafassijr no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-09-2005, 23:44
  5. preciso urgente de ajuda...pois estou com um problema no meu
    Por no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 17-09-2003, 13:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L