+ Responder ao Tópico



  1. #1

    Padrão Estou levando um baile do no-ip

    Olá galera, estou com o seguinte problema instalei o no-ip em meu servidor de internet para que os usuarios do software tenhãm acesso externo.
    tenho um:
    pentium 3 1000 , 256mb ,
    Velox de 600k
    slacware 10.2
    squid
    iptables

    e o software responde na porta 1000, e eu não estou conseguindo fazer o servidor do banco de dados que fica por traz do firewall responder.
    para que o software funcione eu só preciso nrmalmente que tenha o ip e a porta do servidor interno 10.10.11.100:1000 mas para ele passar por dentro do firewall com o no-ip eu não estou conseguindo.
    Alguem pode me ajudar?

  2. #2

    Padrão

    O serviço que vc quer disponibilizar está na mesma máquina que recebe o Velox e tem o no-ip instalado? Caso positivo, basta abrir a porta que vc quer no firewall.
    Caso não esteja, vc deve redirecionar o tráfego da porta que vc utiliza (no caso a 1000) para o IP do micro em que o software está instalado.
    Se não lhe ajudar, poste maiores detalhes do seu caso.



  3. #3

    Padrão

    Vamos devagar, agente resolve isso tranquilo, se vc instalou o no-ip sem dificuldades já um grande passo porque quando eu comecei a testar no-ip eu levei um banho pra botar pra funcionar, mas descobrir que lendo o help do programa faço em 10 segundos essa parada funcionar, agora é só festa.

    O sistema é de interface web?
    Se sim, o software obrigatóriamente precisa ser tb um servidor web e rodar sobre a porta 1000 aí vc vai ter que fazer um DNAT para a porta 1000 e liberar a porta 1000 na chain FORWARD, beleza.

    O sistema é desktop e fica em um servidor microsoft e os usuários acessam esta máquina vi TS?
    Se sim. Aí tem que fazer um DNAT para porta 3389 e tem que liberar porta 3389 na chain FORWARD.

    Essas são as primeiras coisas. Depois...

    Vc vai ter que ir no router e fazer um redirecionamento de porta das portas dos aplicativos/serviços para o teu Linux 1000 ou 3389 isso se seu modem for roteado, caso vc use protocolo ppp ou seja teu Linux disque e use modem como brige não precisa fazer redireciomento de portas.

    por enquanto é isso posta mais coisas que agente vai tentando abraços.

  4. #4

    Padrão

    Citação Postado originalmente por vioflas Ver Post
    Vamos devagar, agente resolve isso tranquilo, se vc instalou o no-ip sem dificuldades já um grande passo porque quando eu comecei a testar no-ip eu levei um banho pra botar pra funcionar, mas descobrir que lendo o help do programa faço em 10 segundos essa parada funcionar, agora é só festa.

    O sistema é de interface web?
    Se sim, o software obrigatóriamente precisa ser tb um servidor web e rodar sobre a porta 1000 aí vc vai ter que fazer um DNAT para a porta 1000 e liberar a porta 1000 na chain FORWARD, beleza.

    O sistema é desktop e fica em um servidor microsoft e os usuários acessam esta máquina vi TS?
    Se sim. Aí tem que fazer um DNAT para porta 3389 e tem que liberar porta 3389 na chain FORWARD.

    Essas são as primeiras coisas. Depois...

    Vc vai ter que ir no router e fazer um redirecionamento de porta das portas dos aplicativos/serviços para o teu Linux 1000 ou 3389 isso se seu modem for roteado, caso vc use protocolo ppp ou seja teu Linux disque e use modem como brige não precisa fazer redireciomento de portas.

    por enquanto é isso posta mais coisas que agente vai tentando abraços.
    Exatamente por ai, tem que ver em que maquina esta rodando a aplicacaoe depois abrir as portas que ela precisa e redirecionar essas portas do ip do velox para a maquina interna que esta rodando a aplicacao.
    Sou do RS, aqui é a brasil telecom a operadora, portanto não conheço completamente o velox, mas já li vários posts falando que o velox tem as portas altas bloqueadas. Não sei isto ainda acontece, mas poderia verificar isso também, pois esta pode ser uma das portas bloqueadas pelo velox.



  5. #5

    Padrão

    É exatamente isso!
    meu no-ip é xxxxxx.no-ip.biz , quando eu ping o meu server responde retorando o numero do ip e como eu estou usando um windows 2003 por tras deste servidor não estou conseguindo redirecionar o serviço.
    vou colocar o meu firewall para vcs analizarem e me ajudarem blz...

    $IPT -t nat -A PREROUTING -s $IPSOURCE -p tcp --dport 80 -j REDIRECT --to-port $SQUID
    $IPT -t nat -A PREROUTING -i ppp0 -j DNAT --to 10.10.11.100

    eu coloquei essa regra logo apos a regra do squid sera que eu fiz certo?

  6. #6

    Padrão

    cara...

    você fez a regra de redirecionamento de pedidos externos da porta em questão para o serviço desejado?



  7. #7

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    cara...

    você fez a regra de redirecionamento de pedidos externos da porta em questão para o serviço desejado?
    É exatemente esse meu problema eu não sei se eu uso "PREROUTING OU POSTROUTING" se eu uso na interface ou se uso no DNS do no-ip eu não estou sabendo criar a regra já queimei os neuronios e não consegui, vc tem como me dar uma ajuda?

  8. #8

    Padrão

    cara..

    com a regra que você postou:

    Código :
    $IPT -t nat -A PREROUTING -i ppp0 -j DNAT --to 10.10.11.100

    você está redirecionando todo o tráfego para o micro 10.10.11.100, mas se você quer redirecionar apenas o tráfego da porta 1000 não seria apenas isso..., sem contar que apenas essa regra não fará o serviço...

    vamos a um exemplo hipotético:

    eth0 - internet
    eth1 - rede interna ou dmz

    eth0 = 10.0.0.1
    eth1 = 192.168.0.1

    SRV = servidor da aplicação
    SRV = 192.168.0.10
    PORT = porta da aplicação
    PORT = 1000

    Código :
    $IPT -t nat -A PREROUTING -i eth0 -s 0/0 -p tcp -m tcp --dport $PORT -j DNAT --to $SRV:$PORT
    $IPT -t nat -A POSTROUTING -o eth1 -d $SRV -p tcp -m tcp --dport $PORT -j SNAT --to 192.168.0.1
    $IPT -t filter -A FORWARD -p tcp -m tcp --dport 1000 -j ACCEPT
    $IPT -t filter -A FORWARD -p tcp -m tcp --sport 1000 -j ACCEPT

    com estas regras deve funcionar seu serviço, se funcionar é só otimizá-las...



  9. #9

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    cara..

    com a regra que você postou:

    Código :
    $IPT -t nat -A PREROUTING -i ppp0 -j DNAT --to 10.10.11.100

    você está redirecionando todo o tráfego para o micro 10.10.11.100, mas se você quer redirecionar apenas o tráfego da porta 1000 não seria apenas isso..., sem contar que apenas essa regra não fará o serviço...

    vamos a um exemplo hipotético:

    eth0 - internet
    eth1 - rede interna ou dmz

    eth0 = 10.0.0.1
    eth1 = 192.168.0.1

    SRV = servidor da aplicação
    SRV = 192.168.0.10
    PORT = porta da aplicação
    PORT = 1000

    Código :
    $IPT -t nat -A PREROUTING -i eth0 -s 0/0 -p tcp -m tcp --dport $PORT -j DNAT --to $SRV:$PORT
    $IPT -t nat -A POSTROUTING -o eth1 -d $SRV -p tcp -m tcp --dport $PORT -j SNAT --to 192.168.0.1
    $IPT -t filter -A FORWARD -p tcp -m tcp --dport 1000 -j ACCEPT
    $IPT -t filter -A FORWARD -p tcp -m tcp --sport 1000 -j ACCEPT

    com estas regras deve funcionar seu serviço, se funcionar é só otimizá-las...

    Com isso eu posso criar as variaveis para a regra tambem, blz
    mais uma ultima pergunta, eu coloco essa regra depois ou antes da regra do proxy?

  10. #10

    Padrão

    Desculpe-me se estou sendo iguinorante, depois de um tempo que le seu post fiquei com uma duvida, se era melhor:
    Qual é a melhor interface para deixar esctando?

    EX 1:
    $IPT -t nat -A PREROUTING -i eth0 -s 0/0 -p tcp -m tcp --dport $PORT -j DNAT --to $SRV:$PORT
    EX 2:
    $IPT -t nat -A PREROUTING -i ppp0 -s 0/0 -p tcp -m tcp --dport $PORT -j DNAT --to $SRV:$PORT
    EX 3:
    $IPT -t nat -A PREROUTING -i (OU O DNS DO NO-IP) -s 0/0 -p tcp -m tcp --dport $PORT -j DNAT --to $SRV:$PORT
    Me desenrole mais essa vez?