+ Responder ao Tópico



  1. olá.
    Estou tentando criar um sistema de Raid 1 com Slackware 11. Já criei uma partição com ID fd (Linux raid autodetect) no HD "espelho" e criei o arquivo /etc/raidtab.
    Está instalado na máquina o raidtools e o mdadm.

    Quando digito o comando mkraid /dev/md0, o sistema me retorna o seguinte erro:

    cannot determine md version: 25.

    Meu arquivo /etc/raidtab está da seguinte forma:

    raiddev /dev/md0
    raid-level 1
    nr-raid-disks 2
    nr-spare-disks 0
    chunk-size 4

    device /dev/hda2
    raid-disk 0

    device /dev/hdb2
    raid-disk 1

    Alguém sabe me dizer como posso solucionar este problema?

    Muito obrigado

  2. Me diz uma coisa vc criou a partição Linux raid autodetect no hd principal tbem.


    Citação Postado originalmente por slackman Ver Post
    olá.
    Estou tentando criar um sistema de Raid 1 com Slackware 11. Já criei uma partição com ID fd (Linux raid autodetect) no HD "espelho" e criei o arquivo /etc/raidtab.
    Está instalado na máquina o raidtools e o mdadm.

    Quando digito o comando mkraid /dev/md0, o sistema me retorna o seguinte erro:

    cannot determine md version: 25.

    Meu arquivo /etc/raidtab está da seguinte forma:

    raiddev /dev/md0
    raid-level 1
    nr-raid-disks 2
    nr-spare-disks 0
    chunk-size 4

    device /dev/hda2
    raid-disk 0

    device /dev/hdb2
    raid-disk 1

    Alguém sabe me dizer como posso solucionar este problema?

    Muito obrigado



  3. Não...o HD principal está particionado normalmente (ext3).

    Na verdade, essa máquina já estava "em produção", mas por medida de segurança, coloquei um novo HD e só queria fazer o espelhamento de uma das partições.

  4. #4
    estanisgeyer
    Se você quer espelhar, você precisa ter a partição como Raid também, pois como vc vai fazer seu array? Não é possível fazer com ext3 apenas. Você pode habilitar seu hd novo como Raid e depois copiar as informações para esse hd. Após copiado, refaça as partições no seu hd como Raid e coloque no ramo e mande reconstruir seu ramo.



  5. Fiz back up de tudo que estava no HD "velho" e refiz a partição dos dados como 'fd' , fiz o array (mkraid /dev/md0), formatei e montei as partições.....aparentemente está tudo certo.
    Obrigado!






Tópicos Similares

  1. Problemas com RAID no DEBIAN
    Por GeovaneRoberto no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 19-08-2010, 13:48
  2. Problemas com RAID 0 - Hd nao é reconhecido.
    Por alubale no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 13-02-2009, 21:05
  3. Problemas com Raid via software
    Por LinuxKids no fórum Servidores de Rede
    Respostas: 2
    Último Post: 16-02-2007, 12:06
  4. Problemas com raid 1 suse 10
    Por marceloedrei no fórum Sistemas Operacionais
    Respostas: 20
    Último Post: 17-11-2005, 07:50
  5. Problema com RAID
    Por fabricio_ no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-07-2005, 10:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L