+ Responder ao Tópico



  1. Pessoal hoje por volta da hora do almoço meu servidor começou a gera um load de cpu, ocasionado pelo seguinte problema abaixo descrito.
    ###########LOG PPPOE
    Apr 19 11:45:11 servpppoe pppoe-server[19625]: Session 522 created for client 00:83:08:00:ea:72 (192.168.10.27) on eth2 using Service-Name ''
    Apr 19 11:45:11 servpppoe pppoe-server[19626]: Session 693 created for client 00:83:08:00:ea:72 (192.168.13.12) on eth2 using Service-Name ''
    Apr 19 11:45:11 servpppoe pppd[19625]: Plugin /etc/ppp/plugins/rp-pppoe.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19625]: RP-PPPoE plugin version 3.8 compiled against pppd 2.4.3
    Apr 19 11:45:11 servpppoe pppd[19625]: Plugin radius.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19625]: RADIUS plugin initialized.
    Apr 19 11:45:11 servpppoe pppd[19625]: Plugin radattr.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19625]: RADATTR plugin initialized.
    Apr 19 11:45:11 servpppoe pppd[19626]: Plugin /etc/ppp/plugins/rp-pppoe.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19626]: RP-PPPoE plugin version 3.8 compiled against pppd 2.4.3
    Apr 19 11:45:11 servpppoe pppd[19625]: pppd 2.4.3 started by root, uid 0
    Apr 19 11:45:11 servpppoe pppd[19625]: Connected to 00:83:08:00:ea:72 via interface eth2
    Apr 19 11:45:11 servpppoe pppd[19626]: Plugin radius.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19626]: RADIUS plugin initialized.
    Apr 19 11:45:11 servpppoe pppd[19626]: Plugin radattr.so loaded.
    Apr 19 11:45:11 servpppoe pppd[19626]: RADATTR plugin initialized.
    Apr 19 11:45:11 servpppoe pppd[19625]: Using interface ppp455
    Apr 19 11:45:11 servpppoe pppd[19625]: Connect: ppp455 <--> eth2
    Apr 19 11:45:11 servpppoe pppd[19625]: Couldn't increase MTU to 1500
    Apr 19 11:45:11 servpppoe pppd[19625]: Couldn't increase MRU to 1500
    Apr 19 11:45:11 servpppoe pppd[19626]: pppd 2.4.3 started by root, uid 0
    Apr 19 11:45:11 servpppoe pppd[19626]: Connected to 00:83:08:00:ea:72 via interface eth2
    Apr 19 11:45:11 servpppoe pppd[19626]: Using interface ppp501
    Apr 19 11:45:11 servpppoe pppd[19626]: Connect: ppp501 <--> eth2
    Apr 19 11:45:11 servpppoe pppd[19626]: Couldn't increase MTU to 1500
    Apr 19 11:45:11 servpppoe pppd[19626]: Couldn't increase MRU to 1500
    Apr 19 11:45:11 servpppoe pppd[19625]: Couldn't increase MRU to 1500
    Apr 19 11:45:11 servpppoe pppd[19625]: PAP peer authentication succeeded for user@provedor
    Apr 19 11:45:11 servpppoe pppd[19625]: peer from calling number 00:83:08:00:EA:72 authorized
    Apr 19 11:45:11 servpppoe pppd[19625]: local IP address 200.200.200.201
    Apr 19 11:45:11 servpppoe pppd[19625]: Connect time 0.0 minutes.
    Apr 19 11:45:11 servpppoe pppd[19625]: Sent 0 bytes, received 48 bytes.
    Apr 19 11:45:11 servpppoe pppd[19625]: local IP address 200.200.200.201
    Apr 19 11:45:11 servpppoe pppd[19625]: remote IP address 201.0.0.1
    Apr 19 11:45:11 servpppoe pppd[19625]: Sent 0 bytes, received 22 bytes.
    Apr 19 11:45:12 servpppoe pppd[19625]: local IP address 200.200.200.201
    Apr 19 11:45:12 servpppoe pppd[19625]: remote IP address 201.0.0.1
    Apr 19 11:45:12 servpppoe pppd[19625]: Connect time 0.0 minutes.
    #assim ele ficou por um bom tempo dando isso no log
    Apr 19 11:45:12 servpppoe pppd[19625]: rc_check_reply: received non-matching id in RADIUS server response
    Apr 19 11:45:12 servpppoe pppd[19625]: Accounting STOP failed for user@provedor
    Apr 19 11:45:12 servpppoe pppd[19625]: Connect time 0.0 minutes.
    Apr 19 11:45:12 servpppoe pppd[19625]: Sent 0 bytes, received 0 bytes.
    Apr 19 11:45:12 servpppoe pppd[19625]: local IP address 200.200.200.201
    Apr 19 11:45:12 servpppoe pppd[19625]: remote IP address 201.0.0.1
    Apr 19 11:46:52 servpppoe pppd[16405]: No response to 5 echo-requests
    Apr 19 11:46:52 servpppoe pppd[16405]: Serial link appears to be disconnected.
    Apr 19 11:46:52 servpppoe pppd[16405]: Connect time 38.4 minutes.
    Apr 19 11:46:52 servpppoe pppd[16405]: Sent 1241587 bytes, received 271195 bytes.
    Apr 19 11:46:52 servpppoe pppd[16405]: Couldn't increase MTU to 1500
    Apr 19 11:46:52 servpppoe pppd[16405]: Couldn't increase MRU to 1500
    Apr 19 11:46:54 servpppoe pppoe-server[3923]: PADT for session 350 received from 00:C0:02:FE:18:B1; should
    be from 00:4F:62:0A:04:AF
    Apr 19 11:46:56 servpppoe pppoe-server[3926]: PADT: Generic-Error: RP-PPPoE: Session 1364: Packet too short from PPP (asyncReadFromPPP)
    Apr 19 11:46:56 servpppoe pppoe-server[3926]: PADT: Generic-Error: ¨\226| iõ5âDEµ Ú\211^VH\200V^O
    Apr 19 11:46:56 servpppoe pppoe-server[3926]: Sent PADT
    Apr 19 11:46:56 servpppoe pppd[13455]: Terminating on signal 15
    Apr 19 11:46:56 servpppoe pppd[13455]: Connect time 83.5 minutes.
    Apr 19 11:46:56 servpppoe pppd[13455]: Sent 2529170 bytes, received 4603298 bytes.
    Apr 19 11:46:57 servpppoe pppd[13455]: Couldn't increase MTU to 1500
    Apr 19 11:46:57 servpppoe pppd[13455]: Couldn't increase MRU to 1500
    ===>>Continua até uma 12:00 PM ae para Voltando apartir da 12:10 PM
    Apr 19 12:10:33 servpppoe pppd[32594]: Accounting START failed for user@provedor
    Apr 19 12:10:33 servpppoe pppd[32594]: Connect time 0.0 minutes.
    Apr 19 12:10:33 servpppoe pppd[32594]: Sent 0 bytes, received 22 bytes.
    Apr 19 12:10:33 servpppoe pppd[32594]: local IP address 200.200.200.201
    Apr 19 12:10:33 servpppoe pppd[32594]: remote IP address 201.0.0.1
    ==> Terminio do log 12:45
    ##############LOG Servidor RADIUS
    Abr 19 11:45:11 Auth.notice: (Access-Request 10.52.1.1 123 "user@provedor" CLID=00:83:08:00:EA:72):
    Login OK [user@provedor]
    Abr 19 11:45:11 Acct.warning: (Accounting-Request 10.52.1.1 129 "user@provedor" CLID=00:83:08:00:EA:72): acct_stop_query updated 0 records
    Abr 19 11:45:12 Acct.notice: (Accounting-Request 10.52.1.1 134 "user@provedor" CLID=00:83:08:00:EA:72): Retransmitting ACCT reply
    Abr 19 11:45:16 Acct.info: login: entry for NAS 10.52.1.1 port 455 duplicate
    Abr 19 11:46:14 Acct.warning: (Accounting-Request 10.52.1.1 179 "user@provedor" CLID=00:83:08:00:EA:72): acct_stop_query updated 0 records
    Abr 19 11:46:14 Acct.info: login: entry for NAS 10.52.1.1 port 455 wrong order
    Abr 19 11:46:15 Acct.info: login: entry for NAS 10.52.1.1 port 455 duplicate
    Abr 19 12:34:23 Acct.notice: (Accounting-Request 10.52.1.1 247 "user@provedor" CLID=00:83:08:00:EA:72): Retransmitting ACCT reply
    Abr 19 13:33:48 Acct.info: Child exiting on timeout.
    Abr 19 13:33:48 Main.notice: child 6610 exited with status 0
    Abr 19 13:33:53 Acct.info: Child exiting on timeout.
    Abr 19 13:33:53 Main.notice: child 6345 exited with status 0
    Pessoal se Alguem puder me dar um auxilio ae nisso, agradeceria.

  2. seu pppoe esta rodando em modo kernel ??
    eu consegui diminuir em 80% o consumo de cpu apenas rodando em modo kernel.



  3. sim, está sim, ele esta rodando em modo kernel, segundo o administrador antigo, e pelo que vi está ativo a opção -k no start do pppoe serve que no caso seria kernel-mode.
    Só não sei o porque dessa mensagem assim, foi o que ocasionou o load no servidor.
    Se você ver no log que postei acima, esse usuario conectou 1 vez
    Abr 19 11:45:11 Auth.notice: (Access-Request 10.52.1.1 123 "user@provedor" CLID=00:83:08:00:EA:72):
    Login OK [user@provedor], e depois ficou gerando novas conexões agora porque disso, não faço idéia pois no meu log do radius e do pppoe apareceu muita tentativa de conexão desse usuario.
    Gerando então os erros postados acima, agora o pq disso não sei.
    Última edição por LinuxKids; 19-04-2007 às 16:48.

  4. Gostaria de saber se alguem já passou por esse tipo de problema antes, pois sei-lá parace que os problemas aqui são sinistro, totalmente fora do normal, pesso se alguem já passou por essa situação ajuda ae pessoal, nunca nada.






Tópicos Similares

  1. Respostas: 0
    Último Post: 03-01-2014, 08:09
  2. Myauth3 +pppoe + Radius no mikrotik
    Por wescleywifi no fórum Redes
    Respostas: 10
    Último Post: 12-08-2009, 14:17
  3. Dúvida no PPPoE+Radius+MySQL
    Por jocthbr no fórum Redes
    Respostas: 0
    Último Post: 01-11-2007, 20:51
  4. erro no radius/pppoe
    Por andrei_piovesan no fórum Redes
    Respostas: 0
    Último Post: 15-12-2004, 11:10
  5. Erro no pppoe
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-07-2003, 16:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L