Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão Acessar web server da rede local pela net

    Olá amigos da lista, tenho um webserver em uma maquina cliente rodando na porta 8080, quero acessar essa pagina externamente pela net, já quebrei a cabeça e a dias não acho solução.

  2. #2

    Arrow Use o Proxy Apache

    Olha ae a solução .

    mod_proxy - Apache HTTP Server

    Ab, Duca.



  3. #3
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por Duca Ver Post
    Olha ae a solução .

    mod_proxy - Apache HTTP Server

    Ab, Duca.
    Obrigado pela dica, ja vi uma luz no fim do tunel, so que não estou conseguindo adaptar isso ao Mikrotik.

  4. #4

    Padrão

    Citação Postado originalmente por marcelomg Ver Post
    Obrigado pela dica, ja vi uma luz no fim do tunel, so que não estou conseguindo adaptar isso ao Mikrotik.
    Você quer direcionar as conexoes da porta 80 para o ip local com a porta 8080??



  5. #5
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Você quer direcionar as conexoes da porta 80 para o ip local com a porta 8080??
    Assim... se eu digitar lagoanet.zyns.com:8081 abre o webbox, quero digitar lagoa.net.zyns.com:8080 abrir a pagina de uma maquina cliente do MK na porta 8080

  6. #6

    Padrão

    marcelo eu ja tinha postado uma regra para isso

    It works only for http connections not https connections, as transparent web proxy does not support https connections.

    Imagine, that you have only one public IP address i.e. xxx.xxx.xxx.xxx, but want to host 3 web servers:

    [email protected]
    [email protected]
    [email protected]
    1. Configure your web proxy

    /ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=unlimited max-ram-cache-size=unlimited
    /ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    add dst-port=80 action=allow comment="Enable Http Connection" disabled=no
    2. Configure Static DNS of domains to resolve to internal ip

    /ip dns static add name=123.com address=192.168.0.2
    /ip dns static add name=abc.com address=192.168.0.3
    /ip dns static add name=456.com address=192.168.0.4
    /ip dns static add name=www.123.com address=192.168.0.2
    /ip dns static add name=www.abc.com address=192.168.0.3
    /ip dns static add name=www.456.com address=192.168.0.4
    3. Configure NAT to redirect traffic to webproxy

    /ip firewall nat
    add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
    dst-port=80 action=redirect to-ports=8080 comment="" disabled=no
    The traffic for 123.com will be like this:

    The web proxy will redirect traffic to the 123.com internal ip address which is 192.168.0.2

    Internet --> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 --> 192.168.0.2:80

    I hope this would be helpful

    mais mesmo assim ta ai o link

    Multiple Web Servers - MikroTik Wiki