+ Responder ao Tópico



  1. #1

    Smile Proxy Arp - "ip ja esta em uso na rede"

    Tenho um servidor em uma lan house

    A eth0 (net) eh 192.168.3.100 (255.255.255.0) a eth1(rede interna) eh 192.168.0.x.(255.255.255.0)

    Eu queria usar um pc windows com ip 192.168.3.x dentro dessa rede interna da lan house e parecer que eu estivesse conctado a rede externa.

    Usei o comando echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp

    e

    echo 1 > /proc/sys/net/ipv4/conf/eth1/proxy_arp

    mas quando configuro o ip 192.168.3.200 no meu pc windows, diz que o ip ja esta em uso na rede, mesmo sabendo que na rede externa ninguem tem esse ip.

    Se alguem puder me ajudar, obrigado

    Joao

  2. #2

    Padrão

    Olá,

    digite mais esta regra,

    route add -host 192.168.3.200 dev eth1

    ai deve resolver seu problema,



  3. #3

    Padrão

    Valeu amigo. Parece que consegui resolver meu problema.

    Voce poderia me explicar o que esse comando faz?

    Obrigado

  4. #4

    Padrão

    route add -host 192.168.3.200 dev eth1

    Cria uma rota para o micro 192.168.3.200 pela placa eth1



  5. #5

    Padrão

    quando eu fui testar pra ver qual o ip que tava usando pra navegar, mostrou que era o do gateway da lan house e nao o que eu configurei no micro com windows dentro da rede interna.


    micro(192.168.3.200)---(eth1(192.168.0.2)-eth1(192.168.3.100))---net(200.xxx.xxx.xxx)

    eu quero navegar com meu ip 3.200, mas ta aparecendo o do gateway 3.100.

    sera que tem como fazer isso?