+ Responder ao Tópico



  1. #1

    Post Acesso externo com IP dinâmico, como saber o ip?

    Boa noite caros colegas, venho pedir ajuda.. pois já procurei no forum .. talvez tenha passado pelo assunto e não prestei atenção... mas gostaria de saber como acessar meus servidores externamente .. minha situação é a seguinte..

    Tenho 4 servidores com link adsl que muda cosntantemente de ip.. e tenho que conectar a distância para monitoramento dos mesmo... ou manutenção....

    tem como toda as vezer que a conexão estabilizar ele me mandar via mail ou outra forma tipo ddns ..?

    agradeço desde então .. e desculpem minha rudez.......boa noite a todos.

  2. #2

    Padrão ddns

    Boa noite amigo ramilio...

    Vc pode usar o o change-ip que funciona numa boa, basta vc fazer um cadastro no site Enhanced Dynamic DNS Solutions e seguir esse script aqui Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki

    Citação Postado originalmente por ramilio Ver Post
    Boa noite caros colegas, venho pedir ajuda.. pois já procurei no forum .. talvez tenha passado pelo assunto e não prestei atenção... mas gostaria de saber como acessar meus servidores externamente .. minha situação é a seguinte..

    Tenho 4 servidores com link adsl que muda cosntantemente de ip.. e tenho que conectar a distância para monitoramento dos mesmo... ou manutenção....

    tem como toda as vezer que a conexão estabilizar ele me mandar via mail ou outra forma tipo ddns ..?

    agradeço desde então .. e desculpem minha rudez.......boa noite a todos.



  3. #3

    Padrão

    agradecido amigo vou fazer um teste.. t+

  4. #4

    Padrão

    Citação Postado originalmente por ramilio Ver Post
    agradecido amigo vou fazer um teste.. t+
    Blz poste os resultados, precisando estamos ai.. t++



  5. #5

    Smile changeip.com

    Citação Postado originalmente por gilbertoandrade Ver Post
    Boa noite amigo ramilio...

    Vc pode usar o o change-ip que funciona numa boa, basta vc fazer um cadastro no site Enhanced Dynamic DNS Solutions e seguir esse script aqui Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki
    amigo boa noite !!

    eu tb to passando pelo mesmo problema , fiz o cadastro no changeip.com,
    ja crieia minha conta e la mostrou um ip pra mim ip xxx.xxx.142.141

    ate ai blz , agora desculpa minha falta de conhecimento + vc poderia me explicar como faço pra colocar o script:

    como e onde alterar o script??


    :log info "DDNS: Begin"

    :global ddns-user "YOURUSERID"
    :global ddns-pass "YOURPASSWORD"
    :global ddns-host "*1"
    :global ddns-interface "EXACTINTERFACENAME"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    desde agradeço sua atenção
    Última edição por ivovid; 30-04-2007 às 18:38.

  6. #6

    Padrão

    Amigo boa noite..

    Primeiramente vc precisar de colocar o seu script dentro de system scripts adicionar copie o codigo e jogue lá. Vc so vai precisar de editar isso aqui q escrevi em baixo e pronto. salve e de um run script.



    :log info "DDNS: Begin"

    :global ddns-user "no de usuario que vc criou no change ip"
    :global ddns-pass "sua senha de acesso criada la"
    :global ddns-host "*1"
    :global ddns-interface "sua interface de saida"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"

    Citação Postado originalmente por ivovid Ver Post
    amigo boa noite !!

    eu tb to passando pelo mesmo problema , fiz o cadastro no changeip.com,
    ja crieia minha conta e la mostrou um ip pra mim ip xxx.xxx.142.141

    ate ai blz , agora desculpa minha falta de conhecimento + vc poderia me explicar como faço pra colocar o script:

    como e onde alterar o script??


    :log info "DDNS: Begin"

    :global ddns-user "YOURUSERID"
    :global ddns-pass "YOURPASSWORD"
    :global ddns-host "*1"
    :global ddns-interface "EXACTINTERFACENAME"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    desde agradeço sua atenção



  7. #7
    fabiano2006
    Visitante

    Cool

    acho que com esse programinha vai ajudar


    Satélite Download