Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Ip valido com OSPF

    Ai pessoal seguinte tenho um servidor com pppoe server e hotspot para meus clientes, mas estou usando ip invalido para todos mas eu tenho muitos ips validos e eu quero usar os ips nos meus clientes, como faço para depois que o cliente fizer a conexção pppoe para sair direto para meu router, eu estava estudando OSPF será que resolve...

    Alguem me de uma dica

  2. #2

    Padrão ips validos

    por ips validos nos clientes é ter dor de cabeça


    se eu fosse vc nao faria isto.



  3. #3

    Padrão

    Citação Postado originalmente por ispbrasil Ver Post
    por ips validos nos clientes é ter dor de cabeça


    se eu fosse vc nao faria isto.
    Não sei em que ponto vc diz em ter dor de cabeça em relação a colocar ip's valido em cliente, pelo contrario, acho que isso ajuda mais ainda na administração, pois eles acabam sendo desmascarado, quero dizer saindo do nat.

    Kra em relação ao OSPF, vai depender da sua politica de roteamento.

  4. #4

    Padrão

    Citação Postado originalmente por ispbrasil Ver Post
    por ips validos nos clientes é ter dor de cabeça


    se eu fosse vc nao faria isto.
    Ai eu pergunto, se não colocar o ip valido no cliente implicar em perder o cliente faz-se o que? perde o cliente?



  5. #5

    Smile IP valido e OSPF

    O cara perguntou tecnicamente como fazer!

    Vamos lá!

    Dá pra fazer, inclusive acho uma otima solução, uso em todos meus clientes de medio porte.

    Se voce ativar OSPF em todos seus roteadores e MK's, sua rede vai se alto conhecer, construir aneis propositais pode ser uma boa ideia para alta disponibilidade, uma vez que se parte da sua rede cair o OSPF vai pensar em uma rota para contornar a parte DOWN.

    Relevancias: na configuração, os tempos de retransmissao e hello devem ser iguais para que os roteadores falem entre si.

    Exemplo de configuração OSPF no Linux (quagga):

    hostname router1
    password sine123
    enable password sline123
    log file /var/log/ospf.log
    !
    !
    !
    interface eth1
    ip ospf hello-interval 2
    ip ospf dead-interval 40
    ip ospf retransmit-interval 3
    !
    router ospf
    ospf router-id 202.22.22.1
    redistribute kernel
    redistribute connected
    redistribute static
    redistribute rip
    redistribute bgp
    network 202.22.22.0/26 area 0.0.0.0
    neighbor 202.22.22.2
    neighbor 202.22.22.3
    neighbor 202.22.22.4
    !
    line vty
    !


    Descrição:
    network XXXX area 0.0.0.0: descreve a área de backbone (coloque todas suas redes validas ligadas diretamente no link de saida. Ex.:
    network 202.22.22.0/26 area 0.0.0.0
    network 202.22.21.0/26 area 0.0.0.0

    neighbor x.x.x.x: descreve um roteador visinho, o OSPF pode descobrir os vizinhos por MULTICAST mas especificar pode ser uma boa ideia se voce escolher fazer conexao entre os roteadores sem uso de MULTICAST ou BROADCAST.

    ospf router-id 202.22.22.1: define o ip identificador do roteador local, esse ip é usado em calculos matematicos para definir qual roteador será de backup e qual será o mestre.

    redistribute kernel: significa que todas as rotas que aparecerem com 'proto kernel' na saida do comando:
    ip route show
    serao repassadas para os outros roteadores OSPF.


    Parametros de interface:

    ip ospf hello-interval 2: define o tempo de saudaçao entre os roteadores, o pacote é bem pequeno, se voce tiver 50 roteadores na mesma rede eles nao sao capazes de consumir nada significante!

    ip ospf dead-interval 40: tempo que um vizinho será considerado morto se nao responder.

    ip ospf retransmit-interval 3: tempo de retransmissao de rotas alteradas.


    No Mikrotik é bem mais facil de fazer, já que pelo winbox tudo é questão de click's, mas a logica é a mesma do Linux, fiz no meu laboratório e funcionou de primeira (e olha que eu nao trabalho com Mikrotik!!!)


    Objetivo: dar ip valido.


    Simples demais com PPPoE server, basta fornecer o IP via Radius no pacote Framed-IP-Address que o OSPF vai avisar da nova rota ao roteador de saida.

    Adicionar uma rota estática no roteador de saida apontando os ips validos usados no PPPoE para o IP do roteador Mikrotik também é uma boa ideia.

    Nesses casos, o OSPF ajuda muito pois sem ele o trafego de ips valido passa todo pelo roteador mesmo quando a troca de dados é entre servidores internos com IP valido. Com OSPF, os roteadores saberão o caminho mais curto para o destino local.

    Saudações,
    Patrick Brandão
    MyAuth Gateway
    Última edição por PatrickBrandao; 03-05-2007 às 09:50.

  6. #6

    Thumbs up

    Realmente otima ideia vou usar no pppoe como vc falow, na realidade o colega ispbrasil ter ip validos nos clientes e otimo ter um unico ip e pecimo pois ataques entre outras coisa acontece com mais frequencia desta forma doque ter todos com ip validos mas dinamicos alem do que eu não preciso ficar fazendo redirecionamento toda vez que alguem que jogar ou um empresa precisa liberar uma porta tipo VNC, a minha duvida era essa mesma obrigado a todos ....


    Ps. vou testar depois posto o resultado