Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bem pessoal, vou começar bem do começo pra ver se voces entendem, tenho um serv aqui operando como ap pra distribuir internet, esse serv usa placa wireless lg com chipset rtl8180, bem esse drive é carregado toda vez que o linux é iniciado tem a seguinte linha no rc.local aqui do serv :
    insmod -f /wire/rtl8180_24x.o
    /wire/wlanap.sh
    /wire/net ap

    Dessa maneira o driver é carregado e a placa ligada sendo que no arquivo wlanap.sh é assim:
    ##################################################
    #SCRIPT PARA INCIAR EM MODO AP####################
    ##################################################

    #echo Iniciando modo AP.
    iwpriv wlan0 drv_para apclient_enable=0
    #sleep 1
    #echo tete ok
    echo Configurando SSID.
    iwpriv wlan0 wlan_para ssid=serverap
    #sleep 1

    echo Configurando Canal de Operacao.
    iwpriv wlan0 wlan_para channel=3
    #sleep 1

    echo Desligando modo HiddenAP.
    iwpriv wlan0 wlan_para hiddenAP=false
    #sleep 1

    echo Configurando Velocidade basica de operacao.
    iwpriv wlan0 wlan_para basicrates=bit1
    #sleep 1
    echo Configurando Velocidade de Transmissão.
    iwpriv wlan0 wlan_para oprates=bit1
    #sleep 1

    #echo Configurando para Open System.
    iwpriv wlan0 wlan_para authtype=both
    #sleep 1

    #echo Configurano Fragment Treshould.
    iwpriv wlan0 wlan_para fragthres=2432
    #sleep 1

    #echo Configurando RTS Treshould.
    iwpriv wlan0 wlan_para rtsthres=2432
    #sleep 1

    #echo Configurando Preamble.
    iwpriv wlan0 wlan_para preamble=long
    #sleep 1

    #echo Configurando DtimPeriod.
    iwpriv wlan0 wlan_para dtimperiod=1
    #sleep 1
    #echo Configurando Broadcast de SSID.
    #iwpriv wlan0 wlan_para bcnint=100
    #sleep 1

    #echo Configurando Tempo de vida.
    #iwpriv wlan0 wlan_para expired_time=10000
    #sleep 1

    #echo Ativando a Criptografia em 40bits.
    #iwpriv wlan0 wlan_para wepmode=wep40
    #sleep 1

    #echo Configurando o KeyIndex da chave.
    #iwpriv wlan0 wlan_para wepkeyid=1
    #sleep 1

    #echo Configurando a chave de criptografia.
    #iwpriv wlan0 wlan_para wepkey40_1=11111
    #sleep 1

    #echo Desligando Debug.
    #iwpriv wlan0 msglevel 0
    #echo Ativando a operacao da celula.
    iwpriv wlan0 enable
    iwpriv wlan0 disable
    iwpriv wlan0 enable
    __________________________________________________________________
    E O ARQUIVO /wire/net está assim:
    #!/bin/sh
    #--------------------------
    # Atalhos de comando

    IWPRIV=`which iwpriv`
    INSMOD=`which insmod`
    RMMOD=`which rmmod`
    IFCONFIG=`which ifconfig`
    ROUTE=`which route`


    #--------------------------
    # Carrega o driver

    $INSMOD -f rtl8180_24x.o


    #--------------------------
    # Tipo da Comunicação

    case "$1" in
    ap)
    echo "ap"
    #------------------------------------------
    # Config AP mode
    # Assign SSID and operation channel.

    $IWPRIV wlan0 wlan_para ssid=APMucambo
    $IWPRIV wlan0 wlan_para channel=2
    ;;
    infra)
    echo "infra"
    #------------------------------------------
    # Config infrastructure mode
    # Assign network type and desired SSID.

    $IWPRIV wlan0 wlan_para networktype=infra
    $IWPRIV wlan0 wlan_para ssid2scan=APMucambo
    ;;
    adhoc)
    echo "adhoc"
    #------------------------------------------
    # Config infrastructure mode
    # Assign network type and desired SSID.
    # 'ssid' and 'channel' are the default setting
    # and meaningful if this is the first station
    $IWPRIV wlan0 wlan_para channel=2
    $IWPRIV wlan0 wlan_para ssid2scan=wireless
    $IWPRIV wlan0 wlan_para networktype=adhoc
    $IWPRIV wlan0 wlan_para ssid=wireless1

    ;;
    *)
    $RMMOD rtl8180_24x
    echo "Usage: $0 {ap | infra | adhoc}"
    exit 1
    ;;
    esac


    #--------------------------
    # Configuração Básica

    # Alguns usam essa opção, parece funcionar
    $IWPRIV wlan0 wlan_para networktype=auto

    $IWPRIV wlan0 wlan_para basicrates=0xf
    $IWPRIV wlan0 wlan_para oprates=0xf
    $IWPRIV wlan0 wlan_para fraghres=512
    $IWPRIV wlan0 wlan_para preamble=auto

    # Ativar ou desativar debug-message
    $IWPRIV wlan0 msglevel 0

    #--------------------------
    # Config WEP mode

    #$IWPRIV wlan0 wlan_para encmode=on
    #$IWPRIV wlan0 wlan_para wepmode=on

    #$IWPRIV wlan0 wlan_para encmode=wep,wepmode=wep40
    #$IWPRIV wlan0 wlan_para wepmode=wep40,wepdkeyid=1,wepkey40_1=36541
    #$IWPRIV wlan0 wlan_para authtype=sharedkey


    #--------------------------
    # Enable wireless lan driver

    # É estranho, mas primeiro o povo desliga, para depois ligar :-)
    $IWPRIV wlan0 disable
    $IWPRIV wlan0 enable


    #--------------------------
    # Configure wlan0 IP address

    $IFCONFIG wlan0 192.168.1.254
    echo "$($IFCONFIG wlan0)"
    ______________________________________________________________________
    bem o que eu quero é colocar uma chave no meu sinal, tentei já descomentei as linhas:
    #$IWPRIV wlan0 wlan_para encmode=on
    #$IWPRIV wlan0 wlan_para wepmode=on

    #$IWPRIV wlan0 wlan_para encmode=wep,wepmode=wep40
    #$IWPRIV wlan0 wlan_para wepmode=wep40,wepdkeyid=1,wepkey40_1=36541
    #$IWPRIV wlan0 wlan_para authtype=sharedkey

    Mas nada de funcionar o sinal ficava com a chave só que quando eu ia conectar não conectava, então se algum puder me dar uma luz pra eu colocar a chave no sinal, e que todos os meus usuarios consigam conectar e navegar na net sem prob vou ficar muito grato sinto um pouco de dificuldades pq sou iniciante em linux e aqui na minha cidade eu sou o unico a defender a bandeira de software livre.
    abraços.

  2. pessoal ainda tô aguardando alguma ajuda preciso muito da ajuda de v6. fico muito agradecido a todos.
    abraço



  3. amigo, diz ai que versao do linux, talvez possamos ajudar.

  4. cara eu uso o conectiva 9.



  5. esses scripts é copia de algum tutorial ou foi feito por você, os valores definidos estão corretos?






Tópicos Similares

  1. Bug no sinal dos AP's de Rocket [Ajuda]
    Por leandronets no fórum Redes
    Respostas: 7
    Último Post: 13-06-2014, 08:59
  2. colocar fserv de pé no xchat2
    Por flipeexpl no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-12-2005, 10:48
  3. como colocar controle de velocidade no kurumim
    Por jhonnybravo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 23-05-2005, 16:55
  4. Dificuldade em criar regras de firewall
    Por marcosgw no fórum Servidores de Rede
    Respostas: 10
    Último Post: 11-01-2005, 14:54
  5. Dificuldade em instalar placa de video onboard
    Por ricardodru no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-11-2003, 15:16

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L