Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    alexsistemass
    tem uma maquina com duas placas de rede
    e quero fazer um roteador ..

    Sou Iniciante em roteador ...

    Consegui Fazer no Fedora 1
    Mas nao Funciona no Fedora 6..

    No Fedora 1
    Placa eth0 192.168.1.100
    Placa eth1 192.168.2.1


    echo 1 > /proc/sys/net/ipv4/ip_forward

    iptables -t nat -A POSTROUTING -s 192.168.2.0/24 -j MASQUERADE


    Assim no Fedora 1 Funciona no Fedora 6 nao Funciona
    nao entendo muito de Roteamento nem de Iptables ...
    Se vcs poderem me ajudar fico Grato...

  2. tente fazer assim, crie um arquivo com o seguinte conteudo:

    #!/bin/bash
    echo 1 > /proc/sys/net/ipv4/ip_forward

    iptables -t filter -P INPUT ACCEPT
    iptables -t filter -P FORWARD ACCEPT
    iptables -t filter -P OUTPUT ACCEPT

    iptables -t filter -F
    iptables -t nat -F
    iptables -t mangle -F

    iptables -t nat -A POSTROUTING -s 192.168.2.0/24 -o eth0 -j MASQUERADE


    execute-o e veja se vai funcionar !!!



  3. #3
    alexsistemass
    Nao deu Certo, nao Funcionou a Internet.

    tem mais alguma configuracao que tem que alterar ?
    Por Enquanto so Quero Liberar para funcionar a internet nao quero
    bloquear nada..

    Se pode me Ajudar Fico Grato..
    Valew

  4. temq funcionar essas regras q passei ai.. é o basico do basico !!

    o que nao deve estar funcionando eh configuração ai das rotas.. ips de placa de rede...



  5. #5
    alexsistemass
    Como deveria ser as rotas
    no meu fedora 6 esta da seguinte maneira

    Placa de Rede eth0 Ligada no Modem Ip 192.168.1.100
    Placa de Rede eth1 Ligada na Rede interna 192.168.2.1

    Modem Adsl 192.168.1.1

    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.0.0.0 U 0 0 0 eth0
    0.0.0.0 192.168.1.1 0.0.0.0.0 UG 0 0 0 eth0


    As rotas estao dessa Maneira ..... Nao Funciona no Fedora 6..
    Mas Com essas mesmas Rotas Funciona no Fedora 1

    Alguma Dica
    Nao Criei nem uma rota na inicializaçao

    Se Poder me ajudar fico Grato






Tópicos Similares

  1. Problemas com NAT no cisco 805
    Por Skill no fórum Redes
    Respostas: 1
    Último Post: 13-05-2004, 19:15
  2. Problemas com NAT iptables
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-06-2003, 07:43
  3. Servidores internos com NAT
    Por lite no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-03-2003, 12:53
  4. VPN linux atráz de router com NAT
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 21-03-2003, 07:53
  5. Roteamento e NAT com IPTables
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-02-2003, 12:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L