+ Responder ao Tópico



  1. Pessoal,

    Estou configurando um servidor LTSP da seguinte maneira: os thin-clients (rede 192.168.2.0/24) acessam um servidor LTSP (2 placas de rede 192.168.2.115 e 192.168.254.115), no Suse 10.0, que redireciona (rdesktop) para um Windows Server 2003 (2 placas de rede 192.168.254.120 e 192.168.2.120).

    Consigui fazer com que o thin-client acesse o shell, o kdm e a tela de login do 2003. Consigo logar em todas elas. Só que, no 2003, ele fica com Qualidade de Cor de apenas 8 Bits.

    Não sei onde está o problema. Já defini nas Group Polices para que os terminais tenham cor de 24 bits.

    Abaixo segue meus arquivos de configuração.

    Grato pela ajuda...


    #/opt/ltsp/i386/etc/lts.conf
    [Default]
    SERVER = 192.168.2.115
    XSERVER = auto
    X_MODE_0 = 1024x768
    X_COLOR_DEPTH = 16
    X_MOUSE_PROTOCOL = IMPS/2
    X_MOUSE_DEVICE = /dev/psaux
    X_MOUSE_RESOLUTION = 400
    X_MOUSE_BUTTONS = 5
    X_ZAxisMapping = "4 5"
    XKBMODEL = ABNT2
    XKBLAYOUT = BR
    USE_XFS = N
    SCREEN_01 = rdesktop -f blackpearl.elderjmp.br
    SCREEN_02 = startx
    SCREEN_03 = shell

    #/etc/hosts
    192.168.2.115 xyaco.elderjmp.br xyaco
    192.168.254.115 xyaco.elderjmp.br xyaco
    192.168.2.220 lab-04-01.elderjmp.br lab-04-01
    192.168.2.120 blackpearl.elderjmp.br blackpearl
    192.168.254.120 blackpearl.elderjmp.br blackpearl


    #/etc/hosts.allow
    bootpd: 0.0.0.0
    in.tftpd: 192.168.2.0/24 192.168.254.0/24
    portmap: 192.168.2.0/24 192.168.254.0/24
    rpc.mountd: 192.168.2.0/24 192.168.254.0/24


    #/etc/exports
    /opt/ltsp 192.168.2.0/255.255.255.0(ro,no_root_squash,sync)
    /opt/ltsp 192.168.254.0/255.255.255.0(ro,no_root_squash,sync)
    /var/opt/ltsp/swapfiles 192.168.2.0/255.255.255.0(rw,no_root_squash,async)


    #/etc/dhcpd.conf
    # LAB-04
    shared-network LAB-04 {
    option broadcast-address 192.168.2.255;
    option domain-name-servers 192.168.2.115;
    option domain-name "elderjmp.br";
    option root-path "192.168.2.115:/opt/ltsp/i386";
    get-lease-hostnames true;
    next-server 192.168.2.115;
    subnet 192.168.2.0 netmask 255.255.255.0 {
    }
    # lab-04-01
    host lab-04-01 {
    hardware ethernet 44:4D:50:80:70:6C;
    fixed-address 192.168.2.220;
    filename "/lts/2.6.17.8-ltsp-1/pxelinux.0";
    }
    }

  2. Resolvido o problema... era só acrescentar o parâmetro -a no rdesktop:

    #/opt/ltsp/i386/etc/lts.conf
    [Default]
    SERVER = 192.168.2.115
    XSERVER = auto
    X_MOUSE_PROTOCOL = IMPS/2
    X_MOUSE_DEVICE = /dev/psaux
    X_MOUSE_RESOLUTION = 400
    X_MOUSE_BUTTONS = 5
    X_ZAxisMapping = "4 5"
    USE_XFS = N
    SCREEN_01 = rdesktop -5 -a 16 -g 1024x768 -f blackpearl.elderjmp.br


    O problema agora passou a ser o som... estou usando a opção -r sound:local e não está funcionando.






Tópicos Similares

  1. Gerenciar rede com windows 2003 em grupo de trabalho
    Por FMANDU no fórum Certificação
    Respostas: 2
    Último Post: 16-09-2011, 08:52
  2. Respostas: 0
    Último Post: 03-08-2009, 19:03
  3. LTSP com o Debian e Windows 2003??
    Por tio_chico no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 09-09-2006, 15:17
  4. Clientes windows 98 com problemas de DHCP
    Por gsiena no fórum Redes
    Respostas: 2
    Último Post: 17-07-2006, 10:17
  5. Acessando compartilhamentos do Windows 2003 com o Linux
    Por jungleboy no fórum Servidores de Rede
    Respostas: 3
    Último Post: 05-04-2005, 13:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L