+ Responder ao Tópico



  1. #1
    UPLinux
    Visitante

    Unhappy Compartilhamento (ajuda)

    Caro amigos !!!

    Estou com dificuldade de configurar o meu proxy na minha rede
    A minha rede ele é da seguinte forma:

    Modem => Hub=> computadores

    Quero colocar um Proxy e ficaria assim

    Modem=> Proxy=> hub=> Computadores

    Configurei o proxy tudo certinho com duas placas de rede, as placas de redes estão com a seguinte configuração:

    eth0
    ONBOOT=YES
    IPADDR=10.1.3.2
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.1 ( MODEM)
    DDNS1=201.10.128.2
    DDNS2=201.10.120.2

    eth1
    ONBOOT=YES
    IPADDR=192.168.1.1
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.2

    E executei o seguinte comando

    iptables -t nat -A POSTROUTING -s 192.168.101.0/24 -o eth0 -j MASQUERADE

    Para compartilhar a internet, consigo pingar fora e dentro da minha rede, mas as maquinas dos usuarios não conseguem navegar.

    As configurações estão corretas?
    Devo criar mais regras de iptables?
    Ou está tudo errado?

    Me ajudem por favor!!!!

  2. #2
    UPLinux
    Visitante

    Unhappy Compartilhamento

    Caro amigos !!!

    Estou com dificuldade de configurar o meu proxy na minha rede
    A minha rede ele é da seguinte forma:

    Modem => Hub=> computadores

    Quero colocar um Proxy e ficaria assim

    Modem=> Proxy=> hub=> Computadores

    Configurei o proxy tudo certinho com duas placas de rede, as placas de redes estão com a seguinte configuração:

    eth0
    ONBOOT=YES
    IPADDR=10.1.3.2
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.1 ( MODEM)
    DDNS1=201.10.128.2
    DDNS2=201.10.120.2

    eth1
    ONBOOT=YES
    IPADDR=192.168.1.1
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.2

    E executei o seguinte comando

    iptables -t nat -A POSTROUTING -s 192.168.101.0/24 -o eth0 -j MASQUERADE

    Para compartilhar a internet, consigo pingar fora e dentro da minha rede, mas as maquinas dos usuarios não conseguem navegar.

    As configurações estão corretas?
    Devo criar mais regras de iptables?
    Ou está tudo errado?

    Me ajudem por favor!!!!



  3. #3

    Padrão

    Citação Postado originalmente por UPLinux Ver Post
    Caro amigos !!!

    Estou com dificuldade de configurar o meu proxy na minha rede
    A minha rede ele é da seguinte forma:

    Modem => Hub=> computadores

    Quero colocar um Proxy e ficaria assim

    Modem=> Proxy=> hub=> Computadores

    Configurei o proxy tudo certinho com duas placas de rede, as placas de redes estão com a seguinte configuração:

    eth0
    ONBOOT=YES
    IPADDR=10.1.3.2
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.1 ( MODEM)
    DDNS1=201.10.128.2
    DDNS2=201.10.120.2

    eth1
    ONBOOT=YES
    IPADDR=192.168.1.1
    NETMASK=255.255.255.0
    GATEWAY=10.1.3.2

    E executei o seguinte comando

    iptables -t nat -A POSTROUTING -s 192.168.101.0/24 -o eth0 -j MASQUERADE

    Para compartilhar a internet, consigo pingar fora e dentro da minha rede, mas as maquinas dos usuarios não conseguem navegar.

    As configurações estão corretas?
    Devo criar mais regras de iptables?
    Ou está tudo errado?

    Me ajudem por favor!!!!
    Retire o gateway da eth1 que funciona

    eth1
    ONBOOT=YES
    IPADDR=192.168.1.1
    NETMASK=255.255.255.0
    GATEWAY=""

  4. #4

    Post

    Boa noite UPLinux.

    Verifiquei as configurações que você efetuou, e elas estão meio confusas.

    Primeiro de tudo, é importante você revelar se a conexão com a internet é por meio de "conexão" ADSL (IP Dinâmico) ou por IP Fixo.
    Dependendo da situação, nem é necessário fazer seu modem virar roteador. Pode deixá-lo como bridge.

    Certo. Caso você consiga o que precisa com a dica do binhorp, morre por aqui esse assunto.

    abracos



  5. #5

    Padrão

    Como foi dito tu tem que dar especificação da sua net, é PPPOE (Speedy) link direto com a embratel??

    o que seria?


    sua eth0 se for ela conectada com a interface de saida pra internet não precisa de gateway, coloque pra garantir, no arquivo /etc/sysconfig/network ( se for padrão red hat, se for debian nem sei XD) na parte GATEWAYDEV=eth0.

    e lembrese no seu firewall o -o quer dizer interface de saida, então se for um link vai ser eth0 como tu descreveu se for um ADSL, speedy e outras tranqueiras, vai ser o pppoe.

    espero ter ajudado um poco ^^

  6. #6

    Padrão

    A primeira coisa que tu tem que testar é se as máquinas se pingam. Se não pingarem, tu deve atacar a parte de configuração de rede ou a parte física do negócio (HUB's, switches, placas de rede...).

    Se pingar a eth1, beleza. Tente pingar agora a eth0. Não deu certo? Ative o roteamento no kernel com o seguinte comando:

    Código :
    # echo 1 > /proc/sys/net/ipv4/ip_forward

    Se não navegar - o quê muito provavelmente vai acontecer - tente arrmar essa sua regra de firewall e setar o seguinte:

    Código :
    # iptables -t nat -A POSTROUTING -s 192.168.1.0/24 -o eth0 -j MASQUERADE

    E reconfigure os seus clientes na rede 192.168.1.0 (192.168.1.2/24 - 192.168.1.254/24).

    Se depois de tudo isso não funcionar, posta de novo aqui pra gente com a atual situação...


    Abraços!



  7. #7
    UPLinux
    Visitante

    Padrão Boa Tarde Amigos.

    Desde já agradeço a todos por te me ajudado com as respostas...
    Fiz funcionar o meu proxy com a ajuda de vocês, e está rodando perfeitamente.

    Muito obrigado a todos.

  8. #8

    Padrão

    Fico feliz que tenha resolvido o seu problema, mas se as respostas aqui ajudaram, é de boa praxe que você clique no botão "Agradecer".


    Abraços!