Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Redirecionar PÁgina Inicial Para Clientes - Via Pppoe

    É isso mesmo, eu consegui desenvolver uma regra para isso, em PPPoE... Estou preparando o material para soltar aqui para a galera... Funciona da seguinte forma:

    Quando o cliente loga a primeira vez e abre o broswer, via PPPoE, aparece a página que você define ou aviso, após 10 segundos (ou mais), ele é redirecionado automaticamente para a página inicial dele... Também tem uma derivada desta regra que quando o cliente é bloqueado só consegue entrar na página definida, que pode ser somente a página do provedor ou um aviso de débitos... Show de bola pra os provedores que trabalham com PPPoE, pois só encontrávamos isso em HOTSPOT.

    TEm mais, dependendo pode-se colocar a janela com redirecionamento ou como pop-up, bastando apenas modificar um código HTML. Você poderá utilizar páginas existentes na web, ou com um simples soft, transformar sua máquina windows em um servidor web interno. Aqui testei da seguinte forma:

    1º teste: Redirecionando os clientes para uma página qualquer na web, podendo ser um simples aviso, hospedado em qualquer lugar e também para uma página qualquer... Funcionou perfeitamente, tanto para forçamento de página inicial, quanto de bloqueio.

    2º teste: No meu notebook, coloquei um soft e transformei-o em um server web, no frontpage criei minha página personalizada... Quando o cliente entra na internet pela primeira vez é redirecionado para a minha página personalizada (criei um aviso, com logos e etc), após 10 segundo ele é redirecionado automaticamente para a página dele inicial... Funciona 100% também... Estou preparando o material e em breve disponibilizarei....
    ´
    O melhor de tudo é que realmente esta tela inicial só aparece quando ele loga a primeira vez, evitando assim a fadiga de toda vez abrir o explorer e aparecer ela.... Show!!

  2. #2

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    É isso mesmo, eu consegui desenvolver uma regra para isso, em PPPoE... Estou preparando o material para soltar aqui para a galera... Funciona da seguinte forma:

    Quando o cliente loga a primeira vez e abre o broswer, via PPPoE, aparece a página que você define ou aviso, após 10 segundos (ou mais), ele é redirecionado automaticamente para a página inicial dele... Também tem uma derivada desta regra que quando o cliente é bloqueado só consegue entrar na página definida, que pode ser somente a página do provedor ou um aviso de débitos... Show de bola pra os provedores que trabalham com PPPoE, pois só encontrávamos isso em HOTSPOT.

    TEm mais, dependendo pode-se colocar a janela com redirecionamento ou como pop-up, bastando apenas modificar um código HTML. Você poderá utilizar páginas existentes na web, ou com um simples soft, transformar sua máquina windows em um servidor web interno. Aqui testei da seguinte forma:

    1º teste: Redirecionando os clientes para uma página qualquer na web, podendo ser um simples aviso, hospedado em qualquer lugar e também para uma página qualquer... Funcionou perfeitamente, tanto para forçamento de página inicial, quanto de bloqueio.

    2º teste: No meu notebook, coloquei um soft e transformei-o em um server web, no frontpage criei minha página personalizada... Quando o cliente entra na internet pela primeira vez é redirecionado para a minha página personalizada (criei um aviso, com logos e etc), após 10 segundo ele é redirecionado automaticamente para a página dele inicial... Funciona 100% também... Estou preparando o material e em breve disponibilizarei....
    ´
    O melhor de tudo é que realmente esta tela inicial só aparece quando ele loga a primeira vez, evitando assim a fadiga de toda vez abrir o explorer e aparecer ela.... Show!!
    amigo, muito me interessa isso, eu consegui aki redirecionar para um site específico, mais não consegui redirecionar para meu pc com um programa http server instalado
    ja to tentando a mó tempão



  3. #3

    Padrão

    legal, dá pra apontar os clientes pro portal do provedor, estando ele online ou apenas na rede interna. mto bom.

  4. #4

    Padrão

    ho catv, e nao da de rodar isto pra quem nao usa nem pppoe e nem hotspot?



  5. #5

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    ho catv, e nao da de rodar isto pra quem nao usa nem pppoe e nem hotspot?
    pelo Jeito tem bastante jente interessado neste tema, eu fiz aki, instalei um servidor http em um pc, na rede funciona blz, mais nos clientes que estão no mik não funga, tem que liber firewall. ai tá laskera...

  6. #6

    Padrão

    Amigao ... como faria para redirecionar um determinado IP para meu servidor web

    Assim

    Cliente conecta PPPOE ele nao pagou redireciona para pagina criada no meu servidor Web ( Windows ).

    ja tentei fazer as regras postada aqui no forum mais nao consigo sucesso.

    IP Cliente : 10.1.1.8 porta 80 redirecionar para servidor web IP 10.1.1.2 porta 80

    obrigado pela atenção e aguardo resposta



  7. #7

    Smile Aguardem...

    já montei o códigos fonte do redirecionamento, com padrão em 10 segundos como o nosso amigo CATV citou.

    vou montar o servidor http para efetuar alguns testes e em breve disponibilizo para vocês como fazer o redirecionamento, tanto em Hotspot, PPPoE, IP Fixo..

    tenham só um pouco de paciência =D

  8. #8

    Padrão Uma pergunta...

    Citação Postado originalmente por catvbrasil Ver Post
    É isso mesmo, eu consegui desenvolver uma regra para isso, em PPPoE... Estou preparando o material para soltar aqui para a galera... Funciona da seguinte forma:

    Quando o cliente loga a primeira vez e abre o broswer, via PPPoE, aparece a página que você define ou aviso, após 10 segundos (ou mais), ele é redirecionado automaticamente para a página inicial dele... Também tem uma derivada desta regra que quando o cliente é bloqueado só consegue entrar na página definida, que pode ser somente a página do provedor ou um aviso de débitos... Show de bola pra os provedores que trabalham com PPPoE, pois só encontrávamos isso em HOTSPOT.

    TEm mais, dependendo pode-se colocar a janela com redirecionamento ou como pop-up, bastando apenas modificar um código HTML. Você poderá utilizar páginas existentes na web, ou com um simples soft, transformar sua máquina windows em um servidor web interno. Aqui testei da seguinte forma:

    1º teste: Redirecionando os clientes para uma página qualquer na web, podendo ser um simples aviso, hospedado em qualquer lugar e também para uma página qualquer... Funcionou perfeitamente, tanto para forçamento de página inicial, quanto de bloqueio.

    2º teste: No meu notebook, coloquei um soft e transformei-o em um server web, no frontpage criei minha página personalizada... Quando o cliente entra na internet pela primeira vez é redirecionado para a minha página personalizada (criei um aviso, com logos e etc), após 10 segundo ele é redirecionado automaticamente para a página dele inicial... Funciona 100% também... Estou preparando o material e em breve disponibilizarei....
    ´
    O melhor de tudo é que realmente esta tela inicial só aparece quando ele loga a primeira vez, evitando assim a fadiga de toda vez abrir o explorer e aparecer ela.... Show!!
    Uma curiosidade q tenho nisso tudo...

    Como vc faz o MK clasificar quem é cliente INADIMPLENTE???????
    Após a conexao do PPPoE vc tem q dizer q aquele MAC é inadimplente ou nao correto??? A meu ver só com um servidor RADIUS pra fazer isso... como foi o meu caso... quando implantei meu freeradius foi molezinha fazer isso q vc esta se prontificando em fazer... mas sem ele nao vejo como fazer... se é possivel mostra ai alguma coisa pra galera poder ter um material pra desenvolver em conjunto?? Ou vc ta sonhando alto??? Desculpa falar assim mas ja nos conhecemos né??? Abraços DAVID



  9. #9

    Padrão

    Citação Postado originalmente por cgrellier Ver Post
    Uma curiosidade q tenho nisso tudo...

    Como vc faz o MK clasificar quem é cliente INADIMPLENTE???????
    Após a conexao do PPPoE vc tem q dizer q aquele MAC é inadimplente ou nao correto??? A meu ver só com um servidor RADIUS pra fazer isso... como foi o meu caso... quando implantei meu freeradius foi molezinha fazer isso q vc esta se prontificando em fazer... mas sem ele nao vejo como fazer... se é possivel mostra ai alguma coisa pra galera poder ter um material pra desenvolver em conjunto?? Ou vc ta sonhando alto??? Desculpa falar assim mas ja nos conhecemos né??? Abraços DAVID
    A classificação seria pelo IP do cliente... Vou mandar alguma coisa abaixo pra ter uma idéia da coisa...


    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    Esta regra acima define quem será a página inicial do cliente. Quando o mesmo entra no PPPoE, será direcionado automaticamente para a página sua que está no servidor local (dentro da rede). Para criar um servidor web simples em uma máquina windows, utilizei o soft "ironwall". Esta regra deve ser colocada logo após a regra de NAT, para seguir a irarquia de priorização do firewall. No exemplo acima o src-address é uma faixa de ips (10.0.0.1-10.0.0.253), na qual é redirecionada para o servidor web (winxp com ironwall) no ip 10.0.0.2. Para ser redirecionado automaticamente para sua página inicial, criei um código fonte dentro desta página inicial, recarrengando ela mesma, gerando assim, algumas conexões simultâneas e mudando automaticamente de página. Basicamente a regra funciona a ação do "conection limit".
    PS: A porta padrão do irowall foi alterada para a 81.


    BLOQUEIO DE CLIENTE PARA PÁGINA INICIAL

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1 dst-address=!10.0.0.2 protocol=tcp \
    dst-port=80 action=dst-nat to-addresses=10.0.0.2 to-ports=81 comment="REGRA \
    PARA DIRECIONAR CLIENTE PARA UMA MESMA PÁGINA \(D BITO\) - SISTEMA \
    INTELIGÊNTE DE BLOQUEIO" disabled=yes

    Esta regra é a mesma de cima, somente retirando o "conection limit" o mikrotik entenderá que em todas as circustâncias ele deve sempre redirecionar o cliente para o servidor (10.0.0.2). Neste caso o cliente 10.0.0.1 está bloqueado. A mesma página HTML pode ser utilizada (está em anexo), pois quando a mesma for redirecionada após os 10 segundos, irá voltar para ela mesma, criando um loop na qual o cliente não conseguirá sair e exibirá apenas aquela mensagem padrão de bloqueio. O ideal para ficar show, é incluir uma regra como a debaixo para este mesmo cliente, para bloquear todos os serviços, exceto o da página.

    REGRA ANEXA PARA BLOQUEIO DE CLIENTES

    /ip firewall nat
    add chain=src-nat src-address=10.0.0.1 protocol=!tcp \
    src-port=!80 action=drop comment="BLOQUEIO DE CLIENTE" \
    disabled=yes

    Com esta regra acima de exceção, o mikrotik bloqueará todas as portas e protocolos, menos a porta 80 e o protocolo tcp.

    Em anexo o ironwall e os arquivos da página inicial de testes... Dúvidas? Entre em contato que a gente desenvolve qualquer coisa!!!
    Arquivos Anexos Arquivos Anexos

  10. #10

    Padrão

    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    usei estas regras mais nao funciona, uso windows IIS para servidor de WEB, consigo acessar minha pagina como cliennte pppoe. Mais todas as vezes que clico para atualizar a pagina para principal ele so entra na minha, nao consigo por exemplo acessar a pagina que esta definida no navegador como principal. Nao tem uma regra que ele redireciona a pagina do cliente, e depois acabe com redirecionamento ?



  11. #11

    Padrão David...

    Um provedor com mil clientes??? Como vc faria essa regra... automaticamente quando a fatura dele vencer ele ser redirecionado pra essa regra???

    OBS.: SEM UTILIZAR RADIUS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  12. #12

    Padrão

    utilize o address list, para o source para so precisar fazer uma regra e ir adicionando os ips que precisa que bloqueie!



  13. #13

    Padrão

    Citação Postado originalmente por gustkiller Ver Post
    utilize o address list, para o source para so precisar fazer uma regra e ir adicionando os ips que precisa que bloqueie!
    Não esquente. O cgrellier (Cyrille), virou meu sócio novamente. Implantei justamente isso no servidor.

  14. #14

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Não esquente. O cgrellier (Cyrille), virou meu sócio novamente. Implantei justamente isso no servidor.
    O meu patrão Kd vc, sumiu meu, depois do curso n te vi mais.....
    me adicione ai no MSN que vc entra com mais frequencia

    tiagomatias[]linuxap.com.br

    Abraços



  15. #15

    Padrão Redirecionar PÁgina Inicial Para Clientes - Via Pppoe

    Citação Postado originalmente por chiareloto Ver Post
    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    usei estas regras mais nao funciona, uso windows IIS para servidor de WEB, consigo acessar minha pagina como cliennte pppoe. Mais todas as vezes que clico para atualizar a pagina para principal ele so entra na minha, nao consigo por exemplo acessar a pagina que esta definida no navegador como principal. Nao tem uma regra que ele redireciona a pagina do cliente, e depois acabe com redirecionamento ?
    aconteceu a mesma coisa comigo.
    vece conseguiu a solucao ?
    abraço

  16. #16

    Padrão

    isto é um bug do internet explorer, se vc abrir e fechar o navegador vai conseguir navegar em outras paginas.



  17. #17

    Padrão m

    Citação Postado originalmente por catvbrasil Ver Post
    A classificação seria pelo IP do cliente... Vou mandar alguma coisa abaixo pra ter uma idéia da coisa...


    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    Esta regra acima define quem será a página inicial do cliente. Quando o mesmo entra no PPPoE, será direcionado automaticamente para a página sua que está no servidor local (dentro da rede). Para criar um servidor web simples em uma máquina windows, utilizei o soft "ironwall". Esta regra deve ser colocada logo após a regra de NAT, para seguir a irarquia de priorização do firewall. No exemplo acima o src-address é uma faixa de ips (10.0.0.1-10.0.0.253), na qual é redirecionada para o servidor web (winxp com ironwall) no ip 10.0.0.2. Para ser redirecionado automaticamente para sua página inicial, criei um código fonte dentro desta página inicial, recarrengando ela mesma, gerando assim, algumas conexões simultâneas e mudando automaticamente de página. Basicamente a regra funciona a ação do "conection limit".
    PS: A porta padrão do irowall foi alterada para a 81.


    BLOQUEIO DE CLIENTE PARA PÁGINA INICIAL

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1 dst-address=!10.0.0.2 protocol=tcp \
    dst-port=80 action=dst-nat to-addresses=10.0.0.2 to-ports=81 comment="REGRA \
    PARA DIRECIONAR CLIENTE PARA UMA MESMA PÁGINA \(D BITO\) - SISTEMA \
    INTELIGÊNTE DE BLOQUEIO" disabled=yes

    Esta regra é a mesma de cima, somente retirando o "conection limit" o mikrotik entenderá que em todas as circustâncias ele deve sempre redirecionar o cliente para o servidor (10.0.0.2). Neste caso o cliente 10.0.0.1 está bloqueado. A mesma página HTML pode ser utilizada (está em anexo), pois quando a mesma for redirecionada após os 10 segundos, irá voltar para ela mesma, criando um loop na qual o cliente não conseguirá sair e exibirá apenas aquela mensagem padrão de bloqueio. O ideal para ficar show, é incluir uma regra como a debaixo para este mesmo cliente, para bloquear todos os serviços, exceto o da página.

    REGRA ANEXA PARA BLOQUEIO DE CLIENTES

    /ip firewall nat
    add chain=src-nat src-address=10.0.0.1 protocol=!tcp \
    src-port=!80 action=drop comment="BLOQUEIO DE CLIENTE" \
    disabled=yes

    Com esta regra acima de exceção, o mikrotik bloqueará todas as portas e protocolos, menos a porta 80 e o protocolo tcp.

    Em anexo o ironwall e os arquivos da página inicial de testes... Dúvidas? Entre em contato que a gente desenvolve qualquer coisa!!!
    Parabéns meu Brother era disso que eu tava precisando, pois quando eu cortava o acesso dos clientes inadimplentes sempre aparecia meia duzia dew engraçadinhos dizendo que tava fora do ar que o serviço estava ruim ! Pq trabalho com ip fixo e nao tenho nem hotspot e nem ppoE

    Abraços !

  18. #18

    Padrão

    bom gente testei aqui e nao funcionou !

    Eu gostaria simplesmente que todo o acesso que o cliente fizesse o mikrotik redirecionasse para uma página na internet como vcs fizeram com ppoe, e eu gostaria de fazer com ip fixo ! Pois controlo meus clientes por ipxmac !

    Abraços !



  19. #19

    Padrão

    Citação Postado originalmente por admskill Ver Post
    bom gente testei aqui e nao funcionou !

    Eu gostaria simplesmente que todo o acesso que o cliente fizesse o mikrotik redirecionasse para uma página na internet como vcs fizeram com ppoe, e eu gostaria de fazer com ip fixo ! Pois controlo meus clientes por ipxmac !

    Abraços !
    Alguém se habilita ???

  20. #20

    Smile

    Citação Postado originalmente por admskill Ver Post
    Alguém se habilita ???


    Tinha em outra parte do forum...


    Redirecionando para um site da net

    ip firewall nat

    no nat logo depois do mascaramento
    add chain=dstnat protocol=tcp src-address-list=Clientes_block action=dst-nat \
    to-addresses=ip_do_site_do_aviso to-ports=80 comment="" disabled=no

    ip firewall address-list

    add list=Clientes_block address=ip_do_cliente comment="Fulano de tal" disabled=no

    Funciona perfeitamente para quem tem um site de aviso