Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Amigos,

    Coloquei abaixo o meu controle de banda para que os usuários utilizem o link de forma balanceada, fazendo downloads a 400 kbps e uploads a 200 kpbs.

    Estou meio inseguro quanto às interfaces usadas. Coloquei a ether1 como saída para o link e a wlan1 como tráfego local.

    Críticas e sugestões serão muito bem-vindas.


    Esquema da rede:
    Link -> Server -> swith -> Mikrotik -> usuários

    Primeiro, marcar os pacotes vindos da rede 192.168.x.0 com a marca “uses”:
    /ip firewall mangle add chain=forward src-address=192.168.x.0/24 \
    action=mark-connection new-connection-mark=users-con
    /ip firewall mangle add connection-mark=users-con action=mark-packet \
    new-packet-mark=users chain=forward

    Depois eu criei dois PCQs (filas por conexão), um para download outra para upload.
    /queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
    /queue type add name=pcq-upload kind=pcq pcq-classifier=src-address

    Em seguida, criei uma queue tree para download e outra para upload.
    Download
    /queue tree add name=Download parent=wlan1 max-limit=400000
    /queue tree add parent=Download queue=pcq-download packet-mark=users

    Upload:
    /queue tree add name=Upload parent=ether1 max-limit=200000
    /queue tree add parent=Upload queue=pcq-upload packet-mark=users

    Tirei esse controle do manual do MK, depois de lê-lo umas trezentas vezes.

  2. Não vou comentar o seu, apenas postar o meu... compare as diferenças, se existirem e teste (se quiser). Criei tem uns 20 dias e ao que parece tem funcionado bem (preciso acompanhar com mais atenção...)

    / ip firewall mangle
    add chain=prerouting src-address=10.4.0.0/16 p2p=all-p2p action=mark-packet new-packet-mark=p2p-franca passthrough=no comment="Marca pacotes p2p Franca" \
    disabled=no
    add chain=prerouting src-address=10.4.0.0/16 action=mark-packet new-packet-mark=franca passthrough=no comment="Marcar pacotes Franca" \
    disabled=no

    / queue type
    add name="pcq-download-franca" kind=pcq pcq-rate=600000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    add name="pcq-upload-franca" kind=pcq pcq-rate=600000 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000
    add name="pcq-p2p-down" kind=pcq pcq-rate=100000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    add name="pcq-p2p-upload" kind=pcq pcq-rate=100000 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000

    / queue tree
    add name="P2P-Down" parent=franca-in packet-mark=p2p-franca limit-at=0 queue=pcq-p2p-down priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="P2P-Up" parent=franca-out packet-mark=p2p-franca limit-at=0 queue=pcq-p2p-upload priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="franca-in" parent=global-in packet-mark=ilefrance limit-at=0 queue=pcq-download-franca priority=2 max-limit=0 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no
    add name="franca-out" parent=global-out packet-mark=ilefrance limit-at=0 queue=pcq-upload-franca priority=2 max-limit=0 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no

    / queue simple
    add name="franca" target-addresses=10.4.0.0/16 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 \
    queue=pcq-download-franca/pcq-upload-franca limit-at=0/0 max-limit=0/0 burst-limit=800000/800000 burst-threshold=600000/600000 \
    burst-time=30s/30s total-queue=default-small disabled=no



  3. Sergio,

    Percebi que você também fez controle P2P, coisa que eu preciso fazer.
    Mas minha pouca inteligência não me deixou entender exatamente o que você está controlando.

    Você poderia especificar o que você objetivou no seu controle de banda?
    E pra que serve a simple queue que você criou?

  4. Citação Postado originalmente por Del*.* Ver Post
    Sergio,

    Percebi que você também fez controle P2P, coisa que eu preciso fazer.
    Mas minha pouca inteligência não me deixou entender exatamente o que você está controlando.
    Não se subestime, com atenção entenderá as regras.

    Citação Postado originalmente por Del*.* Ver Post
    Você poderia especificar o que você objetivou no seu controle de banda?
    E pra que serve a simple queue que você criou?
    1 - marca pacotes de uma determinada rede que quero controlar
    2 - marca os pacotes p2p desta mesma rede.
    3 - cria-se as queue types pcq para o p2p (100k) e para a rede(600k).
    4 - cria-se as queue tree para a rede, associa-se as mesmas aos parents globais e a queue type, em seguida as queue tree para p2p associadas ao parent que é a queue tree da rede que acabou de criar e a queue type, onde o p2p terá os 100k dentro dos 600k disponibilizados a queue type de 600k.
    5 - criei a queue simple apenas para fazer o burst (nem verifiquei ainda se está funcionando de maneira correta).



  5. Sergio,
    Obrigado pelas dicas. Com elas, vou incrementar meu controle de banda.

    Valeu mesmo.

    Dell*.*






Tópicos Similares

  1. Respostas: 12
    Último Post: 12-02-2013, 16:38
  2. Cache Full Ok, Mas Perco Meu Controle De Banda
    Por cyberpoint no fórum Redes
    Respostas: 4
    Último Post: 11-06-2008, 21:28
  3. Vejam meu controle de banda e opinem
    Por adircastro no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 12-02-2008, 19:27
  4. Controle de Banda CBQ
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-08-2003, 14:55
  5. Controle de banda
    Por ediguedes no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-06-2002, 13:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L