Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Como faço para controlar o P2P "ARES" no mikrotik.

    Olá amigos, tenho controle de P2P no meu servidor mikrotik, ele funciona quase perfeitamente, pois ele controla programas de P2P tipo o emule e outros programas de P2P parecidos, menos o ARES, alguem já conseguiu aplicar um filtro para controlar o ARES? o ARES é o unico que não consigo controla, alias ele até consome mais banda do que disponibilizo pro meu cliente, tenho clientes cadastrados no QUEUES com 150k, mas quando ele ou eles usam o ARES eles consomem de 200k a 350k direto, principalmente de upload, preciso controla essa praga, se alguem tiver a solução agradeço pela ajuda.

    Fábio.

  2. #2

    Padrão

    Amigo tenho rodando aqui o controle de P2P do manual que temos no wiik, porem o ares percebi que consigo segurar ele apenas usando o limite de sessões por IP.
    Fiz o teste e realmente funciona, quando libero o controle de P2P e tiro o limite de sessões os downloads sobem, dae quando habilito as regras novamente ele caem muito, limitei em 512kpbs pra 400 maquinas em 1 link de 6mb porem todos os clientes estao com IP Publico ainda nao teste com IP privado atras de NAT mais deve funcionar do mesmo jeito

    Falow



  3. #3

    Padrão

    Citação Postado originalmente por cleciorodrigo Ver Post
    Amigo tenho rodando aqui o controle de P2P do manual que temos no wiik, porem o ares percebi que consigo segurar ele apenas usando o limite de sessões por IP.
    Fiz o teste e realmente funciona, quando libero o controle de P2P e tiro o limite de sessões os downloads sobem, dae quando habilito as regras novamente ele caem muito, limitei em 512kpbs pra 400 maquinas em 1 link de 6mb porem todos os clientes estao com IP Publico ainda nao teste com IP privado atras de NAT mais deve funcionar do mesmo jeito

    Falow
    como se faz o limite de sessões ? tens alguna receita pronta ?

  4. #4

    Padrão

    Segue abaixo os scripts pra controle de banda, bloqueio de conexões de entrada, e controle de sessões

    Script bloqeio de conexões de entrada destinadas ao IP do cliente nas portas 0 ate 1024
    /ip firewall filter : for i from=2 to=254 do={ add chain=forward src-address=0.0.0.0/0 dst-address=("192.168.0." . $i ) protocol=tcp dst-port=0-1024 action=drop }

    Script controle de banda simples
    /queue simple : for i from=1 to=254 do={ add name=("192.168.0." . $i ) target-address=("192.168.0." . $i . "/32") dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=128000/128000 total-queue=default-small }

    Script limite de sessões
    / ip firewall filter : for i from=2 to=254 do={ add chain=forward src-address=("192.168.0." . $i) protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop }

    Falow



  5. #5

  6. #6

    Padrão

    Gostaria de saber co mo realmente funciona o ARES, pois dizem que o mesmo utiliza a porta 80 e aqui no meu ele tem uma porta específica. Criei uma marcação específica para o ARES com o limite de banda meu desejado e funcionou perfeitamente... Se alguém que seja mais "expert" em ARES poder dar uma luz, seria melhor para desenvolermos soluções específicas... Como falei, criei um controle para ele e funcionou perfeitamente, ao menos em minha rede....



  7. #7
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Gostaria de saber co mo realmente funciona o ARES, pois dizem que o mesmo utiliza a porta 80 e aqui no meu ele tem uma porta específica. Criei uma marcação específica para o ARES com o limite de banda meu desejado e funcionou perfeitamente... Se alguém que seja mais "expert" em ARES poder dar uma luz, seria melhor para desenvolermos soluções específicas... Como falei, criei um controle para ele e funcionou perfeitamente, ao menos em minha rede....
    Dá uma olhada na documentação e também no forum do layer7 que encontrará algumas informações sobre o Ares.

  8. #8

    Padrão E aí, alguém conseguiu "domar" o ares ?

    hein... ?
    posta ae por favor



  9. #9

    Padrão

    Amigo eu consegui, sem maiores problemas seguindo o tutorial do wiki, aqui tenho um link de 6mb com a embratel em casa meu PC nao tem controle de banda sem estar ativado o controle p2p meu download é muito rapido mesmo colocando varios downloads simultaneos, todos sao superiores a 50kbps, usando o controle ativado não passou de 10kbps e quanto mais download ativo, menor a velocidade dos downloads, o mesmo vale para upload, lembrando que usei tambem o controle de sessoes limitando em 30 sessoes tcp por IP, sendo todos os clientes deste meu servidor com IP Público, sem o uso de NAT

    Falow

  10. #10

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Gostaria de saber co mo realmente funciona o ARES, pois dizem que o mesmo utiliza a porta 80 e aqui no meu ele tem uma porta específica. Criei uma marcação específica para o ARES com o limite de banda meu desejado e funcionou perfeitamente... Se alguém que seja mais "expert" em ARES poder dar uma luz, seria melhor para desenvolermos soluções específicas... Como falei, criei um controle para ele e funcionou perfeitamente, ao menos em minha rede....
    O ares usa criptografia na conexao e portas aleatórias. Por causa da criptografia, o mikrotik não identifica ele como p2p e nem consegue controlar a banda dele.
    Uma alternativa para resolver isso, é criar uma regra no firewall dropando o protocolo warez, que impede o ares de conectar e usar a criptografia. Mas nem a pesquisa do ares vai funcionar.



  11. #11

    Padrão Warez ?

    por gentileza, teria como vc demostra a regra ?

  12. #12



  13. #13

    Padrão

    Aqui tinha esse problema também... Minha sorte é que ainda tenho nessa rede o bom e velho CBQ, numa máquina com Conectiva 10... Esse segurou o Ares...

  14. #14

    Padrão

    Ae galera estou disponibilizando as regras de controle P2P que uso aqui no caso limito todos os clientes em 512kbps, abra um terminal

    acesse /ip firewall mangle e adicione as seguintes regras

    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=Conexao-P2P passthrough=yes

    add chain=prerouting connection-mark=Conexao-P2P action=mark-packet new-packet-mark=Pacotes-P2P passthrough=yes

    agora acesse /queue tree e adicione as seguintes regras

    add name="P2P-Donwload" parent=global-in packet-mark=Pacotes-P2P limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0 burst-threshold=0 burst-time=0s

    add name="P2P-Upload" parent=global-out packet-mark=Pacotes-P2P limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0 burst-threshold=0 burst-time=0s

    Lembrando que uso IP Público em meus cliente, não fiz o teste com NAT e aqui funciona muito bem, e não tive ate agora problema com Ares.

    Falow



  15. #15

    Padrão

    Amigo fiz como descreveu aqui mas nao deu certo, se puder me ajudar com mais alguma instrucoes eu ficaria muito agradecido.
    abraços


    Citação Postado originalmente por cleciorodrigo Ver Post
    Ae galera estou disponibilizando as regras de controle P2P que uso aqui no caso limito todos os clientes em 512kbps, abra um terminal

    acesse /ip firewall mangle e adicione as seguintes regras

    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=Conexao-P2P passthrough=yes

    add chain=prerouting connection-mark=Conexao-P2P action=mark-packet new-packet-mark=Pacotes-P2P passthrough=yes

    agora acesse /queue tree e adicione as seguintes regras

    add name="P2P-Donwload" parent=global-in packet-mark=Pacotes-P2P limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0 burst-threshold=0 burst-time=0s

    add name="P2P-Upload" parent=global-out packet-mark=Pacotes-P2P limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0 burst-threshold=0 burst-time=0s

    Lembrando que uso IP Público em meus cliente, não fiz o teste com NAT e aqui funciona muito bem, e não tive ate agora problema com Ares.

    Falow

  16. #16

    Padrão

    Amigo fiz como descreveu aqui mas nao deu certo, se puder me ajudar com mais alguma instrucoes eu ficaria muito agradecido.
    abraços



  17. #17

    Padrão

    As regras acima funcionam são as mesmas do manual no wiki, tenho rodando aqui e tambem tenho alguns amigos usando e funciona perfeitamente, posta ai como esta sua configuração, e tambem suas regras.

    Citação Postado originalmente por duaardo Ver Post
    Amigo fiz como descreveu aqui mas nao deu certo, se puder me ajudar com mais alguma instrucoes eu ficaria muito agradecido.
    abraços

  18. #18

    Padrão ....

    Eu tb nao consegui !



  19. #19

  20. #20

    Padrão

    Citação Postado originalmente por antoni Ver Post
    O ares usa criptografia na conexao e portas aleatórias. Por causa da criptografia, o mikrotik não identifica ele como p2p e nem consegue controlar a banda dele.
    Uma alternativa para resolver isso, é criar uma regra no firewall dropando o protocolo warez, que impede o ares de conectar e usar a criptografia. Mas nem a pesquisa do ares vai funcionar.
    isso mesmo amigo, a unica solução pro ares ate o momento e dropar ele, pois essa praga acaba com qualquer link. outra coisa, quando criar a regra as coneções estabelecidas não para, para isso tem que dar um reboot, e adeus ares.


    saip

    o sol nasce para todos, mas a maioria gosta de dormir um pouco mais