+ Responder ao Tópico



  1. Ol´pessoal

    Estou com um problema em meu server, ele nao inicia e da um erro no RNDC, uso a distribuição ubuntu server 6.06 LTS, ja corrigi varios servidores com este problema era so gerar a chave e colocar aas chaves no rndc.conf e no named. conf, mas este não consigo de geito nenhum. o named está configurado enjaulado feito igual a este site "http://www.debianpt.org/node/959"
    o que ta me deixando mais irritado ele nao mostra nada no log,é como se o bind nao enviasse registro pro log, enquanto em outros servidores ao reiniciar o bind existe o registro no log perfeitamente. /var/log/sysconf ou messages


    me ajude por favor
    segue abaixo o erro e os arquivos de configurações


    Erro:
    root@intersrv01:/etc/bind# /etc/init.d/bind9 restart
    * Stopping domain name service...
    rndc: connect failed: connection refused
    ...done.
    * Starting domain name service...
    ...done.
    root@intersrv01:/etc/bind#
    ---------------------------------------------------------
    #named.conf
    include "/etc/bind/named.conf.options";

    key "rndc-key" {
    algorithm hmac-md5;
    secret "3XP3jNfFGNWs4RvXXjLa8w==";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };
    zone "." {
    type hint;
    file "named.ca";
    };

    zone "localhost" {
    type master;
    file "db.local";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "db.127";
    };

    include "/etc/bind/named.conf.local";
    -------------------------------
    # rndc.conf
    key "rndc-key" {
    algorithm hmac-md5;
    secret "3XP3jNfFGNWs4RvXXjLa8w==";
    };

    options {
    default-key "rndc-key";
    default-server 127.0.0.1;
    default-port 953;
    };
    ---------------------------------

    #syslog.conf
    auth,authpriv.* /var/log/auth.log
    *.*;auth,authpriv.none -/var/log/syslog
    cron.* /var/log/cron.log
    daemon.* -/var/log/daemon.log
    kern.* -/var/log/kern.log
    lpr.* -/var/log/lpr.log
    mail.* -/var/log/mail.log
    user.* -/var/log/user.log
    uucp.* /var/log/uucp.log

    #
    # Logging for the mail system. Split it up so that
    # it is easy to write scripts to parse these files.
    #
    mail.info -/var/log/mail.info
    mail.warn -/var/log/mail.warn
    mail.err /var/log/mail.err

    # Logging for INN news system
    #
    news.crit /var/log/news/news.crit
    news.err /var/log/news/news.err
    news.notice -/var/log/news/news.notice

    #
    # Some `catch-all' logfiles.
    #
    *.=debug;\
    auth,authpriv.none;\
    news.none;mail.none -/var/log/debug
    *.=info;*.=notice;*.=warn;\
    auth,authpriv.none;\
    cron,daemon.none;\
    mail,news.none -/var/log/messages

    #
    # Emergencies are sent to everybody logged in.
    #
    *.emerg *

    #
    # I like to have messages displayed on the console, but only on a virtual
    # console I usually leave idle.
    #
    #daemon,mail.*;\
    # news.=crit;news.=err;news.=notice;\
    # *.=debug;*.=info;\
    # *.=notice;*.=warn /dev/tty8

    # The named pipe /dev/xconsole is for the `xconsole' utility. To use it,
    daemon.*;mail.*;\
    news.crit;news.err;news.notice;\
    *.=debug;*.=info;\
    *.=notice;*.=warn |/dev/xconsole

    kern.=debug -/var/log/bandwidth
    -----------------------------------------------------

  2. Resolvi o problema do LOG, e agora sei queal o problema, porem ainda nao consegui corrigir

    starting BIND 9.3.2 -u bind -t /var/lib/bind9/
    Jun 18 10:44:25 intersrv01 named[8217]: found 1 CPU, using 1 worker thread
    Jun 18 10:44:25 intersrv01 named[8217]: loading configuration from '/etc/bind/named.conf'
    Jun 18 10:44:25 intersrv01 named[8217]: /etc/bind/named.conf.options:2: change directory to '/var/lib/bind9/var/named/' failed: file not found
    Jun 18 10:44:25 intersrv01 named[8217]: /etc/bind/named.conf.options:2: parsing failed
    Jun 18 10:44:25 intersrv01 named[8217]: loading configuration: file not found
    Jun 18 10:44:25 intersrv01 named[8217]: exiting (due to fatal error)

    Os arquivo se encontram no diretorio so que ele nao reconhece, ja configurei permissãoe e nada






Tópicos Similares

  1. zabbix não inicia o serviço (erro nos host windows)
    Por davidcortez no fórum Servidores de Rede
    Respostas: 6
    Último Post: 21-11-2008, 14:14
  2. Bind não inicia
    Por fajo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-02-2008, 03:46
  3. BIND não inicia no Conectiva 10
    Por dogmatico no fórum Servidores de Rede
    Respostas: 8
    Último Post: 17-05-2005, 10:58
  4. Erro no gcc, não pode criar ecexutáveis
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 4
    Último Post: 12-03-2004, 13:39
  5. script que nao inicia no boot
    Por demiurgo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-03-2003, 17:02

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L