Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal, tenho um erro que deve ser bastante comum

    Uso o VI para editar Perl, as vezes quero copiar parte de um código dentro de um arquivo e quando colo, ele cola com um espaços malucos e a tabulação fica totalmente fora. Isso faz com que eu tenha que arrumar linha a linha ou tenha que fazer um filtro para isso. Alguem conhece isso?

  2. Quando vc abrir um arquivo com o vim, digite : para entrar no modo linha de comando, e coloque esta configuração:
    Código :
    :set noautoindent
    se eu entendi o seu problema, isso resolve.
    abraço



  3. Olá...

    não deu certo não. Quando eu seleciono um código com o mouse e tento colar, ele continua colando dando espações no inicio de cada linha, e estes espações aumentam a cada linha. Logo, se eu colar umas 100 linhas por exemplo, ele vai me dar mais de 400 caracteres de espaçamento em cada linha.

  4. 1º - Tecle "esc"
    2º - Tecle ":"
    3º - set paste > digite enter
    4º - tecle "i" - no rodapé ira aparecer "paste (insert).

    agora é só colar.



  5. Uma observação, quanto estou escrevendo meus scripts uso tambem o ":set number" dessa forma as linhas são numeradas.






Tópicos Similares

  1. Como copiar texto e colar no terminal com um script
    Por Giovane Silva no fórum Redes
    Respostas: 3
    Último Post: 10-01-2013, 12:28
  2. Respostas: 9
    Último Post: 03-11-2009, 18:56
  3. Erro ao editar arquivo no VI
    Por sgeovane no fórum Servidores de Rede
    Respostas: 4
    Último Post: 26-03-2004, 08:50
  4. Erro ao instalar programa no Debian com apt-get
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-02-2004, 07:24
  5. proxy transparente no squid com erro
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 20-06-2003, 11:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L