Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Isso mesmo!!! Pra quem usa ADSL e só consegue acessar 1 mikrotik na rede, consegui desenvolver uma regra pra salvar a pele de quem está fora da rede (como estou agora) e acessar todas as suas redes usando o DDNS. Com esta regra você conseguirá acessar toda sua rede, quando estiver viajando ou passeando por ae... Útil também para quem tem vários ADSL na rede e só consegue acessar o primeiro Mikrotik. Já posto ela...

  2. posta ai amigo
    to curioso pra testar

    ha e afinal como falo com voce, sobre o negocio do suporte, no msn nunca mais te vi.



  3. so faltou postar a regra

  4. Citação Postado originalmente por catvbrasil Ver Post
    Isso mesmo!!! Pra quem usa ADSL e só consegue acessar 1 mikrotik na rede, consegui desenvolver uma regra pra salvar a pele de quem está fora da rede (como estou agora) e acessar todas as suas redes usando o DDNS. Com esta regra você conseguirá acessar toda sua rede, quando estiver viajando ou passeando por ae... Útil também para quem tem vários ADSL na rede e só consegue acessar o primeiro Mikrotik. Já posto ela...
    NAo seria isso aki noa???


    Primeiro só fazer o cadastro aki??? Depois colocar essa regra em cada um ds MK'S????
    Free Dynamic DNS / Free Domain Names


    Adicione esse Script:
    :log info "DDNS: Begin"

    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Agora voce deve agendar a execução do Script:
    Agendar...
    -----------------------------------------------------------
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO" disabled=no

    Tem mais facil q isso??? Ahhhhhhhh um cadastro pra cada MK...

    Ai para os menos entendidos rssssssssssss basta colocar no winbox : "connect to: O NOME CRIADO NO SITE.
    Última edição por cgrellier; 28-06-2007 às 15:52.



  5. Citação Postado originalmente por cgrellier Ver Post
    NAo seria isso aki noa???


    Primeiro só fazer o cadastro aki??? Depois colocar essa regra em cada um ds MK'S????
    Free Dynamic DNS / Free Domain Names


    Adicione esse Script:
    :log info "DDNS: Begin"

    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Agora voce deve agendar a execução do Script:
    Agendar...
    -----------------------------------------------------------
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO" disabled=no

    Tem mais facil q isso??? Ahhhhhhhh um cadastro pra cada MK...

    Ai para os menos entendidos rssssssssssss basta colocar no winbox : "connect to: O NOME CRIADO NO SITE.
    O script e agendamento para DDNS estão corretos, mas não seria isso... Quando você trabalha com o DDNS e tem mais de um Mikrotik interligado, não se consegue acessar mais de um MK pois a porta padrão winbox não é mudada... Para funcionar desenvolvi esta regra, pois estou com ADSL e 3 MK em séria. Com o script só consegui acessar o primeiro mikrotik... Segue a regra:

    /ip firewall nat
    add chain=dstnat in-interface=pppoe-out1 protocol=tcp dst-port=8291 \
    action=dst-nat to-addresses=192.168.200.1 to-ports=8291 comment="ENTRAR EM \
    NOVAS TORRES" disabled=yes

    Onde o ip 192.168.200.1 é o segundo mikrotik que deseja acessar... Esta regra deve ser usada assim:

    Incluir e deixar desabilitada. Entrar no mikrotik base. Deixá-lo aberto e habilitar a regra. Entrar novamente no mikrotik pelo ddns. Ele entrará agora na segundo mikrotik. Você acessará os 2 individualmente. Quando terminar de usar a segunda torre, desabilite a regra no seu primiro mikrotik, pois caso a mesma fique habilitada, quando entrar novamente ele irá direto para a segunda torre, somente sendo possível desabilitar a regra (para ter acesso a primeira), via ssh do próprio winbox. Esta regra é segura e 100% funcional e pode ser aplicada em quantas torres em cascata tiver.

    MInha estrutura hoje é assim:

    ADSL => MIKROTIK (BASE) => MIKROTIK (DISTRIBUIÇÃO) => MIKROTIK (DISTRIBUIÇÃO)

    Consegui perfeito acesso a todos os mikrotik...

    Qualquer dúvida estamos ae!!
    Última edição por catvbrasil; 28-06-2007 às 21:48.






Tópicos Similares

  1. Respostas: 0
    Último Post: 09-02-2015, 14:57
  2. Mais de um HOTSPOT no mesmo Mikrotik
    Por LeopoldoMeireles no fórum Redes
    Respostas: 3
    Último Post: 22-05-2009, 22:58
  3. Mais de um diretório no Proftpd
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 01-04-2003, 07:36
  4. mais de um Gateway no linux...
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-03-2003, 17:08
  5. Login em mais de um servidor
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-02-2003, 08:42

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L