Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Fala galera,

    Estou precisando de uma ajuda para autenticar o DynDNS no MK. Eu ja conheço aquele script que está no site internacional do MK + qdo eu coloco ele la em /system script e clico em Run script na no RunCont continua marcando 0, acredito que nao esteja rodando....alguem pode me explicar pq?

    :log info "DDNS: Begin"

    :global ddns-user "usuario ddns"
    :global ddns-pass "senha do ddns"
    :global ddns-host "host criado no ddns"
    :global ddns-interface "interface que está a internet"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"

  2. Citação Postado originalmente por iceblue Ver Post
    Fala galera,

    Estou precisando de uma ajuda para autenticar o DynDNS no MK. Eu ja conheço aquele script que está no site internacional do MK + qdo eu coloco ele la em /system script e clico em Run script na no RunCont continua marcando 0, acredito que nao esteja rodando....alguem pode me explicar pq?

    :log info "DDNS: Begin"

    :global ddns-user "usuario ddns"
    :global ddns-pass "senha do ddns"
    :global ddns-host "host criado no ddns"
    :global ddns-interface "interface que está a internet"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Amigo tudo joia??

    Se estiver procurando sobre dns dinamico no mikrotik nesse post que eu respondi tem a solução https://under-linux.org/forums/mikro...aber-o-ip.html precisando estamos na area.. t+



  3. Citação Postado originalmente por gilbertoandrade Ver Post
    Amigo tudo joia??

    Se estiver procurando sobre dns dinamico no mikrotik nesse post que eu respondi tem a solução https://under-linux.org/forums/mikro...aber-o-ip.html precisando estamos na area.. t+
    Amigo, fiz tudo o que voce pediu no outro post e mesmo assim nao marca nada no Run Script....existe algum problema com a versão cracked do MK?

  4. Citação Postado originalmente por iceblue Ver Post
    Amigo, fiz tudo o que voce pediu no outro post e mesmo assim nao marca nada no Run Script....existe algum problema com a versão cracked do MK?
    amigo fiz isso usando a versão 2.9.27 ajeitada rsrsrsrs.... e funcionou numa boa, quando vc vai la em script e da um run no script oq ele te retorna? olhou no log para ver se retorna algum erro??



  5. Citação Postado originalmente por gilbertoandrade Ver Post
    amigo fiz isso usando a versão 2.9.27 ajeitada rsrsrsrs.... e funcionou numa boa, quando vc vai la em script e da um run no script oq ele te retorna? olhou no log para ver se retorna algum erro??
    Olhei nos logs, e nao retorna erro nenhum....achei meio estranho....posso estar fazendo algo errado....vou refazer tudo aki!






Tópicos Similares

  1. Mikrotik & DynDNS
    Por DataLinux no fórum Redes
    Respostas: 5
    Último Post: 09-03-2007, 18:02
  2. Problemas com Ipfixo?Use o Dyndns
    Por cadeveloper no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-03-2005, 07:28
  3. Configurar dyndns
    Por sgeovane no fórum Servidores de Rede
    Respostas: 3
    Último Post: 01-03-2005, 18:48
  4. Dyndns X no-ip
    Por sgeovane no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-01-2005, 07:52
  5. DynDNS.org
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-08-2004, 15:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L