+ Responder ao Tópico



  1. Caros Amigos, Habilitei o apache esta rodando tudo ok. Consegui habilitar o meu servidor DNS e tambem tudo ok

    Agora me surgiu um problema : quando eu digito no meu browser http://www.meudominio.com.br o servidor DNS aponta direitinho para o apache e o mesmo exibe tudo certinho. Todavia quando eu digito http://meudominio.com.br , ou seja sem o "www" o servidor encaminha a requisição para a pasta defult do apache ( www/htdocs) e exibe o index que está nesta pasta . Vale ressaltar que este dominio está com diretiva "serverAlias" que supostamente serve para está finalidade, Inclusive já configurei a diertiva <directory> no httpd.conf e não resolveu o problema.
    Gostaria de saber se o problema é no meu DNS o alguma outra diretiva do apache?

    Grato!

  2. coloca a configuracao ai do apache.. e das entradas do dns...



  3. Citação Postado originalmente por nilsonfsilva Ver Post
    Agora me surgiu um problema : quando eu digito no meu browser http://www.meudominio.com.br o servidor DNS aponta direitinho para o apache e o mesmo exibe tudo certinho. Todavia quando eu digito http://meudominio.com.br , ou seja sem o "www" o servidor encaminha a requisição para a pasta defult do apache ( www/htdocs) e exibe o index que está nesta pasta . Vale ressaltar que este dominio está com diretiva "serverAlias" que supostamente serve para está finalidade, Inclusive já configurei a diertiva <directory> no httpd.conf e não resolveu o problema.
    Gostaria de saber se o problema é no meu DNS o alguma outra diretiva do apache?

    Grato!
    O problema não está bind, está no apache . Se o domínio sem www aponta para a página default o bind ja fez a parte dele.
    Poste a configuração de servername e serveralias de seu apache. Se está usando vhost poste o vhost completo.

    Falow

  4. nilsonfsilva,

    Não sei se você já conseguiu resolver o problema, mas é um problema clássico de configuração do apache. Você deve verificar dentro do "<VirtualHost>" correspondente ao seu dominio e dentro dessa tag deve ter uma diretiva da segunte forma:

    ServerName www.meudominio.com.br

    Pois bem, o que você precisa agora é adicionar a diretiva

    ServerAlias meudominio.com.br

    Com o "ServerAlias" você pode fazer outro dominio apontar para o mesmo, por exemplo, vamos dizer que você tenha e queira que o dominio "outrodominio.com.br" também aponte para esse mesmo, então você colocar na diretiva "ServerAlias":

    ServerAlias meudominio.com.br outrodominio.com.br

    Ou até mesmo:

    ServerAlias meudominio.com.br
    ServerAlias outrodominio.com.br


    Espero ter esclarecido sua dúvida como de outras pessoas também.

    ate+






Tópicos Similares

  1. Onde esta instalado o Calc do Openoffice?? Urgente
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 10-12-2003, 07:03
  2. Como eu sei se o bind/dns esta funcionando?
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 6
    Último Post: 14-10-2003, 16:52
  3. onde esta errado nesse comando CUT?!
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-10-2003, 22:30
  4. onde esta o PostgreSQL 7.3
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-06-2003, 12:21
  5. Como sei onde está montado???
    Por serrato no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-07-2002, 13:43

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L