Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Wiki -Load Balance Free com problemas

    Pessoal finalmente consegui meu segundo link e estou tentando fazer um loadbalance e segui um tutorial postado no wiki https://under-linux.org/wiki/index.p...d_Balance_Free que ajudei um amigo a postar la no wiki e descobri q nao funciona e dentro deste tutorial tem 2 tipos de loadbalance, testando o primeiro percebi q faltam algumas informacoes mas mesmo assim consegui finalizar mas nao consegui entrar em nenhuma pagina ai parti pro segundo ja q estava escrito q era mais facil ainda e q era so copiar e colar, copiei e colei mas deu erro, por algum motivo o mikrotik nao aceitou nenhum dos scripts ai eu parti para a interpretacao dos scripts para fazer manualmente e descobri q haviam varios itens q nao consegui achar e fiquei frustrado de novo, sera q alguem poderia dar uma olhada no wiki e ver o q tem de errado e consertar e o q tiver faltando acrescentar por favor.

  2. #2

    Padrão

    No primeiro segmento q tem as figuras deu o seguinte erro:

    ERROR
    The requested URL could not be retrieved

    Ja no segundo seguimento eu nao consegui achar algumas opcoes fazendo o script manualmente e se eu copiar e colar no terminal ele da erro e o script nao funciona.



  3. #3

    Wink

    Ola Maxmelo,

    Load balance que funcione é bastante complicado, sofri bastante tbm mas com tenho um funcionando com dois links também... colocar ele aqui como script é complicado mas podemos tentar adaptá-lo para sua situação.
    Posta mais detalhes de como está teus links (ips, gwt, etc) que tetarei fazer a adaptação do meu pra vc e consequentemente para os demais do forum que quizerem tentarem fazer.
    abrços

  4. #4

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    Ola Maxmelo,

    Load balance que funcione é bastante complicado, sofri bastante tbm mas com tenho um funcionando com dois links também... colocar ele aqui como script é complicado mas podemos tentar adaptá-lo para sua situação.
    Posta mais detalhes de como está teus links (ips, gwt, etc) que tetarei fazer a adaptação do meu pra vc e consequentemente para os demais do forum que quizerem tentarem fazer.
    abrços
    Antes de tudo muito obrigado pela ajuda....

    entao vamos lá:

    Link1 IP: 192.168.254.254/24
    Link2 IP: 192.168.173.254/24
    IP Mikrotik: 192.168.254.100/24 / 192.168.173.100/24
    Interface Local IP Mkt: 10.50.0.1/24 / 172.16.0.1/24
    Interface Local IP Clientes Cabeados: De 10.50.0.2/24 até 10.50.0.254/24
    Interface Local IP Clientes Wireless: De 172.16.0.2/24 até 172.16.0.254/24

    Estou usando DHCP só no 10.50.0.0/24 e fixando o IP sempre no mesmo mac, ja com o 172.16.0.0/24 eu nao usei DHCP por nao saber como fazer aliais nem sei se é possivel ter 2 servidores DHCP na mesma rede sendo 1 para Cabeados e outro para WIFI.

    Espero ter colocado todas as informacoes necessarias.



  5. #5

    Padrão

    Pessoal sei q é dificil mas to precisando disso urgente, se alguem puder me ajudar eu agradeco...

  6. #6

    Padrão

    Veja se consegue compreender isso:

    ip address
    add address=1.1.1.50/24 network=1.1.1.0 broadcast=1.1.1.255 interface=Local comment="" disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.1.1.3 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 comment="" disabled=no

    Obs: Trocar o ODD por EVEN entre os 2 NAT´s


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 routing-mark=even comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 comment="TESTE2" disabled=yes



  7. #7

    Padrão

    Citação Postado originalmente por liandrocarniel Ver Post
    Veja se consegue compreender isso:

    ip address
    add address=1.1.1.50/24 network=1.1.1.0 broadcast=1.1.1.255 interface=Local comment="" disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.1.1.3 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 comment="" disabled=no

    Obs: Trocar o ODD por EVEN entre os 2 NAT´s


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 routing-mark=even comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 comment="TESTE2" disabled=yes
    / ip address
    add address=192.168.254.100/24 network=192.168.254.0 broadcast=192.168.254.255 \
    interface=Publica comment="Link Internet Telemar" disabled=no
    add address=10.50.0.1/24 network=10.50.0.0 broadcast=10.50.0.255 \
    interface=Local comment="Link Cabeado" disabled=no
    add address=172.16.0.1/24 network=172.16.0.0 broadcast=172.16.0.255 \
    interface=Local comment="Link Wireless" disabled=no
    add address=192.168.173.100/24 network=192.168.173.0 broadcast=192.168.173.255 \
    interface=Publica2 comment="Link Internet Telemar2" disabled=no


    #
    / ip firewall mangle
    add chain=prerouting src-address=10.50.0.0/24 action=mark-routing \
    new-routing-mark=GroupA passthrough=no comment="Grupo A" disabled=no
    add chain=prerouting src-address=172.16.0.0/24 action=mark-routing \
    new-routing-mark=GroupB passthrough=no comment="Grupo B" disabled=no
    add chain=prerouting protocol=tcp dst-port=22-23 \
    action=add-src-to-address-list address-list=drop_port_22_23 \
    address-list-timeout=0s comment="Ajuste de Bloqueio SSH e Telnet" \
    disabled=yes
    add chain=postrouting out-interface=Local p2p=all-p2p action=mark-packet \
    new-packet-mark=p2p-down-mark passthrough=yes comment="Marca Todo Trafego \
    p2p" disabled=no
    add chain=forward out-interface=Publica p2p=all-p2p action=mark-packet \
    new-packet-mark=p2p-up-mark passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp src-port=1863 action=mark-packet \
    new-packet-mark=msn-out passthrough=yes comment="Msn" disabled=no
    add chain=prerouting protocol=tcp dst-port=1863 action=mark-packet \
    new-packet-mark=msn-in passthrough=yes comment="" disabled=no
    add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1360 \
    comment="Msn" disabled=no
    add chain=prerouting protocol=udp dst-port=5060 action=mark-connection \
    new-connection-mark=voip_in passthrough=yes comment="VOIP-IN" disabled=no
    add chain=prerouting connection-mark=voip_in action=mark-packet \
    new-packet-mark=VOIP_IN passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=udp src-port=5060 action=mark-connection \
    new-connection-mark=voip_out passthrough=yes comment="VOIP-OUT" \
    disabled=no
    add chain=prerouting connection-mark=voip_out action=mark-packet \
    new-packet-mark=VOIP_OUT passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
    new-connection-mark=http-down passthrough=yes comment="HTTP" disabled=no
    add chain=prerouting connection-mark=http-down action=mark-packet \
    new-packet-mark=HTTP passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-connection \
    new-connection-mark=443_conn passthrough=yes comment="SSL" disabled=no
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p_conn passthrough=yes comment="Marca o de Pacotes \
    p2p" disabled=no
    add chain=prerouting connection-mark=p2p_conn action=mark-packet \
    new-packet-mark=p2p passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=udp action=mark-connection \
    new-connection-mark=udp_teste passthrough=yes comment="Marca o de Udp" \
    disabled=no
    add chain=prerouting connection-mark=udp_teste action=mark-packet \
    new-packet-mark=udp passthrough=yes comment="" disabled=no


    / ip firewall nat
    add chain=srcnat src-address=10.50.0.0/24 action=masquerade \
    comment="masquerade hotspot network" disabled=no
    add chain=srcnat src-address=172.16.0.0/24 action=masquerade comment="" \
    disabled=no
    add chain=srcnat out-interface=Publica action=masquerade comment="Nat" \
    disabled=no
    add chain=srcnat out-interface=Publica2 action=masquerade comment="" \
    disabled=no
    add chain=dstnat in-interface=Local protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="Proxy Rede Interna" disabled=no


    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="" disabled=no



    o meu esta assim, sera q poderia dar uma olhada pra ver se tem algo de errado e me mostrar o q eu tenho de acrescentar por favor...

  8. #8

    Padrão

    Falta simplesmente o essencial no teu Mangle

    Tem um monte de regras, mas nenhuma que trate o balanceamento (uma conexão sai uma hora por um link, na outra por outro)...
    Veja as regras que postei...

    O Mangle é o que faz tudo... e das regras que coloquei você nao tem nada parecido.



  9. #9

    Padrão

    Citação Postado originalmente por liandrocarniel Ver Post
    Falta simplesmente o essencial no teu Mangle

    Tem um monte de regras, mas nenhuma que trate o balanceamento (uma conexão sai uma hora por um link, na outra por outro)...
    Veja as regras que postei...

    O Mangle é o que faz tudo... e das regras que coloquei você nao tem nada parecido.
    Vou testa mais tarde pq agora é horario de pico e depois eu posto aqui se funcionou ou nao, mesmo assim vlw...

  10. #10



  11. #11

    Padrão

    Como te falei, o que falta são as regras do Mangle. Repetindo então:

    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    Interprete elas, e apenas mude os nomes... onde diz in-interface, vai o nome da sua interface. Acho até que dá para deixar sem nome, dai ele usará para todas as interfaces que vão aos teus clientes. Crie esses mangles e ative, e veja se pelo menos estão passando informações por ela (pacotes). Se sim, veja as rotas conforme digo abaixo. Não tem erro.

    o event e odd que aparecem ai, é o nome que você vai ter que dar para as tuas rotas. Conforme exemplo abaixo.

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 routing-mark=even comment="" disabled=no

  12. #12

    Padrão

    Citação Postado originalmente por liandrocarniel Ver Post
    Como te falei, o que falta são as regras do Mangle. Repetindo então:

    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= NOME1 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    Interprete elas, e apenas mude os nomes... onde diz in-interface, vai o nome da sua interface. Acho até que dá para deixar sem nome, dai ele usará para todas as interfaces que vão aos teus clientes. Crie esses mangles e ative, e veja se pelo menos estão passando informações por ela (pacotes). Se sim, veja as rotas conforme digo abaixo. Não tem erro.

    o event e odd que aparecem ai, é o nome que você vai ter que dar para as tuas rotas. Conforme exemplo abaixo.

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=200.xxx.xxx.xxx scope=255 target-scope=10 routing-mark=even comment="" disabled=no
    Nome1 é a interface do cliente ou do link?



  13. #13

    Padrão

    Ja fiz e a resposta q o IE me da é essa ai abaixo:

    ERROR
    The requested URL could not be retrieved

  14. #14

    Padrão

    Os pacotes estao sendo marcados mas qdo acesso a internet da esse erro e a pagina nao abre



  15. #15

    Padrão

    O nome da interface é a que sei para o cliente.

    Se está dando erro para navegar, é porque algo não está certo ainda...
    É dificil avaliar o que pode estar errado...

    Você deu os nomes para as rotas?

    No ultimo exemplo coloquei lá que você precisa dar o nome para as rotas (even e odd)

  16. #16

    Padrão

    me chama pelo messenger q vou te dar um login e senha



  17. #17

    Padrão

    maxmello to tendo os mesmos problemas ...
    vamos mais tarde tentar solucionar isso ?
    ai agente posta aki!

  18. #18

    Padrão

    Até poderia te ajudar também, mas depois da ´besteira´ que fiz com o maxmelo, não sei se ele vai indicar.

    Loguei no MT, e tinha 2 rotas duplicadas. Quando exclui uma, caiu a conexão (provavelmente dos clientes dele)...
    Foi mal aí amigo... Desculpe se o transtorno foi grande.

    Mas creio que o balanceamento está funcionando (o único problema que não 100% pois havia 3 rotas, e 2 eram iguais). Tem que resolver isso, para ficar 100%.



  19. #19

    Padrão

    Olá Max,
    demorei um bocado, mas veja se com esses comandos vc resolve seu problema do uso dos dois links:
    P.S.: O que eu tou propondo é o uso dos dois links, tipo o msn, orkut, bancos, vai sair pelo link 2. e o demais pelo link 1 (claro que isso pode ser invertido!). tambem pode-se modificar pra sair os lixos (principalmente os p2p) por um link e o trafego bom pelo outro. As variaveis são inumeras.
    Mas do jeito que está não terá o uso alternado, (uso assim pq tenho o web-proxy e se for alternar, várias coisas não iram funcionar, tipo msn, sites de banco: pq eles não entenderiam essas alternancias e acabariam derrubando a sua conexão)
    Se for do seu interesse veja ae como fica.

    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=32.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.4.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=64.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=65.54.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=65.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=66.232.99.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=72.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.101.81.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.201.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.221.2.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.241.42.4/32 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="TESTE LINK2" disabled=no
    add dst-address=200.252.57.4/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK1" disabled=no
    add dst-address=207.46.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=207.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link1" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    / system script
    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    / tool netwatch
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK1-UP \
    down-script=LINK1-DOWN comment="TESTE LINK1" disabled=no
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK2-UP \
    down-script=LINK2-DOWN comment="TESTE LINK2" disabled=no

    Forte Abraço.
    Att.
    Josevaldo

  20. #20

    Padrão

    Para os que tentarem essa opção que postei:
    1º) As rotas são estáticas e estão indicando os links que o msn, orkut, e alguns bancos vão utilizar;
    2º) Os demais acessos vão sair pelo outro link;
    3º) Caso algum link (rota) pare de responder, os acessos a eles serão encaminhados para o outro (pelo script é feito a checagem a cada 10min);
    É isso ae, faço dessa forma para poder continuar usando o web-proxy, caso alguem queria melhorar essas regras favor disponibilizar pra galera.
    Te mais