+ Responder ao Tópico



  1. #19

    Padrão

    Olá Max,
    demorei um bocado, mas veja se com esses comandos vc resolve seu problema do uso dos dois links:
    P.S.: O que eu tou propondo é o uso dos dois links, tipo o msn, orkut, bancos, vai sair pelo link 2. e o demais pelo link 1 (claro que isso pode ser invertido!). tambem pode-se modificar pra sair os lixos (principalmente os p2p) por um link e o trafego bom pelo outro. As variaveis são inumeras.
    Mas do jeito que está não terá o uso alternado, (uso assim pq tenho o web-proxy e se for alternar, várias coisas não iram funcionar, tipo msn, sites de banco: pq eles não entenderiam essas alternancias e acabariam derrubando a sua conexão)
    Se for do seu interesse veja ae como fica.

    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=32.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.4.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=64.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=65.54.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=65.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=66.232.99.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=72.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.101.81.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.201.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.221.2.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.241.42.4/32 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="TESTE LINK2" disabled=no
    add dst-address=200.252.57.4/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK1" disabled=no
    add dst-address=207.46.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=207.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link1" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    / system script
    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    / tool netwatch
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK1-UP \
    down-script=LINK1-DOWN comment="TESTE LINK1" disabled=no
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK2-UP \
    down-script=LINK2-DOWN comment="TESTE LINK2" disabled=no

    Forte Abraço.
    Att.
    Josevaldo

  2. #20

    Padrão

    Para os que tentarem essa opção que postei:
    1º) As rotas são estáticas e estão indicando os links que o msn, orkut, e alguns bancos vão utilizar;
    2º) Os demais acessos vão sair pelo outro link;
    3º) Caso algum link (rota) pare de responder, os acessos a eles serão encaminhados para o outro (pelo script é feito a checagem a cada 10min);
    É isso ae, faço dessa forma para poder continuar usando o web-proxy, caso alguem queria melhorar essas regras favor disponibilizar pra galera.
    Te mais



  3. #21

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    Olá Max,
    demorei um bocado, mas veja se com esses comandos vc resolve seu problema do uso dos dois links:
    P.S.: O que eu tou propondo é o uso dos dois links, tipo o msn, orkut, bancos, vai sair pelo link 2. e o demais pelo link 1 (claro que isso pode ser invertido!). tambem pode-se modificar pra sair os lixos (principalmente os p2p) por um link e o trafego bom pelo outro. As variaveis são inumeras.
    Mas do jeito que está não terá o uso alternado, (uso assim pq tenho o web-proxy e se for alternar, várias coisas não iram funcionar, tipo msn, sites de banco: pq eles não entenderiam essas alternancias e acabariam derrubando a sua conexão)
    Se for do seu interesse veja ae como fica.

    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=32.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.4.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=64.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=65.54.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2 \( MSN \)" disabled=yes
    add dst-address=65.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=66.232.99.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=72.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=64.0.0.0/3 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.101.81.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.201.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.221.2.0/24 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=200.241.42.4/32 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="TESTE LINK2" disabled=no
    add dst-address=200.252.57.4/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK1" disabled=no
    add dst-address=207.46.0.0/16 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=207.0.0.0/8 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link1" disabled=yes
    add dst-address=0.0.0.0/0 gateway=192.168.173.254 scope=255 target-scope=10 \
    comment="link2" disabled=yes
    / system script
    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] disabled=no" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] disabled=yes" \
    policy=ftp,reboot,read,write,test,winbox
    / tool netwatch
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK1-UP \
    down-script=LINK1-DOWN comment="TESTE LINK1" disabled=no
    add host=200.253.251.32 timeout=3s interval=10m up-script=LINK2-UP \
    down-script=LINK2-DOWN comment="TESTE LINK2" disabled=no

    Forte Abraço.
    Att.
    Josevaldo
    como faco pra testar isso e saber se esta funcionando? e minha antiga rota eu apago?

  4. #22

    Padrão

    Olá Maxmelo,
    essas configurações devem ser aplicadas no seu mik, no caso não é um complemento da solução postada aqui, portanto, para testá-la o seu mk deve está funcional, ou seja, deve está permitindo acesso às suas maquinas em um dos links.
    Partindo disso basta ir no terminal e copiar e colar.
    como falei, ele ira dizer as rotas estáticas para o msn, orkut etc... e caso um dos gateway deixe de responder o trafego dele sera desabilitado e o outro assume sozinho.
    qualquer duvida é so dizer



  5. #23

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    Olá Maxmelo,
    essas configurações devem ser aplicadas no seu mik, no caso não é um complemento da solução postada aqui, portanto, para testá-la o seu mk deve está funcional, ou seja, deve está permitindo acesso às suas maquinas em um dos links.
    Partindo disso basta ir no terminal e copiar e colar.
    como falei, ele ira dizer as rotas estáticas para o msn, orkut etc... e caso um dos gateway deixe de responder o trafego dele sera desabilitado e o outro assume sozinho.
    qualquer duvida é so dizer
    Te adicionei no msn me aceita

  6. #24

    Padrão

    Ok!
    os detalhes pormenores a gente discute via msn. e o resultado a gente posta aqui pra que o pessoal do forum que tem o mesmo problema possa tbm saber no que deu essas regras.

    Te amanha.