+ Responder ao Tópico



  1. #1

    Padrão Como marcar arquivos (extensão) - Funciona!!

    Isso mesmo... Consegui uma forma de marcar arquivos pela extenção. Esta regra é util para, por exemplo, dropar extenções conhecidas. No exemplo abaixo, dropamos da nossa rede, todos os arquivos com extenção .scr

    /ip firewall filter
    add chain=input content=.scr action=drop comment="DROPAR ARQUIVOS .SCR" \
    disabled=no

    Estou desenvolvendo uma regra para marcar tipos de arquivos (pela extenção) e redirecioná-los para um link específico ou mesmo, marcar e poder definir quanto de banda aquele arquivo irá ter....

    Pronto! Agora abrimos mais um leque de possibilidades com esta regra...

    PS: Em breve livro de MK (já estou escrevendo).......... Valeuuuuuuuu!!

  2. #2

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Isso mesmo... Consegui uma forma de marcar arquivos pela extenção. Esta regra é util para, por exemplo, dropar extenções conhecidas. No exemplo abaixo, dropamos da nossa rede, todos os arquivos com extenção .scr

    /ip firewall filter
    add chain=input content=.scr action=drop comment="DROPAR ARQUIVOS .SCR" \
    disabled=no

    Estou desenvolvendo uma regra para marcar tipos de arquivos (pela extenção) e redirecioná-los para um link específico ou mesmo, marcar e poder definir quanto de banda aquele arquivo irá ter....

    Pronto! Agora abrimos mais um leque de possibilidades com esta regra...

    PS: Em breve livro de MK (já estou escrevendo).......... Valeuuuuuuuu!!
    kra
    testei essa regra
    e aki nao esta funcionando nao
    sera q estou fazendo algo de errado???



  3. #3

    Padrão Dropar Arquivos

    Cara Coloquei *.src Em Content E Esta Funcionado

  4. #4

    Padrão

    Aqui funcionou certo e quando coloquei o * asterisco pra teste a regra parou de funcionar, se vc estiver rodando proxy na maquina onde esta o mikrotik use input se nao usar proxy use forward, faça o teste mude a extrensão tente por exemplo .swf e tente abrir um site em flash, porem com essas regras senti um pouco de lentidão na rede, e nos meus teste se eu colocar uma palavra por exemplo todo os site que tenha aquela palavra não é aberto parabéns
    Última edição por cleciorodrigo; 17-07-2007 às 19:35.



  5. #5

    Padrão

    testei com varias extençoes e funcionou
    parabens

  6. #6

    Padrão Seu doente...

    Citação Postado originalmente por catvbrasil Ver Post
    Isso mesmo... Consegui uma forma de marcar arquivos pela extenção. Esta regra é util para, por exemplo, dropar extenções conhecidas. No exemplo abaixo, dropamos da nossa rede, todos os arquivos com extenção .scr

    /ip firewall filter
    add chain=input content=.scr action=drop comment="DROPAR ARQUIVOS .SCR" \
    disabled=no

    Estou desenvolvendo uma regra para marcar tipos de arquivos (pela extenção) e redirecioná-los para um link específico ou mesmo, marcar e poder definir quanto de banda aquele arquivo irá ter....

    Pronto! Agora abrimos mais um leque de possibilidades com esta regra...

    PS: Em breve livro de MK (já estou escrevendo).......... Valeuuuuuuuu!!
    To te catando igual um louco.. sera q da pra vc aparecer... liga pro meu cel/rado sei la oq for msn... Consegui a parada do velox pra 8m hiiiiiiiiiiiii agora so vai dar NÓS!!!!!!!

    Ae filho aki ta um problema dos grandes tb... o msn nao para de cair com esse adsl filho, e a regra do DDNS nao ta funfando aparece ai pra trocar uma ideia...

    Abraços filho ahhhhhhhhhhhh ve se nao some... A casa agradece rssssssss



  7. #7

    Padrão

    Pessoal.. tomem cuidade que tem algo de errado com essa regra..
    pois poderá causar muita dor de cabeça,,..

    podem testar.. ativem a regra.. e depois tente abrir algum site como por ex. o da asus.com.tw e depois abra alguma regiao..

    ele nao vai abrir.. como a maioria dos sites..

    me parece que qualquer palavra q contiver o SCR será bloqueada.. entao.. nao da pra colocarmos no servidor sem um estudo mais aprofundado.. da mesma..

    Abraços.. T+

  8. #8

    Padrão

    outra detalhe importante..

    muitos filtros usando a tag de "content" pode deixar a conexao lenta..

    cada pacote o mk precisa efetuar uma comparação usando função regular... e função regular consome alguns % de cp.. dependendo do trafego.. mais problemas...



  9. #9

    Padrão

    Citação Postado originalmente por deivyn Ver Post
    Pessoal.. tomem cuidade que tem algo de errado com essa regra..
    pois poderá causar muita dor de cabeça,,..

    podem testar.. ativem a regra.. e depois tente abrir algum site como por ex. o da asus.com.tw e depois abra alguma regiao..

    ele nao vai abrir.. como a maioria dos sites..

    me parece que qualquer palavra q contiver o SCR será bloqueada.. entao.. nao da pra colocarmos no servidor sem um estudo mais aprofundado.. da mesma..

    Abraços.. T+
    Por isso disse que seve ser colocado .scr (ponto scr). A regra bloqueará tudo com esta extenção. Caso haja bloqueio de .com, você estará bloqueando sites (endereços) e arquivos com .com.... Aqui em testes funcionou perfeitamente, mas deve ser usada com cautela, como qualquer regra de firewall.

  10. #10

    Padrão

    Aqui bloqueio extensões pelo web proxy.

    add url=":\\.sc\[r\]$" action=deny

    A ideia de controlar banda e otima, pricipalmente para lan houses que utilizam links altos e os donos estão sempre fazendo download na hora vaga.



  11. #11

    Padrão Portas Mais usadas por virus

    ip firewall filter

    add chain=input content=.scr action=drop comment="DROPAR ARQUIVOS .SCR" disabled=no
    add chain=input content=.vbs action=drop comment="DROPAR ARQUIVOS .VBS" disabled=no
    add chain=input content=.dat action=drop comment="DROPAR ARQUIVOS .DAT" disabled=no
    add chain=input content=.pif action=drop comment="DROPAR ARQUIVOS .PIF" disabled=no
    add chain=input content=.ini action=drop comment="DROPAR ARQUIVOS .INI" disabled=no
    add chain=input content=.sys action=drop comment="DROPAR ARQUIVOS .SYS" disabled=no
    add chain=input content=.vxd action=drop comment="DROPAR ARQUIVOS .VXD" disabled=no
    add chain=input content=.dll action=drop comment="DROPAR ARQUIVOS .DLL" disabled=no
    add chain=input content=.bat action=drop comment="DROPAR ARQUIVOS .BAT" disabled=no
    add chain=input content=.reg action=drop comment="DROPAR ARQUIVOS .REG" disabled=no
    add chain=input content=.diz action=drop comment="DROPAR ARQUIVOS .DIZ" disabled=no
    add chain=input content=.cpp action=drop comment="DROPAR ARQUIVOS .CPP" disabled=no
    add chain=input content=.cpl action=drop comment="DROPAR ARQUIVOS .CPL" disabled=no

  12. #12

    Padrão

    como disse anteriormente, acho esta pratica problematica, o modulo que usa estas comparacoes (ipt_string) usa função regular (regex) para 'bater' o conteudo do pacote, acrescentando alguns microsegundos de delay em cada pacote, a medida que o trafego aumenta e o tanto de regras também, microsegundos podem virar milisegundos, em alguns casos,, segundos !!

    o ideal para filtrar este tipo de conteudo é utilizar um proxy com o squidguard ou dansguardian, filtrando por mime-type e extensoes (path_regex).. lembrando tambem que squid como filtro perde desempenho no acesso (ver wiki.squid-cache.org)



  13. #13

    Padrão

    E se, em vez de dropar, redirecionar para uma página de aviso?!
    Tem como? Usando NAT, por exemplo?

  14. #14
    Avatar de evil_inside
    Ingresso
    Aug 2004
    Localização
    Bagé, Rio Grande do Sul, Brazil, Brazil
    Posts
    275

    Padrão

    Citação Postado originalmente por kryseck Ver Post
    E se, em vez de dropar, redirecionar para uma página de aviso?!
    Tem como? Usando NAT, por exemplo?
    de qquer forma vai ter q analizar o conteudo dos pacotes
    eu controlo c/ o squid a banda por extensoes, mas fiz um daemon q mede qto ta sendo usada a banda e se tiver mto alta ele substitui o squid.conf e aplica p/ controlar e qdo tem banda sobrando ele deixa liberado