+ Responder ao Tópico



  1. #1
    edgarjr
    Pessoal, estou com o seguinte problema:

    - Fiz uma atualização do iptables da versão 1.3.3 para 1.3.5 e ao reiniciar, começou apresentar vários erros e estava faltando habilitar algumas opções de modulo, habilitei e recompilei e não apresentou erros, MAS não consigo enxergar mais as redes externas e consequentemente navegar, as regras do iptables estão lá, inclusivo de NAT, todas, mas não consigo pingar um site, ou até mesmo o gw de meu servidor, que é o ip válido da internet
    Verifiquei os modulos ativos e estão os mesmos.

    Se volto para o kernel 2.4 que estava antes em meu servidor, funciona normalmente.

    Gostaria de saber se existe alguma particularidade que tenha no kernel 2.6, para que funcione com o IPTABLES 1.3.5 ou superior.

    Desde já agradeço a ajuda.

    Obrigado

  2. nao existem particularidades nao...

    talvez voce esta esquecendo algo na recompilação do kernel.. vi que em alguns casos.. o FULL NAT vem desmarcado no config do kernel



  3. #3
    edgarjr
    Está marcado sim, eu fui fazer uma atualização pelo slackpkg e quando reinicie apareceu várias mensagens, no dns que arrumei e no iptables também arrumei, e compilei novamente o kernel, só que quando está iniciando, o sendmail demora um tempão para iniciar, já começa por ai o problema.

    O que ocorre quando estou com este kernel, é que tenho em meu servidor duas placas de rede, uma com ip para rede interna e outra com o ip válido da internet, aonde meu GW é meu modem, no caso o ip do modem, eu pingo minha rede interna, mas não pingo o meu modem de saida para internet e consequentemente nao navego mais, ou qualquer serviço de internet nao funciona.

    As regras de iptables são as mesmas que funciona com o kernel antigo, 2.4, assim como o iptables também é a mesma versão.
    Tenho os modulos ativo, ip_nat_ftp e ip_conntrack_ftp e o echo 1 > ip_forward, necessário para o nat, mas não consigo achar o problema.

    Quando pingo da a mensagem;
    PING 200.00.00.00 (200.00.00.00) 56(84) bytes of data.
    From 200.00.00.00 icmp_seq=1 Destination Host Unreachable
    From 200.00.00.00 icmp_seq=2 Destination Host Unreachable
    From 200.00.00.00 icmp_seq=3 Destination Host Unreachable

    Se tiver alguma ideia, favor me avisar.

    Obrigado






Tópicos Similares

  1. Problema com iptables no ubuntu10.10
    Por rogerbot no fórum Servidores de Rede
    Respostas: 1
    Último Post: 27-11-2010, 20:48
  2. Problema com Iptables em Cache Server
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 04-10-2003, 00:53
  3. Problemas com IPTABLES
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-07-2003, 16:38
  4. Problemas com IPTABLES
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-06-2003, 10:00
  5. problemas com iptables
    Por no fórum Servidores de Rede
    Respostas: 15
    Último Post: 05-02-2003, 18:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L