+ Responder ao Tópico



  1. #1

    Padrão Meus usuários não tem mais nomes...que sinistro,o que pode ser??

    Estou com um erro muito cabuloso aqui.rodo uns servidores pra estudo e etc,só que do nada meus usuários estão tendo diversos problemas,eles simplemente não possuem um nome.

    olha o prompt como fica:

    I have no [email protected]:~$

    não tem um nome???alguém sabe o que é isso.

    saída do whoami :

    whoami: cannot find name for user ID ...


    meu gnome não loga mais ninguém sem ser pelo modo de segurança.e me traz os erros :

    /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
    /etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xserver s" -h "" -l ":0" "programador"
    /etc/gdm/Xsession: Beginning session setup...
    Could not get password database information for UID of current process:
    User "???" unknown or no memory to allocate pas sword entry

    Failed to start message bus: Memory allocation failure in message bus
    EOF in dbus-launch reading address from bus daemon

    Será que alguém já passou por isso e pode me dar um help aqui?ter que formatar a máquina toda é osso,más vou tentar minha última esperança,já estou umas 5 horas pesquisando e nada.

    As estradas nos /etc/passwd e /etc/group aparentemente estão ok,os usuários existem.
    Última edição por cROMADO; 07-08-2007 às 22:22.

  2. #2

    Padrão

    fala!

    você fez alguma alteração no sistema antes de acontecer isso?
    não conseguiu encontrar nada nos logs?


    abraços



  3. #3

    Padrão

    Caro N3o
    Não fiz nada de excepcional,estou instalando os servidores mais usados e estudando,atualizo sempre a máquina,minhas fontes no source.list são todas "stables" já pra evitar coisas estranhas,é máquina sem frecura,a intenção é manter o mais seguro possível,porém esta zica está zuando o esquema.

    Meus logs :

    tail -f /var/log/messages
    Aug 8 07:18:34 debian kernel: [drm] writeback test succeeded in 1 usecs
    Aug 8 07:18:49 debian gconfd (somebody-2891): iniciando (versão 2.16.1), pid 2891 usuário 'somebody'
    Aug 8 07:18:49 debian gconfd (somebody-2891): Endereço "xml:readonly:/etc/gconf/gconf.xml.mandatory" resolvido para uma fonte de configuração com permissões apenas de leitura na posição 0
    Aug 8 07:18:49 debian gconfd (somebody-2891): O endereço "xml:readwrite:/home/programador/.gconf" resolvido para uma fonte de configuração com permissões de escrita na posição 1
    Aug 8 07:18:49 debian gconfd (somebody-2891): Endereço "xml:readonly:/etc/gconf/gconf.xml.defaults" resolvido para uma fonte de configuração com permissões apenas de leitura na posição 2
    Aug 8 07:18:49 debian gconfd (somebody-2891): Endereço "xml:readonly:/var/lib/gconf/debian.defaults" resolvido para uma fonte de configuração com permissões apenas de leitura na posição 3
    Aug 8 07:18:49 debian gconfd (somebody-2891): Endereço "xml:readonly:/var/lib/gconf/defaults" resolvido para uma fonte de configuração com permissões apenas de leitura na posição 4
    Aug 8 07:18:52 debian gconfd (somebody-2891): O endereço "xml:readwrite:/home/programador/.gconf" resolvido para uma fonte de configuração com permissões de escrita na posição 0


    Depois dos Logs,fui tentar algumas coisas,e vi que não tinha a biblioteca "gconf",então instalei,más não resolveu o problema.

    Vou garimpar na net pra ver se acho alguma coisa relacionada aos logs.

    más preciso de ajuda ainda,o problema persiste.

  4. #4

    Padrão

    o comando whoami motra a UID do usuário logado..

    faça um teste:

    loga 3 ou 4 usuários em shell ou por ssh, depois digita o comando who.. e ao invés do comando whoami, você pode tentar com o comando id -u

    um exemplo de usuário do sistema:

    admin:x:1002:1002:Admin Casa Org.,,,:/home/admin:/bin/bash

    eu nunca vi esse erro, ou ouvi falar, se o sistema é novo, talvez possa ter sido um erro de instalação..

    abraços



  5. #5

    Padrão

    Sem chance veio,acabei formatando,más agora fiz um esquema de particionamento,que caso aconteça esses sinistros,ficará mais fácil restaurar.
    agora vou ficar 2 dias configurando tudo de novo,putz!.

    vlw.

  6. #6

    Arrow

    Aconteceu algo parecido comigo, mas isso ocorreu porque eu acidentalmente apaguei todo os arquivos do /etc. hsuahsuahsauhsuas

    Ab, Duca.