+ Responder ao Tópico



  1. #1
    rafalamana
    Olá pessoal, tudo bem?

    Estou com um problema aqui
    Seguinte, tenho uma aplicação desenvolvida em forms, na minha rede interna ela funciona perfeitamente sem problema algum, já quando tento acesso externo a esta aplicação a mesma demora para conectar e quando conecta abre o software mas os icones dos botões não aparecem e do resto funciona perfeitamente, consigo fazer as consultas no software, cadastro dentre outras aplicações... alguém já passou por isto?


    Obrigado

  2. Bem, por favor passe detalhes do tipo de forms (client/server ou web) e versão do mesmo.

    Se sua aplicação é em forms web (presumo que seja), veja que se funciona na rede interna indica que o arquivo $ORACLE_HOME/forms/java/oracle/forms/registry/Registry.dat

    Está com o parâmetro default.icons.iconpath=http://nome_do_servidor.dominio.com.brorta/forms/icons/

    Correto.

    Porém, como você disse que na rede interna está OK, pode ser que no firewall da empresa (tmbm estou presumindo que exista um) para quem acessa da rede EXTERNA, este servidor tenha um outro nome , então aí os ícones não irão aparecer mesmo, pois o nome do servidor está amarrado no parâmetro acima...

    Citação Postado originalmente por rafalamana Ver Post
    Olá pessoal, tudo bem?

    Estou com um problema aqui
    Seguinte, tenho uma aplicação desenvolvida em forms, na minha rede interna ela funciona perfeitamente sem problema algum, já quando tento acesso externo a esta aplicação a mesma demora para conectar e quando conecta abre o software mas os icones dos botões não aparecem e do resto funciona perfeitamente, consigo fazer as consultas no software, cadastro dentre outras aplicações... alguém já passou por isto?


    Obrigado



  3. #3
    rafalamana
    Citação Postado originalmente por mrpawloski Ver Post
    Bem, por favor passe detalhes do tipo de forms (client/server ou web) e versão do mesmo.

    Se sua aplicação é em forms web (presumo que seja), veja que se funciona na rede interna indica que o arquivo $ORACLE_HOME/forms/java/oracle/forms/registry/Registry.dat

    Está com o parâmetro default.icons.iconpath=http://nome_do_servidor.dominio.com.brorta/forms/icons/

    Correto.

    Porém, como você disse que na rede interna está OK, pode ser que no firewall da empresa (tmbm estou presumindo que exista um) para quem acessa da rede EXTERNA, este servidor tenha um outro nome , então aí os ícones não irão aparecer mesmo, pois o nome do servidor está amarrado no parâmetro acima...

    --


    Olá colega, era isto mesmo, já foi resolvido justamente alterando estas opções do Registry.dat


    (:






Tópicos Similares

  1. Oracle Forms 6i for Linux
    Por mirror no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-10-2003, 12:19
  2. script perl conecta no Oracle 8 mas nao no 9
    Por clever no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-01-2003, 13:56
  3. Oracle 9.0.2 no redhat 7.2´
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 23-12-2002, 10:07
  4. RedHat 7.3 + Oracle
    Por 4ndr3 no fórum Servidores de Rede
    Respostas: 9
    Último Post: 19-12-2002, 14:28
  5. Bco Oracle
    Por joe_fox no fórum Servidores de Rede
    Respostas: 4
    Último Post: 28-11-2002, 09:16

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L