+ Responder ao Tópico



  1. #1

    Padrão Problemas com eth1 (network unreachable)

    Pessoal,

    estou com dois problemas, um é com o eth1 e outro com o outlook de clientes windows...
    mas vamos por partes.
    Estou com um servidor proxy Debian 4 Sarge com duas placas de rede. A eth0 ligada à internet e a eth1 com a LAN.
    Os clientes windows navegam direitinho, o squid está trabalhando direito, mas quando dou ping de uma máquina cliente, da esgotado o tempo limite. Quando dou um ifup no servidor, da network unreachable.
    Minha eth0 está com ip 10.1.1.2/255.255.255.0 e eth1 com ip 10.1.2.1/255.255.255.0.
    Problema 2, o outlook das máquinas windows não conecta. Será que é devido ao problema com eth1?
    No servidor só tenho o squid rodando e já tirei as regras do firewall e mesmo assim o outlook não conecta.
    Alguém pode me dar uma força?

    Valeu!

  2. #2

    Padrão

    primeiro caso:

    Você está pingando de onde pra onde? está pingando de uma maquina da LAN para um IP na internet? Sua NAT está configurada direitinho?

    Até onde eu saiba o "ifup" é para levantar a interface de rede, ele já não está levantada? porque você está tentando levanta-la novamente?

    Segundo caso:

    Pode está relacionado com o primeiro problema sim, especialmente se a NAT não estiver configurada.

    ate+



  3. #3

    Padrão

    Não pode esquecer do net.ipv4.ip_forward=1 também, no sysctl.conf.

  4. #4

    Padrão

    joseguilherme,

    então, o problema com a eth1, vem desde a inicialização. ele configura...

    kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
    kernel: eth1: link up, 100Mbps, full-duplex, lpa 0x45E1

    mas não sobe...

    SIOCADDRT: Network is unreachable
    Failed to bring up eth1.

    quando dou ifconfig, o resultado é esse:

    eth0 Link encap:Ethernet HWaddr 00:19:5B:89:0F:8F
    inet addr:10.1.1.2 Bcast:10.1.1.255 Mask:255.255.255.0
    inet6 addr: fe80::219:5bff:fe89:f8f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:598 errors:0 dropped:0 overruns:0 frame:0
    TX packets:548 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:332788 (324.9 KiB) TX bytes:119270 (116.4 KiB)
    Interrupt:10 Base address:0x6800

    eth1 Link encap:Ethernet HWaddr 00:19:5B:89:14:AF
    inet addr:10.1.2.1 Bcast:10.1.2.255 Mask:255.255.255.0
    inet6 addr: fe80::219:5bff:fe89:14af/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1500 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1452 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:208623 (203.7 KiB) TX bytes:667721 (652.0 KiB)
    Interrupt:11 Base address:0x6c00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:37 errors:0 dropped:0 overruns:0 frame:0
    TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4192 (4.0 KiB) TX bytes:4192 (4.0 KiB)

    quando dou ifup na eth0, diz que já está configurada e quando dou ifup na eth1, diz:

    SIOCADDRT: Network is unreachable
    Failed to bring up eth1.

    O que posso ter feito de errado?
    Quanto ao /etc/network/interfaces tenho o seguinte:

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 10.1.1.2
    netmask 255.255.255.0
    network 10.1.1.0
    broadcast 10.1.1.255
    gateway 10.1.1.1

    auto eth1
    iface eth1 inet static
    address 10.1.2.1
    netmask 255.255.255.0
    network 10.1.2.0
    broadcast 10.1.2.255
    gateway 10.1.1.2

    E aí... me ajuda a resolver?

    Valeu!



  5. #5

    Padrão

    czaja

    O erro está na seguinte configuração que você mandou:

    auto eth1
    iface eth1 inet static
    address 10.1.2.1
    netmask 255.255.255.0
    network 10.1.2.0
    broadcast 10.1.2.255
    gateway 10.1.1.2

    Veja que você indicou o gateway como sendo "gateway 10.1.1.2" e o IP como sendo "address 10.1.2.1", pela mascara indicada o seu gateway não está na mesma rede do ip da eth1, por isso que ele diz que a rede não pode ser alcançada, provavelmente é só isso o erro.

    Se você esta configurando essa maquina como servidor, então ela vai ser o proprio gateway e sendo assim você não precisa indigar o gateway para essa interface.

    Espero ter ajudado.

    ate+