+ Responder ao Tópico



  1. Galera, estou tentando compilar o IPTABLES, pois acabei de instalar o Kernel com suporte a PSD e Layer7.
    Mas quando peço para compilar, chega uma parte que dá esse erro:

    libipq/libipq.c: In function âipq_set_vwmarkâ:
    libipq/libipq.c:372: error: âIPQM_VWMARKâ undeclared (first use in this function)
    libipq/libipq.c:372: error: (Each undeclared identifier is reported only once
    libipq/libipq.c:372: error: for each function it appears in.)
    libipq/libipq.c:375: error: âunion <anonymous>â has no member named âvwmarkâ
    libipq/libipq.c:376: error: âunion <anonymous>â has no member named âvwmarkâ
    libipq/libipq.c:377: error: âunion <anonymous>â has no member named âvwmarkâ
    libipq/libipq.c:378: error: âunion <anonymous>â has no member named âvwmarkâ
    make: *** [libipq/libipq.o] Error 1
    rm libiptc/libip4tc.o libiptc/libip6tc.o

    E para por ai. O que pode ser esse erro?

  2. Citação Postado originalmente por durban Ver Post
    libipq/libipq.c: In function âipq_set_vwmarkâ:
    libipq/libipq.c:372: error: âIPQM_VWMARKâ undeclared (first use in this function)
    libipq/libipq.c:372: error: (Each undeclared identifier is reported only once
    libipq/libipq.c:372: error: for each function it appears in.)
    libipq/libipq.c:375: error: âunion <anonymous>â has no member named âvwmarkâ
    Todos são erros de programção. O primeiro diz que o programador usou uma variável sem declara-la. O segundo diz que a estrutura de dado usada não possui o campo âvwmarkâ.

    Esses problemas podem ser de incompatibilidade dessa versão do código do iptables com o seu kernel. Procure no netfilter.org os requisitos dessa versão do iptables. Podem também ser erros dos programadores, mas acho muito improvável.



  3. Olha, não sei o que tem nessa versão do IPTABLES-1.3.8, mas a 1.3.7 ele não me deu erro. Estou usando OpenSUSE 10.2 e compilando Kernel 2.6.18.2

    Quando alguem descobrir o que pode estar acontecendo, poste ai para poder atualizar!!!!!

    Aproveitando, alguem sabe quais são as melhorias do 1.3.8 sobre o 1.3.7 ??????

  4. Como eu disse, pode estar relacionado com a versão do seu kernel. Cheque as incompatibilidades dos pacotes que vc utilizou. Todos os modulos do iptables mantém um documento entitulado INCOMPATIBILITIES. Pode ser uma boa fonte de informação.

    No ftp do netfilter.org tem a lista de mudanças. Adianto que as mudanças do 1.3.7 para 1.3.8 não são significativas o bastante para você fazer a atualização do seu sistema.

    Consegui compilar utilizando o kernel 2.6.22.5 no slackware.
    http://ftp.netfilter.org/pub/iptable...-1.3.8.tar.bz2






Tópicos Similares

  1. Erro na compilação do Iptables
    Por slice no fórum Servidores de Rede
    Respostas: 3
    Último Post: 28-07-2006, 17:56
  2. Compilação do IPTABLES 1.3.5
    Por celsoboy no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-06-2006, 10:37
  3. Problemas na compilacao do pam_mysql
    Por danielssribeiro no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-03-2005, 15:20
  4. Problema na compilação do iptables-p2p
    Por Daniels no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-10-2004, 16:39
  5. Problema na compilaçao do kernel 2.6.7!
    Por nozey no fórum Servidores de Rede
    Respostas: 7
    Último Post: 03-08-2004, 19:28

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L