+ Responder ao Tópico



  1. #1

    Padrão Erro no squid após atualização para versão 2.6

    Meu squid foi atualizado para versão 2.6 e agora está apresentando o erro abaixo ao acessar sem estar com as conexões de lan(proxy configurada), nesse caso aparece esse erro:

    The following error was encountered:
    Invalid Request
    Some aspect of the HTTP Request is invalid. Possible problems:
    Missing or unknown request method
    Missing URL
    Missing HTTP Identifier (HTTP/1.0)
    Request is too large
    Content-Length missing for POST or PUT requests
    Illegal character in hostname; underscores are not allowed
    Your cache administrator is root.
    __________________

  2. #2

    Padrão

    Código :
    $ cat /var/log/messages

    poste aqui a saída do comando



  3. #3

    Padrão

    Opa cara, obrigado por ter respondido...deixa eu te explicar: eu estava com squid 2.5 tenho uma acl chamada "no_auth " que tem vários sites que os inspetores que outros paises que quando vem na empresa acessam pois não querem que mexa no notebook deles....e depois de atualizado, está acontecendo esse erro, agora se ru marcar as configurações do proxy no navegador, os sites dessa acl são acessados normalmente etnão segue lá o que vc pediu:

    Sep 3 19:24:30 localhost -- MARK --
    Sep 3 19:44:30 localhost -- MARK --
    Sep 3 20:04:30 localhost -- MARK --
    Sep 3 20:24:30 localhost -- MARK --
    Sep 3 20:44:30 localhost -- MARK --
    Sep 3 21:04:30 localhost -- MARK --
    Sep 3 21:24:30 localhost -- MARK --
    Sep 3 21:44:30 localhost -- MARK --
    Sep 3 22:04:30 localhost -- MARK --
    Sep 3 22:24:30 localhost -- MARK --
    Sep 3 22:44:30 localhost -- MARK --
    Sep 3 23:04:30 localhost -- MARK --
    Sep 3 23:24:30 localhost -- MARK --
    Sep 3 23:44:30 localhost -- MARK --
    Sep 4 00:04:31 localhost -- MARK --
    Sep 4 00:24:31 localhost -- MARK --
    Sep 4 00:44:31 localhost -- MARK --
    Sep 4 01:04:31 localhost -- MARK --
    Sep 4 01:24:31 localhost -- MARK --
    Sep 4 01:44:31 localhost -- MARK --
    Sep 4 02:04:31 localhost -- MARK --
    Sep 4 02:24:31 localhost -- MARK --
    Sep 4 02:44:31 localhost -- MARK --
    Sep 4 03:04:31 localhost -- MARK --
    Sep 4 03:24:31 localhost -- MARK --
    Sep 4 03:44:31 localhost -- MARK --
    Sep 4 04:04:31 localhost -- MARK --
    Sep 4 04:24:31 localhost -- MARK --
    Sep 4 04:44:31 localhost -- MARK --

  4. #4

    Padrão

    ta usando squid transparent ?

    voce configurou o http_port para transparente ?

    Código :
    http_port 3128 transparent



  5. #5

    Padrão

    então, um amigo me disse isso ontem pois mesmo que o proxy seja autenticado como meu caso, tem que usar o transparent.mas mesmo asim obrigado.