+ Responder ao Tópico



  1. #1

    Thumbs up Controle de banda por MAC address

    Salve, salve galera!!

    Todos os meus clientes possuem AP's, e no APRouter eu faço o controle de banda pelo MAC do AP cliente, então se o cara coloca outra máquina naquele AP, a banda para os dois continua sendo a mesma...

    Estive procurando no Fórum, mas, no MK, sempre encontrei controle de banda por IP. Agora vem o problema... se eu deixo por ip então duas maquinas em um mesmo cliente, pagando uma mensalidade, estarão usando bandas normais.

    o que eu queria fazer é o seguinte:
    colocar o mac do AP cliente e configurar um controle de banda apenas, pois se o cara colocar dez máquinas lá, o problema é dele...

    Então, teria como eu colocar controle de banda por mac no MK?

  2. #2



  3. #3

    Talking Colega

    Citação Postado originalmente por efren Ver Post
    Pow Galera ajuda nóis!!
    Eis o problema o wap pro gerará ips por dhcp se o ap estiver como cliente do teu ap e estiver ativado. os ips gerados no ap cliente navegaram por fora na tua rede e voce nao terá copntrole.
    Aqui uso o bfw crio as suredes e ele que faz o controle de banda
    Exemplo crio uma sub rede para aquele ap com 10 ips logo ele pode colacar dentro desta rede 10 maquinas logo com velocidade total pra divididr de 150 kbps.

    Ele então tera 15kbps pra cada maquina se estiverem todas ligadas simultanemantes.

  4. #4

    Padrão

    Essa subrede que vc mencionou não pode ser feita com o MK? já que o mesmo possui todas as caracterísitcas de rede que o BFW também possui.


    valeu!!



  5. #5

    Padrão Acho

    Não teria esta resposta pra te dar.

    Aqui uso assim

    bfw servidor e router controle de mac amarrado ao ip -
    Ap como brigte tranparente
    aps clientes como brigdte transparente.

    Bfw gera e gerencia os ips por dhcp
    Acredito que o mikrotik deva fazer, tranquilo

  6. #6

    Padrão Resolvido

    Cara obrigado pela ajuda, mas acho que já resolvi esse problema.

    Eu uso em meus clientes apenas AP's ovislink, o novo firmware deste ap vem com a opção de WISP, então o AP cliente gerencia a rede interna do cliente, configurado como gateway, enquanto o MK cuida apenas do ip da interface wireless do ap, então eu posso dar o controle de banda pelo ip, amarrando o MAC ao mesmo...

    Não se se é a melhor forma, mas por enquanto está dando resultado.

    Obrigado pela ajuda, e continue assim cara, pois não aderi a sua sugestão mas vc me deu um norte, ou seja, como comessar...


    Valeu mesmo!!



  7. #7

    Padrão

    Citação Postado originalmente por efren Ver Post
    Salve, salve galera!!

    Todos os meus clientes possuem AP's, e no APRouter eu faço o controle de banda pelo MAC do AP cliente, então se o cara coloca outra máquina naquele AP, a banda para os dois continua sendo a mesma...

    Estive procurando no Fórum, mas, no MK, sempre encontrei controle de banda por IP. Agora vem o problema... se eu deixo por ip então duas maquinas em um mesmo cliente, pagando uma mensalidade, estarão usando bandas normais.

    o que eu queria fazer é o seguinte:
    colocar o mac do AP cliente e configurar um controle de banda apenas, pois se o cara colocar dez máquinas lá, o problema é dele...

    Então, teria como eu colocar controle de banda por mac no MK?
    Como fazer controle banda por MAC ?!

    For download:

    1. connection-mark all packets from the MAC of each client with different marks
    for each client using action=passthrough:
    /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
    action=mark-connection new-connection-mark=host11 passthrough=yes

    2. Remark these packets with flow-mark (again different flow-marks for each connection-marks):
    /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11

    3. We can use these flow-marks in queue trees now.

    While this solution should function, it is fundamentally flawed as the first packet of each connection destined to these clients will not be taken into account.

    For upload:

    [[email protected]] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
    action=mark-packet new-packet-mark=upload

  8. #8

    Padrão

    brother é simples, coloca o ap's em bridge e o ip e mac do cliente serão o da placa de rede cabeada dele, você pode colocar 10 clientes, mas o ap em bridge cada um terá seu mac e ip da placa de rede cabeada.



  9. #9

    Padrão

    É, mas em bridge para repassar os macs só funciona se a conexão do ap com o mk for em ap+wds.