Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico





  1. Bem vamos comecar mais uma vez, talvez alguem me de uma luz:

    É o Seguinte, preciso montar uma estrutura com Linux para servir de Access Point. Meu material:


    3 Maquinas com 3(1 em cada) GWL520(atheros)
    1 Ponto de Rede
    3 antenas de 18dbi omni 360

    Todas as maquinas rodando debian 4.0

    Certo vamos as configuracoes

    Maquina 1 - Modo AP ok. (AQUI É ONDE TEMOS O PONTO DE REDE)
    Maquina 2 – Modo AP ok.
    Maquina 3 – Modo AP ok.


    As placas estão em modo Bridge e estão funcionando ok.

    O meu problema, como vocês viram eu possuo somente 1 ponto de rede na estrutura, e tenho um problema o que devo fazer, quando o cara vem com o laptop dele lá, ele acha somente o AP3, o AP3 tem que mandar ele para o ip para pegar o ip, será que tem jeito de fazer isso??


    Fica assim:
    (REDE - BRIDGE)
    Laptop ---- AP3 ---- AP1 ---- servidor DHCP.
    | |
    +--- FLUXO TCP/IP ------------+



    é Tipo fazer um brigde entre os APS...


    Abracos

  2. Olá amigo, não sei bem como fazer isso nesse hardware que você passou, mas o micro ligado a rede deve ser configurado como Acess point, e os outros dois devem ser configurados como WDS usando o mesmo canal e frequência. Espero não estar enganado nas opções....



  3. Olá amigo,

    já está assim mas nao funcionou. Ele nao deixa pegar o DHCP ..

    A maquina está como AP(bridge) pega ip do meu DHCP windows 2003, ou seja, ele melhora o sinal, melhora tudo mas nao faz o bridge que eu estava esperando hehehe...

    Eu fiz assim:

    Maquina 1 - AP E WDS
    Maquina 2 - WDS e AP
    Maquina 3 - WDS e AP

    Vou ter que sair agora mas ja ja coloco as configuracoes aqui.

  4. Olá,

    Conforme prometido estou aqui postando tudo... hehehe

    As configuracoes que eu fiz nas maquinas.... veja ai se alguem pode me ajudar:


    #### Maquina 1
    ==============

    # Colocando modo AP
    modprobe -r ath_pci
    modprobe ath_pci autocreate=ap
    iwpriv ath0 maccmd 3
    iwpriv ath0 maccmd 0
    iwconfig ath0 essid REDE_WDS channel 11
    iwconfig ath0 rate 11M
    iwpriv ath0 bgscan 0

    # Criando a bridge
    brctl addbr br0
    brctl addif eth0
    brctl addif ath0

    wlanconfig ath create wlandev wifi0 wlanmode wds
    iwpriv ath1 wds_add 00:00:00:00:22
    iwpriv ath1 wds 1
    iwpriv ath0 wds_add 00:00:00:00:22
    iwpriv ath0 wds 1

    brctl addif ath1

    ifconfig eth0 0.0.0.0
    ifconfig ath0 0.0.0.0
    ifconfig ath1 0.0.0.0
    ifconfig br0 10.2.0.7 netmask 255.255.0.0
    route add default gw 10.2.0.2


    #### Maquina 2
    ==============

    # Colocando modo AP
    modprobe -r ath_pci
    modprobe ath_pci autocreate=wds
    iwpriv ath0 maccmd 3
    iwpriv ath0 maccmd 0
    iwconfig ath0 essid REDE_WDS channel 11
    iwconfig ath0 rate 11M
    iwpriv ath0 bgscan 0

    # Criando a bridge
    brctl addbr br0

    wlanconfig ath create wlandev wifi0 wlanmode ap
    iwpriv ath1 wds_add 00:00:00:00:11
    iwpriv ath1 wds 1
    iwpriv ath0 wds_add 00:00:00:00:11
    iwpriv ath0 wds 1

    brctl addif ath0
    brctl addif ath1

    ifconfig ath0 0.0.0.0
    ifconfig ath1 0.0.0.0
    ifconfig br0 0.0.0.0



    #### Maquina 3
    ==============

    # Colocando modo AP
    modprobe -r ath_pci
    modprobe ath_pci autocreate=wds
    iwpriv ath0 maccmd 3
    iwpriv ath0 maccmd 0
    iwconfig ath0 essid REDE_WDS channel 11
    iwconfig ath0 rate 11M
    iwpriv ath0 bgscan 0

    # Criando a bridge
    brctl addbr br0

    wlanconfig ath create wlandev wifi0 wlanmode ap
    iwpriv ath1 wds_add 00:00:00:00:11
    iwpriv ath1 wds 1
    iwpriv ath0 wds_add 00:00:00:00:11
    iwpriv ath0 wds 1

    brctl addif ath0
    brctl addif ath1

    ifconfig ath0 0.0.0.0
    ifconfig ath1 0.0.0.0
    ifconfig br0 0.0.0.0


    Valeu pela força.



  5. Pessoal Obrigado pela ajuda ae...
    Consegui fazer mas mudei algumas coisa por varios motivos o principal foi por questão de Segurança.

    Como a rede vai ficar aberta para clientes(terá cadastrado mac e senha WPA gerada por mac), mesmo assim fiquei com medo de algum engracadim fazer alguma cagada, resolvi mudar minha rede ficando assim com 1 rede somente para os notebooks.

    Segue abaixo o procedimento que fiz:

    Maquina 1
    =======
    # Colocando modo AP
    ifconfig br0 down
    ifconfig ath0 down
    ifconfig ath1_rename down
    modprobe -r ath_pci
    modprobe ath_pci autocreate=ap
    echo 1 > /proc/sys/net/ipv4/ip_forward
    brctl delbr br0
    iwpriv ath0 maccmd 3
    iwpriv ath0 maccmd 0
    iwconfig ath0 essid UNIALUNOS channel 11
    iwconfig ath0 rate 11M
    iwpriv ath0 bgscan 0
    ifconfig ath0 0.0.0.0

    wlanconfig ath create wlandev wifi0 wlanmode wds
    iwconfig ath1_rename channel 11
    iwpriv ath1_rename wds_add 00:00:00:00:22
    iwpriv ath1_rename wds 1
    iwpriv ath0 wds_add 00:00:00:00:22

    iwpriv ath0 wds 1
    brctl addbr br0
    brctl addif br0 ath1_rename ath0
    #brctl addif br0 ath0
    ifconfig ath1_rename 0.0.0.0
    ifconfig br0 192.168.0.1 netmask 255.255.0.0
    ifconfig br0 up
    /etc/init.d/dhcp3-server start


    Maquina 2
    ======
    ifconfig br0 down
    ifconfig ath0 down
    ifconfig ath1_rename down
    modprobe -r ath_pci
    modprobe ath_pci autocreate=ap
    echo 1 > /proc/sys/net/ipv4/ip_forward
    brctl delbr br0
    iwpriv ath0 maccmd 3
    iwpriv ath0 maccmd 0
    iwconfig ath0 essid UNIALUNOS channel 11
    iwconfig ath0 rate 11M
    iwpriv ath0 bgscan 0
    ifconfig ath0 0.0.0.0
    wlanconfig ath create wlandev wifi0 wlanmode wds
    iwconfig ath1_rename channel 11
    iwpriv ath1_rename wds_add 00:00:00:00:11
    iwpriv ath1_rename wds 1
    iwpriv ath0 wds_add 00:00:00:00:11
    iwpriv ath0 wds 1
    brctl addbr br0
    brctl addif br0 ath1_rename ath0
    ifconfig ath1_rename 0.0.0.0


    Na maquina 2 digito para ver quem esta conectado

    Placa em modo WDS:
    ==============

    linuxap:~# wlanconfig ath1_rename list
    ADDR AID CHAN RATE RSSI DBM IDLE TXSEQ RXSEQ CAPS ACAPS ERP STATE MODE
    00:00:00:00:11 1 11 5M 10 -85 0 3160 18304 FA 0 1 Normal


    Placa em modo AP:
    ============
    linuxap:~# wlanconfig ath0 list
    ADDR AID CHAN RATE RSSI DBM IDLE TXSEQ RXSEQ CAPS ACAPS ERP STATE MODE
    (meu notebook) 00:11:f5:1a:f2:55 1 11 11M 48 -47 120 13 3024 ESs F 0 25 Normal ATH




    Entao funcionou, se alguem precisar de ajuda, posso ajudar... a sim a maquina 3, eu so adicionei o wds 2 e 3 para as outras maquinas.

    Estou a disposicao ai no msn s3ri4l@hotmail.com






Tópicos Similares

  1. tranformar linux num access point wireless
    Por marina no fórum Redes
    Respostas: 6
    Último Post: 03-06-2009, 06:03
  2. Access Point do Linux
    Por Carlos Renato no fórum Redes
    Respostas: 5
    Último Post: 23-03-2006, 09:11
  3. Access Point LG LW2205 AP
    Por Quick-Silver no fórum Redes
    Respostas: 6
    Último Post: 19-01-2005, 16:40
  4. Access Point da SENAO
    Por Cleber Luis no fórum Redes
    Respostas: 33
    Último Post: 05-01-2005, 12:13
  5. Access Points - Marcas/Modelos
    Por mistymst no fórum Redes
    Respostas: 11
    Último Post: 11-09-2004, 18:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L