Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Smile Acessando o BD do mikritik

    bom pessoal , andei pensando esses dias se teria como ter acesso ao banco de dados do mikrotik...

    será que seria possivel..

    caso seje alguem saberia as portas para acessar.


    obrigado...

  2. #2

    Padrão

    Banco De Dados Do Mikrotik?:????
    Fantastico....
    Tenta Com Mysql, Derrepente Vc Consegue...



  3. #3

    Padrão

    Citação Postado originalmente por fbig Ver Post
    Banco De Dados Do Mikrotik?:????
    Fantastico....
    Tenta Com Mysql, Derrepente Vc Consegue...
    Sempreee tirando onda com os colegas do forum nao é mesmo rapaz?
    sempre,,,,

  4. #4

    Padrão

    Citação Postado originalmente por dragon1910 Ver Post
    bom pessoal , andei pensando esses dias se teria como ter acesso ao banco de dados do mikrotik...

    será que seria possivel..

    caso seje alguem saberia as portas para acessar.


    obrigado...
    ola amigo, acho que voce está se referindo a arquivos de configs, scripts, etc,,
    jah li no forum a respeito disso, e dizem,, q nao é possivel esse procedimento!

    t+ vlw



  5. #5
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    o maximo que consegui acessar ate hj foi atraves de ftp so isso nada demais ....
    sera que tem algum script dentro dele que bloqueia?

    ate acho que ele e escondido pela intencao de nao modificarmos nao e verdade?
    abracos...

  6. #6

    Padrão

    se vc montar um hd com mk instalado em um servidor linux.. vc pode acessar oque quiser



  7. #7
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    vc ja fez alguma alteracao nele Kilder?

  8. #8

    Padrão

    bom minha ideia era se fosse possivel acessar o mikrotik, desenvolver um sistema para controle de usuarios gerenciamento em geral, por exe: o cliente está mais de 10 dias em atrazo. o sistema bloquear automatico, sem a gente ir la no servidor para bloquear ele ...



  9. #9
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    cara acredito que alguem do forum ja tem um programa que conversa com o mik pra fazer isso....
    abracos....

  10. #10

    Padrão

    contornei o problema da seguinte forma:

    estou desenvolvendo um sistema em PHP + mysql pra controlar os clientes, maquinas ips, nós de redes, abertura de chamadas de manutencao, financeiro

    e para conversar com o mikrotik é simples, basta fazer o PHP escrever um script conforme suas necessasidades em um arquivo, e fazer upload pelo FTP do mikrotik

    no mikrotik um scheduler de 5 em 5 minutos verificando se há o arquivo, se existir rodar ele, no script pode conter qualquer tipo de acao para o mikrotik



  11. #11

    Smile

    bom , sua ideia é execelente , mais temos que meio nija o mikrotik para saber os comandos e escrever os scripts.

    por exemplo se eu quiser so alterar o banda de um determinado cliente, eu não saberia o comando nem de alterar e deletar... dai vai ficar um pouco mais complicado para escrever os scripts.. ha não ser qua alguem ai do forum tenha todos os comando do mikrotik como altera, adicionar excluir etc..

  12. #12

    Padrão

    Citação Postado originalmente por undrtkr Ver Post
    contornei o problema da seguinte forma:

    estou desenvolvendo um sistema em PHP + mysql pra controlar os clientes, maquinas ips, nós de redes, abertura de chamadas de manutencao, financeiro

    e para conversar com o mikrotik é simples, basta fazer o PHP escrever um script conforme suas necessasidades em um arquivo, e fazer upload pelo FTP do mikrotik

    no mikrotik um scheduler de 5 em 5 minutos verificando se há o arquivo, se existir rodar ele, no script pode conter qualquer tipo de acao para o mikrotik
    Olá undrtkr

    Gostaria que vc coloca-se um exemplo um script só para termos ideia... exemplo script para cadastro de mac na accesslist, ativar ou desabilitar uma regra... ou qq outro script só para termos uma ideia...

    Preciso urgente desenvolver algumas soluções como esta php+mysql controlando financeiro e gerenciando a parte de cadastro de user no mkt e bloqueando inadimplentes... hj isto eh feito + tdo manual

    abraço a todos

    Alexandre
    CaracolNET



  13. #13

    Thumbs down

    Citação Postado originalmente por fbig Ver Post
    Banco De Dados Do Mikrotik?:????
    Fantastico....
    Tenta Com Mysql, Derrepente Vc Consegue...
    Concordo com o amigo aqui..Afinal você entrou nesse forum com a finalidade de aprender, então realmente deve ter aprendido algo, e acho que você não deveria zombar de quem não sabe tanto quanto você.


    Se observar você nunca agradeceu a ninguém, mas com certeza recebeu alguma orientação de alguém...

    que tal rever conceitos?

    Boa tarde para você!

  14. #14

    Padrão

    bom pessoal to patinando aki para achar alguma documentação sobre o mikrotik que informe os comando como eu citei acima para altera excluir etc..

    mais to na luta assim que eu achar alguma coisa vou postar aki no forum para que todos façam uso da documentação e ampliem seus conhecimentos..



  15. #15

    Padrão

    bom pessoal achei algums comando para excluir e editar as regras do mikrotik via escript e pront de comando vou postar aki a apostila..
    Miniaturas de Anexos Miniaturas de Anexos Introducao-Mikrotik.pdf  

  16. #16
    Avatar de evil_inside
    Ingresso
    Aug 2004
    Localização
    Bagé, Rio Grande do Sul, Brazil, Brazil
    Posts
    275

    Padrão

    você pode dar comandos utilizando php, seria isso:

    Código :
    $IpMikrotik = "IP";
    $ComandoMikrotik="/ip firewall filter add chain=forward src-address=10.0.0.2/32 action=drop";
     
    $Comando="ssh [email protected]$IpMikrotik '".$ComandoMikrotik."'";
    system("$Comando");



  17. #17

    Padrão

    poderia ser , mais eu estava pensando em desenvolver um soft para gerenciar os clientes e interagir com o mikrotik ... tipo o cliente naum pago o sistema cortar automatico , ou seja passou numero X de dias o sistema gerar um script e enviar para o mikrotik com os comando de bloqueio... e assim por diante..

  18. #18

    Padrão

    Citação Postado originalmente por fbig Ver Post
    Banco De Dados Do Mikrotik?:????
    Fantastico....
    Tenta Com Mysql, Derrepente Vc Consegue...
    Não sei porque tirar onda assim, se nem escrever direito você sabe... DERREPENTE vc descubra isso com o nosso amigo Aurélio...



  19. #19

    Smile

    ai pessoal descobri um script para alterar qualque regra do mikrotik...

    / system script
    add name="queue_disable" source="/queue simple { set \[find \
    name=fulano_de_tal\] max-limit=256000/128000}" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    esse script localiza o nome na lista da queue e altera de acordo com os parametro que vc queira colocar...

    espero que seja ultuil essa regra... t+

  20. #20

    Padrão

    bom pessoal descrobri uns comando via terminal para altera e remove regras do mikrotik... ai vam elas

    alterar exemplo de regra..

    /queue simple

    set [find name="nome do cliente"] max-limit=128000/512000
    este comando altera a regra que contem o nome indicado...

    remover as regras..

    / queue simple

    remove [find name="nome do cliente"]
    esta serve para remover o cliente... ou quaquer outra regra cadastrada ono mk ..