+ Responder ao Tópico



  1. #1

    Padrão Entregando ip valido via pppoe com Myauth

    e ai galera....

    seguinte, recebi 128ips validos. AI SIMM HEM!!! rss

    enfim, utilizo o slackware 10 com o myauth.
    eu vi no site do myauth q da pra entregar ips validos tipo direto no cliente nas conf da rede dele, sendo assim ele vai fica com um ip valido fixo.

    e da tbm pra mandar via pppoe, dinamico, cada conexao o cliente pega um ip diferente valido.

    ambos tenho q criar uma rota no roteador, utilizo um cisco 2500. Criar a rota nele eh facil, eu consigo.

    a duvida eh a seguinte,,,, eu queria entregar via pppoe, soh q tipo vo ter q cadastrar o ip invalido na placa, e na hora q o cliente disca pppoe ele vai pega o valido, soh q se o cliente nao disca pppoe, sera q ele vai conseguir navegar soh com o invalido!!!

    eu nao manjo muito de radius, alguem pode me dar uma ajuda, alguem usa o myauth e entrega ip valido!???

    aguardo, obrigado....

  2. #2

    Padrão

    nao precisa cadastrar o ip invalido nao... so colocar no cadastro de usuarios o ip valido.. que o pppoe faz o resto !!!



  3. #3

    Padrão Não consigo fazer conexão PPoe

    Oi, coloegas vcs que utilizam conexão PPoe no myauth, poderiam me dar um ajuda pois não consigo de maneira nenhum fazer que uma conexão estabeleça, pois semprea dar senha ou usuario invalido, poderiam me falar como vcs utilizam para que eu possa fazer aqui, ja testei via cabo e não deu certo, eu urilizo chave de rede isso atrapanha, ja desabilitei para teste e nada, utilizo umas WRAP com Ikarus, aguardo retorno, é verdade que a conexão PPOe utiliza muito recursos de memoria e processador?

  4. #4

    Padrão

    Citação Postado originalmente por agnaldos Ver Post
    Oi, coloegas vcs que utilizam conexão PPoe no myauth, poderiam me dar um ajuda pois não consigo de maneira nenhum fazer que uma conexão estabeleça, pois semprea dar senha ou usuario invalido, poderiam me falar como vcs utilizam para que eu possa fazer aqui, ja testei via cabo e não deu certo, eu urilizo chave de rede isso atrapanha, ja desabilitei para teste e nada, utilizo umas WRAP com Ikarus, aguardo retorno, é verdade que a conexão PPOe utiliza muito recursos de memoria e processador?
    olha, eu vou começar a mecher agora com o pppoe no myauth + ip valido.

    e realmente nao precisa cadastrar o ip invalido na placa..... mais tipo pra vc rodar o pppoe vc tem q configurar o radius no seu server, no caso do myauth, configurar no slackware, q eh a plataforma q o myauth roda.

    tem um tuto do proprio patrick msm
    Linux: Freeradius - servidor radius eficiente e completo [Artigo]

    agora tipo nunca coloquei pra funcionar, mais vou colocar, assim q der certo posto alguma coisa.



  5. #5

    Padrão

    aqui funciona tranquilo o pppoe com ip valido !

  6. #6

    Padrão

    mais vc criou uma rota no roteador, e tipo no myauth vc cadastra as pessoas com o ip valido msm!???

    eu to um pouco perdido nisso, tipo eu crio uma rota no roteador utilizando um ip valido, pro server funcionar com 2 ips de saida, um exclusivo do gateway myauth fazendo um nat pros clientes, e outra soh pra trafega os ips validos.

    ai tipo, configuro o freeradios, e ai eu cadastro os clientes no myauth msm!??? essa parte q eu nao to sabendo.......

    vc pode me passar o esqueminha de como vc fez pra funcionar o pppoe com o myauth fornecendo ips validos?? valeu obrigado



  7. #7

    Padrão

    vc precisa criar uma rota estatica no router para o segundo bloco.. apontando o nexthop dele para o ip do seu servidor que ta myauth.. feito isso.. eh so configurar normal

  8. #8

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    vc precisa criar uma rota estatica no router para o segundo bloco.. apontando o nexthop dele para o ip do seu servidor que ta myauth.. feito isso.. eh so configurar normal
    deixa eu ve se entendi......
    meu servidor hj ele tem o ip valido ex: 201.1.10.1 e ai faz uma nat e entrega por ip invalido pra cada cliente.

    bom quero entregar ip valido por pppoe!!!!!
    ai eu vou e configuro o servidor radius no slackware, tenho q configurar manualmente pois o myauth nao vem configurado, soh o ip do radios e a senha q esta configurada no myauth. No caso configuro o radios no ip 127.0.0.1 e a senha raioceleste.

    ai depois disso, eu tenho q liberar no roteador um ip valido pra cada cliente, no exemplo o cliente zé vai fica com o ip valido 201.1.10.15

    ai eu vou no roteador e crio uma rota:
    Destino: 201.1.10.15 q eh o ip do zé
    Máscara 255.255.255.252 q eh a mascara da minha classe de ip fornecida pelo link
    Gateway: 201.1.10.1 q eh o ip do server

    ai la no myauth, cadastro ele normalmente com o mac, e no lugar do ip eu coloco esse ip valido 201.1.10.15 e determino a velocidade de conexao dele, ai ele disca via pppoe e o myauth joga ele na rede com o ip valido 201.1.10.15!!!!!???? eh isso msm??

    ou eu tenho q criar um login e senha no servidor radius com esse ip tbm, e depois novamente no myauth!?????

    ai tipo pra cada cliente por ip valido eu tenho q criar uma nova rota no roteador!!!!

    se caso nao me explique como!!!!!
    Aguardo,,,, e obrigado.......

    abraço



  9. #9

    Padrão

    na verdade eh o seguinte.. o seu roteador precisa saber onde esta o ip valido para o cliente...

    supondo q vc tenha:

    200.200.200.0/24 .. seu roteador eh 200.200.200.1 seu servidor gateway eh 200.200.200.2 !!

    no roteador vc precisa dividir o bloco /24 em 2 partes .. ficando assim:

    bloco 1-> 200.200.200.0/25
    bloco 2-> 200.200.200.128/25

    o primeiro bloco vc nao precisa alterar nada apenas alterar a mascara la no roteador... de 255.255.255.0 para 255.255.255.128

    feito isso.. adicione uma rota estatica para o segundo bloco:

    ip route 200.200.200.128 255.255.255.128 200.200.200.2

    feito isso.. o roteador ja sabe por onde chegar no segundo bloco..

    ai no seu servidor.. vc vai ter:

    eth0: 200.200.200.2 netmask 255.255.255.128
    eth1: 200.200.200.129 netmask 255.255.255.128
    gateway DO servidor é: 200.200.200.1 (o roteador, normal)

    agora la no seu cliente... ficaria:

    200.200.200.130 mascara 255.255.255.128 gateway 200.200.200.129 !!!

    para usar isto no pppoe.. basta colocar o ip valido no cadastro para o pppoe dar este ip (independente do gateway)... que vai funcionar : )

  10. #10

    Padrão

    ok Alexandre, desculpe por encher seu saco mais uma vez!!! mais agora entendi e soh quero tirar algumas duvidas.

    no caso entao no roteador, eu mudo apenas a mascara, de 255.255.255.248, eu passo pra 255.255.255.128 e aponto pro servidor.

    ai crio a segunda rota, com outro ip valido com mascara 255.255.255.128 apontando pro server tbm.

    ate ai ta legal, soh q ai no server, eu vou ter duas rotas no eth1, q eh a invalida q nao vao ser tds os clientes q vao receber ips validos, e a rota valida tbm na eth1.

    ai no caso, configuro outra rota no server, e nas interfaces fico com 2 rotas de saida eth1, e 1 de entrada eth0.

    ai nas configuraçoes do pppoe no myauth eu mudo alguma coisa!? tipo em ips inicial e final eu coloco ips invalidos msm??? dns eu coloco o dns da minha rede,,,,
    o servidor radius jah ta configurado com o myauth, preciso mudar alguma coisa!??
    e por ultimo la em redes autenticadas, eu crio uma rota dos ips validos, e coloco como Roteavel!??? ou nao preciso fazer nada?

    valeu, abraçoss



  11. #11

    Padrão

    ok Alexandre, desculpe por encher seu saco mais uma vez!!! mais agora entendi e soh quero tirar algumas duvidas.
    sem problemas

    no caso entao no roteador, eu mudo apenas a mascara, de 255.255.255.248, eu passo pra 255.255.255.128 e aponto pro servidor.
    é mais ou menos, vai depender do SEU bloco de ips que a operadora te liberou, estas mascaras que usei foram exemplos... se voce tiver um bloco que eh so 255.255.255.248 .. aconselho voce nao mexer nele e pedir um bloco adicional para sua operadora pois esta mascara 255.255.255.248 repartida em 2.. vai liberar apenas 2 ips para cada parte ..

    ai crio a segunda rota, com outro ip valido com mascara 255.255.255.128 apontando pro server tbm.

    ate ai ta legal, soh q ai no server, eu vou ter duas rotas no eth1, q eh a invalida q nao vao ser tds os clientes q vao receber ips validos, e a rota valida tbm na eth1.

    ai no caso, configuro outra rota no server, e nas interfaces fico com 2 rotas de saida eth1, e 1 de entrada eth0.

    ai nas configuraçoes do pppoe no myauth eu mudo alguma coisa!? tipo em ips inicial e final eu coloco ips invalidos msm??? dns eu coloco o dns da minha rede,,,,
    o servidor radius jah ta configurado com o myauth, preciso mudar alguma coisa!??
    e por ultimo la em redes autenticadas, eu crio uma rota dos ips validos, e coloco como Roteavel!??? ou nao preciso fazer nada?

    valeu, abraçoss
    esquece a parte de ip invalido..

    voce vai precisar cadastrar o segundo bloco no myauth la em redes autenticadas.. e na opção "tipo de rede" voce escolhe "roteavel"..

    vou te dar outro exemplo.. supondo que voce tenha este bloco:

    200.200.200.0/255.255.255.248 (voce tem 8 ips.. 6 que pode usar)

    no seu router vai ficar assim:

    ip da LAN: 200.200.200.1 mascara 255.255.255.252
    a vai ter uma rota assim:
    ip route 200.200.200.4 255.255.255.252 200.200.200.2

    a LAN do seu roteador esta ligada na ETH0 do seu gateway.. entao o ip da eth0 vai ser:
    200.200.200.2 mascara 255.255.255.252 e o gateway do seu gateway vai ser o router (200.200.200.1)

    agora.. a eth1 voce tem a rede interna.. entao voce coloca este ip nela:
    200.200.200.5 mascara 255.255.255.252

    ok !! agora LAH no seu cliente.. vc coloca:

    200.200.200.6 mascara 255.255.255.252 e o gateway 200.200.200.5

    note que.. voce quebrou o bloco antigo em 2 partes .. a cada 'quebra' que vc faz em uma subnet.. voce perde 2 ips (ip para o start-net q é sempre o PRIMEIRO ip.. e o broadcast que eh sempre o ultimo ip da subnet)

    neste exemplo .. vc ficou com 2 redes

    200.200.200.0/30 (que vai de 200.200.200.0 ate 200.200.200.3) sendo o .0 o start-net e o .3 o broadcast.. sobrando o .1 e o .2 para usar..

    200.200.200.4/30 (vai de 200.200.200.4 ate 200.200.200.7) sendo o .4 o start-net e o .7 o broadcast sobrando o .5 e .6 para voce usar..


    entao.. supondo que voce tenha um bloco 255.255.255.248 (/29) .. vc vai ter utilizado os ips TODOS se fizer isto.. e nao vai ter mais NENHUM ip valido disponivel..

    solicite um bloco de 32 ou 64 ips.. ai voce nao vai precisar nem quebrar o seu 248 !! vc vai apenas adicionar uma rota estatica para o NOVO bloco.. e jogar este novo bloco INTEIRO para dentro da sua rede..

    ai quando conseguir isso.. la no myauth eh simples.. eh cadastrar o bloco como roteavel.. e no pppoe naquela parte de intervalo de ips.. voce pode deixar do jeito q vc usa.. que o pppoe se vira... bastanto alterar APENAS o ip la no cadastro do USUARIO !!


  12. #12

    Padrão

    ok alexandre,,, realmente eu recebi os 120 td em um bloco soh, pois a mascara continua sendo a msm, procurei nos meus emails e achei a planilia dos 120 ips, e tipo continua no 255.255.255.248.

    vou solicitar uma divizao de blocos, tipo 2 blocos de 64 ips.

    eu entendi agora totalmente, mais eu nao posso esquecer dos ips invalidos pois alguns clientes ainda vao ficar na nat, e vao receber ips invalidos.

    eu vou criar uma rota com um ip valido nela, e vou cadastrar ela nas interfaces do myauth, ai eu fico com uma placa de rede na eth1 soh q com duas saidas, com ip valido e invalido.

    valeu msm alexandre pela sua grande ajuda, estou muito grato.

    Abraçossss



  13. #13

    Padrão

    nao precisa solicitar divisao de ip nao.. voce mesmo divide no seu router !!

    para 128 ips a mascara é 255.255.255.128 geralmente a ebt entrega 2 blocos de 64 ips .. mascara 255.255.255.192

  14. #14

    Padrão

    entao soh q o meu nao eh embratel, eh telefonica msm, to com 4mb e eles me deram 128 ips, e vao liberar mais 64 ips.

    nao manjo muito do cisco, eu sei tipo configura ele pro link.... sei cria rota, mais alguma coisas q tem no site do myauth no artigo do cisco.......

    mais consigo me virar,,,,, jah esta td bem claro.... esse fds vou fazer o teste sem criar uma segunda rota, no roteador, soh pra fazer um teste.....