+ Responder ao Tópico



  1. olá amigos do forum

    fiz um balanceamento usando NTH com 2 link, aparentemente ta funcionando mas tenho um duvida que é a seguinte:
    fiz 2 lista, os que conectam na lista 1 vai p/ o link 1 e ganha um Ip 192.168.2.x
    e os que conectam na lista 2 esta aparecendo com 2 IPs repetidos, EX:

    Lista_1 - 192.168.2.5 <===esse tá ok indo p/ link-1
    Lista_1 - 192.168.2.6
    Lista_2 - 192.168.2.6 entrou na Lista_2 mas ta repetindo o IP na Lista_1)
    Lista_1 - 192.168.2.7 <===esse tbm ta ok, ta saindo pelo link-1
    Lista_1 - 192.168.2.8
    Lista_2 - 192.168.2.8 <==repetindo novamente na lista_1
    e assim por diante
    Alguem ja teve esse problema ??
    segue abaixo o codigo
    abraço

    / ip firewall mangle
    add chain=prerouting connection-state=new src-address-list=Lista_1 in-interface=wireless action=mark-connection new-connection-mark=con_1 passthrough=yes
    add chain=prerouting in-interface=wireless connection-mark=con_1 action=mark-routing new-routing-mark=rota_1

    add chain=prerouting connection-state=new src-address-list=Lista_2 in-interface=wireless action=mark-connection new-connection-mark=con_2 passthrough=yes
    add chain=prerouting in-interface=wireless connection-mark=con_2 action=mark-routing new-routing-mark=rota_2

    add chain=prerouting action=mark-connection new-connection-mark=con_1 passthrough=no connection-state=new in-interface=wireless nth=1,1,0
    add chain=prerouting in-interface=wireless connection-mark=con_1 action=add-src-to-address-list address-list=Lista_1 address-list-timeout=03:00:00 passthrough=yes
    add chain=prerouting in-interface=wireless connection-mark=con_1 action=mark-routing new-routing-mark=rota_1 passthrough=no

    add chain=prerouting action=mark-connection new-connection-mark=con_2 passthrough=no connection-state=new in-interface=wireless nth=1,1,1
    add chain=prerouting in-interface=wireless connection-mark=con_2 action=add-src-to-address-list address-list=Lista_2 address-list-timeout=03:00:00 passthrough=yes
    add chain=prerouting in-interface=wireless connection-mark=con_2 action=mark-routing new-routing-mark=rota_2 passthrough=no


    /ip firewall nat
    add chain=srcnat connection-mark=con_1 action=src-nat to-addresses=201.41.154.10 to-ports=0-65535
    add chain=srcnat connection-mark=con_2 action=src-nat to-addresses=10.1.1.2 to-ports=0-65535

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.41.154.9 routing-mark=rota_1
    add dst-address=0.0.0.0/0 gateway=201.14.31.254 routing-mark=rota_2

  2. na verdade o NTH eh randomico..

    ele pega os pacotes ou sources.. e vai jogando uma hora pra um.. outra pra outro...

    o que vc pode fazer eh marcar os ips dos clientes.. (packet mark e connection mark).. e fazer o desvio pelas marcacoes

    acho que assim eh mais seguro..






Tópicos Similares

  1. Balanceamento de carga com Apache e Jboss
    Por victorit no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-07-2016, 09:03
  2. Balanceamento de carga entre links com iproute2 - mini-howto
    Por PEdroArthurJEdi no fórum Servidores de Rede
    Respostas: 33
    Último Post: 29-10-2011, 21:55
  3. Respostas: 2
    Último Post: 20-05-2009, 10:43
  4. balanceamento de carga com win xp pro?
    Por GUSTAVOCIDADE no fórum Redes
    Respostas: 11
    Último Post: 06-05-2008, 13:07
  5. Respostas: 1
    Último Post: 16-08-2006, 09:08

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L